Car Audio, Video & Mobile Electronics Forum
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    1. Announcement:
      Help with New Account Activations
      chris@swedespeed (Administrator)
      02-13-2017
      Views:
      3,170
    Page 1 of 3 1 2 3 LastLast
    Threads 1 to 30 of 77

    Forum: Car Audio, Video & Mobile Electronics Forum

    This area is dedicated to all general discussion concerning car audio & video equipment, installations and applications.

    1. Sticky Thread Sticky: Sensolutions' iMIV video iPod Multi-Media Melbus Module

      Started by mrg_Ed 01-13-2005 01:53 PM
      41 Pages
      1 2 3 ... 41
      • Replies: 1,405
      • Views: 777,283
      09-11-2016, 11:24 PM Go to last post
    2. Sticky Thread Sticky: Audio Forum FAQs and DIYs - READ THIS FIRST

      Started by chris@swedespeed 03-02-2007 06:55 AM
      • Replies: 3
      • Views: 13,112
      05-30-2016, 11:00 AM Go to last post
    3. Exclamation Sticky Thread Sticky: iMIV and new iPods (iPhone)

      Started by iMIV Support 09-24-2007 05:35 PM
      2 Pages
      1 2
      • Replies: 43
      • Views: 31,146
      08-29-2013, 11:35 AM Go to last post
      • Replies: 0
      • Views: 12
      06-22-2017, 12:08 AM Go to last post
    1. S80 2003 radio trouble poss. replacement.

      Started by Onisan69 06-13-2017 02:18 PM
      • Replies: 0
      • Views: 30
      06-13-2017, 02:18 PM Go to last post
      • Replies: 0
      • Views: 32
      06-12-2017, 10:07 PM Go to last post
    2. Noise from the speakers

      Started by Racerxc70 06-11-2017 05:35 PM
      • Replies: 2
      • Views: 46
      06-12-2017, 07:35 PM Go to last post
    3. Installation of BLP-990 Headunit Troubleshoot

      Started by lynxjava 02-13-2016 06:10 AM
      • Replies: 12
      • Views: 4,310
      05-31-2017, 07:07 PM Go to last post
    4. No Sound: HU-850

      Started by EnterTheR 11-11-2011 01:06 PM
      2 Pages
      1 2
      • Replies: 41
      • Views: 28,153
      05-23-2017, 07:43 AM Go to last post
    5. play music from iphone7 in 2009 xc70

      Started by otismodelle 04-25-2017 04:12 PM
      • Replies: 1
      • Views: 99
      05-15-2017, 04:49 PM Go to last post
    6. Simple popup navi retrofit

      Started by Aysientor 05-12-2017 01:10 AM
      • Replies: 0
      • Views: 97
      05-12-2017, 01:10 AM Go to last post
    7. Will Sirius From 07 S80 work in 08 XC90

      Started by Tommm 05-05-2017 05:32 PM
      • Replies: 0
      • Views: 62
      05-05-2017, 05:32 PM Go to last post
    8. Wrong Navigation Location

      Started by DLEastwood 04-27-2017 06:59 PM
      • Replies: 1
      • Views: 107
      05-05-2017, 12:22 PM Go to last post
    9. 2017 XC90 navigation and in-car apps stop working

      Started by rickgu 05-05-2017 12:10 PM
      • Replies: 0
      • Views: 53
      05-05-2017, 12:10 PM Go to last post
    10. "New" 2008 XC70 w Premium Sound...help

      Started by collindaly 04-28-2017 11:30 AM
      • Replies: 0
      • Views: 89
      04-28-2017, 11:30 AM Go to last post
    11. Test question

      Started by gunnar_melby 04-28-2017 08:18 AM
      • Replies: 0
      • Views: 43
      04-28-2017, 08:18 AM Go to last post
    12. 2008 s80 speaker depth and sizes

      Started by Jroo 04-25-2017 03:03 PM
      • Replies: 0
      • Views: 65
      04-25-2017, 03:03 PM Go to last post
    13. Problems accessing Tunein

      Started by BillFerg 04-22-2017 09:13 PM
      • Replies: 4
      • Views: 126
      04-23-2017, 10:50 PM Go to last post
    14. '05 VR switched power issue

      Started by MileHighR 04-11-2017 12:56 PM
      • Replies: 0
      • Views: 82
      04-11-2017, 12:56 PM Go to last post
    15. Bluetooth for 2001 V70

      Started by SteveP 04-07-2017 02:27 PM
      • Replies: 0
      • Views: 106
      04-07-2017, 02:27 PM Go to last post
      • Replies: 1
      • Views: 159
      04-02-2017, 09:55 PM Go to last post
      • Replies: 3
      • Views: 277
      03-26-2017, 04:35 PM Go to last post
    16. Apple CarPlay

      Started by KCCM 12-29-2015 12:28 PM
      • Replies: 5
      • Views: 1,006
      03-21-2017, 06:15 PM Go to last post
      • Replies: 4
      • Views: 968
      03-18-2017, 07:06 PM Go to last post
    17. SC-710 Tape Not Playing

      Started by Dustboy 03-16-2017 06:35 PM
      • Replies: 0
      • Views: 77
      03-16-2017, 06:35 PM Go to last post
    18. Exclamation Bluepower BLP-890 and my 2004 S60R

      Started by GiRaff3 09-14-2009 09:11 AM
      • Replies: 31
      • Views: 12,839
      03-12-2017, 03:14 PM Go to last post

    Page 1 of 3 1 2 3 LastLast

    Forum Information and Options

    Moderators of this Forum

    Thread Display Options

    Use this control to limit the display of threads to those newer than the specified time frame.

    Allows you to choose the data by which the thread list will be sorted.

    Order threads in...

    Note: when sorting by date, 'descending order' will show the newest results first.

    Icon Legend

    Contains unread posts
    Contains unread posts
    Contains no unread posts
    Contains no unread posts
    Closed Thread
    Thread is closed
    Thread Contains a Message Written By You
    You have posted in this thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •