Search Results - Swedespeed
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Search:

    Type: Posts; User: notreadytorock

    Search: Search took 0.02 seconds.

    1. Replies
      6
      Views
      166

      At this point, with all of the issues I've had...

      At this point, with all of the issues I've had with my car, I just want to fix it long enough to save up some money to trade it in and be done with this godforsaken car.
    2. Replies
      6
      Views
      166

      Unfortunately I do not have a vida, and even...

      Unfortunately I do not have a vida, and even worse, the closest dealership tends to be less than cooperative.
    3. Replies
      6
      Views
      166

      Car stalling randomly

      Hello all. Having trouble with my S40 again. It keeps stalling on me randomly, no check engine light, but i still have a code P0629 "OBD-II Trouble Code: Fuel Pump "A" Control Circuit High." Once I...
    4. Replies
      29
      Views
      778

      It was spinning. My fear was the loud banging...

      It was spinning. My fear was the loud banging from the rear was the haldex unit dying or something.

      Sent from my SM-G920V using Tapatalk
    5. Replies
      29
      Views
      778

      The rear wheels don't move when I put it up in...

      The rear wheels don't move when I put it up in the air. The first clue was all the wheel spin I get that I didn't get before the noise started, then stopped.

      There are a lot of parts on this...
    6. Replies
      29
      Views
      778

      AWD Not Engaging

      So I looked all over to see if someone else has had this issue, but I couldn't find any answers. I have a '05 S40 T5 with a 6-speed and AWD. About a year ago, I started hearing a loud bang noise...
    7. Replies
      104
      Views
      10,055

      I had the same issue as you described after I...

      I had the same issue as you described after I replaced all of my fuel stuff, but now that the weather is colder it starts no problem when the engine is cold, it was only when it was 80+ degrees that...
    8. I replaced everything last night. Didn't use a...

      I replaced everything last night. Didn't use a microrachet, but went in without incident (aside from dropping one T-25 torx bit into the abyss) only took about an hour and half. I still should...
    9. I got the key out! It took a lot of wiggling, but...

      I got the key out! It took a lot of wiggling, but it happened! It's not going back in until I replace the SCU.
    10. How much did your dealership charge you for...

      How much did your dealership charge you for everything, if I may ask?
    11. Mercdude, so you're saying that if I only have...

      Mercdude, so you're saying that if I only have one key for my car, I may want to get a new key first before replacing the SCU? My key is stuck in the ignition, car works fine. I was hoping I could...
    12. Replies
      104
      Views
      10,055

      Well, hopefully it stays this way. Thank you all...

      Well, hopefully it stays this way. Thank you all for the assistance.
    13. Replies
      104
      Views
      10,055

      New PEM is in. Fuel pressure went up from 37-38...

      New PEM is in. Fuel pressure went up from 37-38 psi to 43-44 psi. It's at about 60 psi at start up. Drove around for about two hours, no stalling, no trouble starting it back up on multiple...
    14. Replies
      104
      Views
      10,055

      I just love how two issues that were covered by...

      I just love how two issues that were covered by extended warranty occurred at the same time as soon as the car hit its 11th year. It's almost as of Volvo planned it.
    15. Replies
      104
      Views
      10,055

      So, I ordered a "new" PEM from xemodex, since I...

      So, I ordered a "new" PEM from xemodex, since I live in Buffalo, and it snows, a lot, so even if it isn't the problem, it will be eventually. We'll see what happens.
    16. Replies
      104
      Views
      10,055

      No CEL, but P0628 "fuel pump "A" control circuit...

      No CEL, but P0628 "fuel pump "A" control circuit low" and P0627 "fuel pump " A" control circuit/open" came up on my torque app.
    17. Replies
      104
      Views
      10,055

      That's worth a shot. At this point, I just want...

      That's worth a shot. At this point, I just want it running well enough to get rid of it.
    18. Replies
      104
      Views
      10,055

      Used the correct pressure sensor. Torque app was...

      Used the correct pressure sensor. Torque app was reading the high pressure as well and mechanical tester and the computer read the same thing. The seafoam was with a full tank of 93 octane. The PEM...
    19. Replies
      104
      Views
      10,055

      It's a brand new fuel pressure sensor, replaced...

      It's a brand new fuel pressure sensor, replaced it 4 days ago when it was suggested here.
    20. Replies
      104
      Views
      10,055

      Fuel pressure is 38 psi idling, but when the pump...

      Fuel pressure is 38 psi idling, but when the pump starts making its buzzing noise, it goes up to 80 psi.
    21. Replies
      104
      Views
      10,055

      That's what I've been leaning towards as well.

      That's what I've been leaning towards as well.
    22. Replies
      104
      Views
      10,055

      In the fuel.

      In the fuel.
    23. Replies
      104
      Views
      10,055

      So an update: It died on me again yesterday, and...

      So an update: It died on me again yesterday, and I had a check engine light. Rented a fuel pressure tester and a OBDII scanner. I had five codes, 2 for random multiple misfire,2 for misfure in cyl 1,...
    24. Replies
      104
      Views
      10,055

      Connector was good. I think it's doing better. I...

      Connector was good. I think it's doing better. I hope it was just the seafoam loosening up crap which ended up clogging something until it broke up. It seems the more I drive it today the better it...
    25. Replies
      104
      Views
      10,055

      Got the a sensor in, got the seafoam in, and now...

      Got the a sensor in, got the seafoam in, and now it keeps stalling on me. Which isn't enjoyable and it didn't do that before.
    26. Replies
      104
      Views
      10,055

      Welp, bought a new sensor, bought a can of...

      Welp, bought a new sensor, bought a can of seafoam. Ironically, it wouldn't start when I went to leave the local autozone. So hopefully this does the trick. Oddly enough, my troubles started when my...
    27. Replies
      104
      Views
      10,055

      Even though the pump sounds like crap?

      Even though the pump sounds like crap?
    28. Replies
      104
      Views
      10,055

      Hello, I'm new here. I've been having an issue...

      Hello, I'm new here. I've been having an issue with my 05 S40 T5. It'll usually start on the first try when the engine is cold, but will be "laggy" when I first start accelerating, and will randomly...
    Results 1 to 28 of 28