Gear indication- service required
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Welcome to SwedeSpeed
    You're currently browsing Swedespeed as a guest. Please sign up or sign in and take part in the conversation with other Volvo owners and enthusiasts. With more 2 million posts our community is one of the most active groups of Volvo owners in the world. Take a moment to sign up and enjoy all of the features our forums have to offer.
    Results 1 to 9 of 9
    1. #1
      Member d3box1's Avatar
      Join Date
      Mar 2010
      Location
      Barrington, RI
      Posts
      1,000

      Gear indication- service required

      hey, im getting a wierd warning on my s40- Just like the title of the thread "gear indication- service required"
      I drive a 2005 t5 (automatic) and i just got the car so its still under warrenty so i would like to check it out -

      some problems ive noticed include but are not limited to getting stuck in N aswell as when using the triptronic feature when i downshift (say im in gear 3 going 20mph) there is a lag in switching then a clunking noise.

      Is the tranny failing here? anybody else having these problems? J.w im going to take it to a shop in the mean time but a headsup would be nice-

      Thanks

      BLACK 13' HYUNDAI GENESIS 2.0T - CURRENT 05' S40T5A BLACK BLISTEN/ EIBACH/ OBX/ ELEVATE/ K&N/ EST/ BSR SOLD- 98' S70T5A STOCK BLUE "A luxury car should drive itself"

    2. #2

      Re: Gear indication- service required (d3box1)

      Did you ever find out the answer to this one. Mine just started doing the same thing. I have 46,000 miles on the car.

    3. #3
      I don't know why Volvo does not call for a fluid flush on their AT's, just because it's a closed system doesn't mean you forgo a fluid flush every 30K, by 30K it's gonna be pretty dark if not black, it's the heat that kills it. I'm not an expert on AT's, but I've rebuilts lot's of motorcycle front ends (another closed system) and and I change the oil out in those every 10K and it's nasty by then.

    4. #4

      Re: Gear indication- service required (d3box1)

      Well, I changed out the GSM and all is well.

    5. #5
      Junior Member ion's Avatar
      Join Date
      Jul 2009
      Location
      MD
      Posts
      453

      Re: Gear indication- service required (rayrayb)

      GSM being?

      So you don't have the "Gear indication - service required" warning anymore? What about the downshifting from 3rd to 2nd clunking noise, did you have that? And did replacing the GSM, whatever that is, fix the clucking noise?


    6. #6
      Member d3box1's Avatar
      Join Date
      Mar 2010
      Location
      Barrington, RI
      Posts
      1,000

      Re: Gear indication- service required (ion)

      i know what you mean about the clunking- the way to avoid it is on the gtec just switch back to d then to ----> gtec. I no longer have that (info) message and i didnt do anything, it just went away, weird.

      and i have no idea what GSM is lol

      BLACK 13' HYUNDAI GENESIS 2.0T - CURRENT 05' S40T5A BLACK BLISTEN/ EIBACH/ OBX/ ELEVATE/ K&N/ EST/ BSR SOLD- 98' S70T5A STOCK BLUE "A luxury car should drive itself"

    7. #7
      Junior Member ion's Avatar
      Join Date
      Jul 2009
      Location
      MD
      Posts
      453

      Re: Gear indication- service required (d3box1)

      I found a related thread when searching for the clunking issue: http://forums.swedespeed.com/zerothread?id=74333

      Apparently there was a software update that fixes the problem.


    8. #8

      Re: Gear indication- service required (d3box1)

      The GSM - Gear Selector Module.

    9. #9

      Re: Gear indication- service required (d3box1)

      I never had the clunking noise. I did however have my shifter lock into position twice.