AM radio not working
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Welcome to SwedeSpeed
    You're currently browsing Swedespeed as a guest. Please sign up or sign in and take part in the conversation with other Volvo owners and enthusiasts. With more than 2 million posts our community is one of the most active groups of Volvo owners in the world. Take a moment to sign up and enjoy all of the features our forums have to offer.
    Results 1 to 5 of 5
    1. #1
      Junior Member
      Join Date
      Apr 2007
      Location
      Sydney
      Posts
      223

      AM radio not working


      Problems in paradise.

      the other day I had problems with the AM radio (i listen to talkback radio - i know i know some of you will say its probably a plus - but i miss it) it was cutting in and out like the radio was broken.

      then today I was going on a three hour drive somewhere and no AM radio. I turned up the volume and pressed different channels and not a peep. then i press the FM button and hey presto there's sound (and plenty of it).

      then press AM and it ceases.

      anyone got any ideas.

      cheers
      Hatdriver


    2. #2
      Junior Member
      Join Date
      Jun 2006
      Location
      calgary
      Posts
      956

      Re: AM radio not working (Hatdriver)

      P2 wagons had issues with the antennae ground. Interference is the biggest issue. The rear window antennae sucks for am reception.

    3. #3
      Junior Member
      Join Date
      Apr 2007
      Location
      Sydney
      Posts
      223

      Re: AM radio not working (ktm_525)

      Hi,

      I received an email from Mark H. suggesting it could be the radio module. I took it to the dealer and he was aware of a number of other identical problems i.e. am seems to operate with bad reception, then goes off completely. I will have to wait for a few weeks before the new module come in.

      cheers


    4. #4

      Re: AM radio not working (Hatdriver)

      Quote, originally posted by Hatdriver »

      the other day I had problems with the AM radio (i listen to talkback radio - i know i know some of you will say its probably a plus - but i miss it) it was cutting in and out like the radio was broken.
      cheers
      Hatdriver

      I had a similar problem. The AM antenna is built into the driver's side cargo area window on my car (passenger side on yours). Look for the window that has wires embeded in it.

      Under the trim along the top edge of the window, there is a snap connector (similar to a 9v battery) that connects the window antenna to the system. Mine has popped off a couple of times. Snap it back it place.

      This worked for me, hopefully it will solve your problem.


    5. #5
      Junior Member
      Join Date
      Apr 2007
      Location
      Sydney
      Posts
      223
      Further to my am radio not working it is now repaired. they did in fact have to change the whole radio unit. Seems the am board (I think he said) burns out and so the unit is not repairable as the am is built in. Alot of radios have been reported as malfunctioning across the lines, c30, v70, xv70, xc90.

      Cheers