"Top is Unlocked" message again.
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Welcome to SwedeSpeed
    You're currently browsing Swedespeed as a guest. Please sign up or sign in and take part in the conversation with other Volvo owners and enthusiasts. With more 2 million posts our community is one of the most active groups of Volvo owners in the world. Take a moment to sign up and enjoy all of the features our forums have to offer.
    Results 1 to 4 of 4
    1. #1
      Junior Member
      Join Date
      May 2008
      Location
      Staten Island, New York
      Posts
      179

      "Top is Unlocked" message again.

      First TSB fix did not work last week. Message has returned, and eventually Top Malfunction message comes on. Can't open trunk either. Frustrating and back to service again this week. Best weekend of the year probably and I can't use the hardly used as it is convertible!

    2. #2
      Junior Member
      Join Date
      May 2008
      Location
      Staten Island, New York
      Posts
      179

      Angry All "fixes" have failed. Now what?

      Every attempt to fix the top has failed so far: TSB done, then supposedly a bad sensor, and same message back today and it's back in the shop...3rd time in less than 2 weeks. Today they told me they are stumped and haven't a clue. Said maybe electrical, maybe wiring harness. After testing all day, they said they have to contact Tech Support because they have run dry in ideas to fix it.

      Dealer has been very nice though and I haven't lost it yet but this is the 2nd best weekend and I'm without the car again. Every time I got back in after the "fix", I was waiting for the charming beep indicating Top Malfunction, Top is Unlocked, etc.

      I'm losing faith that this problem will be fixed. I smell the NY Lemon Law coming even though I'm 3 weeks too late. I will fight because with the Top Malfunction, the car is undriveable. I have 3k miles to date in 2 yrs.

    3. #3
      I had a failed Hall sensor about a year ago (replaced under warranty - took 3 days of work!)
      It only affected the roof lock if I used the shift out of the boot (=trunk) with the roof folded.

    4. #4
      Junior Member
      Join Date
      May 2008
      Location
      Staten Island, New York
      Posts
      179
      I was told on Saturday that they found a frayed wire in the wiring harness and have repaired the wire. I know the rerouting of the wiring harness was an issue in the 2007's, not the 08's. They said it's a defect from the factory and I would have had the fault much earlier on had I used the car more.

      They kept the car for the weekend to test drive it, and probably cruise around, but they do not want to give it back to me until they are absolutely certain the problem is resolved.