Bluepower BLP-890
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Welcome to SwedeSpeed
    You're currently browsing Swedespeed as a guest. Please sign up or sign in and take part in the conversation with other Volvo owners and enthusiasts. With more 2 million posts our community is one of the most active groups of Volvo owners in the world. Take a moment to sign up and enjoy all of the features our forums have to offer.
    Results 1 to 9 of 9
    1. #1

      Bluepower BLP-890

      I am about to purchase a BLP-890 from a member on here. Have done some serious poking around and reading and am curious what I should look out for in buying one used? How can i tell from photos which version the unit is? Also, is there specialized mounting hardware that i need to be sure is included so the unit sits flush and looks OEM?

      Here is a link to the sellers ad:
      http://forums.swedespeed.com/showthr...-Headunit-04-R



      Thanks guys!
      2004 MT SR Black Saph/Atacama

    2. #2
      Member LOGBOMB's Avatar
      Join Date
      Jul 2009
      Location
      Old Saybrook, CT
      Posts
      1,333

      Bluepower BLP-890

      Don't do it. I bought one during the GB. and it has been the single most disappointing piece of crap in my car. Spend the money on a pioneer or kenwood double din with nav etc.
      2004 S60R, black sapphire, nordikap, M66, Autotech Stage2, K&N, 3" DP, EST catback w/ EST res delete, viva HD CBV,viva FMIC, TWM short shift, snabb intake pipe, TME springs, IPD track spec sways.

    3. #3
      Not sure about the 890 and I'm relatively new to Blupower, but the short amount of time I've had my 840 I think it's ok. While I thought it was slick at first, it's now annoying me because of poor fm reception, volume control makes crackling sound when adjusted. I'm going to have it looked at by a pro to see what can be done. Good luck with yours

    4. #4
      Quote Originally Posted by LOGBOMB View Post
      Don't do it. I bought one during the GB. and it has been the single most disappointing piece of crap in my car. Spend the money on a pioneer or kenwood double din with nav etc.
      What types of issues did you encounter?

    5. #5
      I was waiting for a shipping price etc before we finalized everything but the more I read on this unit the less I could justify spending hundreds of dollars on it. I do trust the seller that it is in working order to his knowledge, but with the unresponsiveness of Bluepower I am concerned that if anything did go wrong I would have no way to troubleshoot it. I will just stick with ordering a GROM unit for less and get the bare essentials that I wanted- hands free calling and Iphone play ability.
      2004 MT SR Black Saph/Atacama

    6. #6
      Junior Member
      Join Date
      Aug 2010
      Location
      central nj
      Posts
      437
      The BLP-840/890 units were hit or miss. Some people have units tha work just like they were designed to. Some people (ususally the most vocal) never had their units work correctly. Whether this be poor installtion or poor product, I think you would be better off getting a custom system or using a GROM unit.

      My unit works as it should and looks great in the car. It is not the most intuitive setup and takes some getting used to, but all of my features work correctly and have been working since the Group Buy. The software environment was pretty slick when the unit was first introduced, but is seriously falling behind the times now with interactive displays, custom setups, etc.

      Also, Bluepower is not good with customer support. They have not really stood behind their product and left many many unhappy customers here on Swedespeed since the group buy.
      2005 S60 T5 M66 (1 of 72 for '05). Four-C. OEM Lip Kit. Climate Pack. Sport Interior.
      2007 Formula SAE Racecar. Chromoly Tube Frame. Un-equal length A-Arm Suspension. Pull Rods. Fox Racing Shocks. GSX-R600. Torsen LSD. Magnesium Wheels. (restoration)
      NSX coming soon.

    7. #7
      Member LOGBOMB's Avatar
      Join Date
      Jul 2009
      Location
      Old Saybrook, CT
      Posts
      1,333

      Bluepower BLP-890

      My unit worked flawlessly the first few months I had it and it has just been more and more of a headache every time I use it. It is glitchy, it doesn't play DVDs anymore, the nav didn't come with all the states in the US and the card doesn't have enough space to fit maps of the whole US, the nav also crashes just about every 1/2 mile when I do use it and it gets seriously aggravating. In just the past weeks the icelink unit stopped working so I don't have any steering wheel controls anymore. iPhone only connects half the time and the blp unit will freeze sometimes when trying to navigate songs and playlists etc. the list goes on and on.

      To the op take it from someone who originally had a working unit and now it has gone down the tube get something else like a kenwood or pioneer double din unit with a good nav and you will not regret it. If you get a blp unit you may not regret it at first but you will after a year.
      2004 S60R, black sapphire, nordikap, M66, Autotech Stage2, K&N, 3" DP, EST catback w/ EST res delete, viva HD CBV,viva FMIC, TWM short shift, snabb intake pipe, TME springs, IPD track spec sways.

    8. #8
      Junior Member
      Join Date
      Aug 2010
      Location
      central nj
      Posts
      437
      Quote Originally Posted by LOGBOMB View Post
      My unit worked flawlessly the first few months I had it and it has just been more and more of a headache every time I use it. It is glitchy, it doesn't play DVDs anymore, the nav didn't come with all the states in the US and the card doesn't have enough space to fit maps of the whole US, the nav also crashes just about every 1/2 mile when I do use it and it gets seriously aggravating. In just the past weeks the icelink unit stopped working so I don't have any steering wheel controls anymore. iPhone only connects half the time and the blp unit will freeze sometimes when trying to navigate songs and playlists etc. the list goes on and on.

      To the op take it from someone who originally had a working unit and now it has gone down the tube get something else like a kenwood or pioneer double din unit with a good nav and you will not regret it. If you get a blp unit you may not regret it at first but you will after a year.
      My nav was crashing all the time too with the supplied SD card and the maps they provided. It was truncated so I did not have maps for any states lower than Pennsylvania alphabeically. I downloaded all the maps a SS user posted here and put them into the SD card file structure, and copied this all onto a 4GB Sandisk SD card, and Nav has been flawless ever since. I have not been able to successfully copy my SD card, either by cloning or the original files and have the Nav work so I have not been able to make copies for others. Very strange problem.

      I would still suggest not buying Bluepower units and just go with a Kenwood/Pioneer/Alpine/CarPC unit.
      2005 S60 T5 M66 (1 of 72 for '05). Four-C. OEM Lip Kit. Climate Pack. Sport Interior.
      2007 Formula SAE Racecar. Chromoly Tube Frame. Un-equal length A-Arm Suspension. Pull Rods. Fox Racing Shocks. GSX-R600. Torsen LSD. Magnesium Wheels. (restoration)
      NSX coming soon.

    9. #9
      Quote Originally Posted by broinkrist View Post
      My nav was crashing all the time too with the supplied SD card and the maps they provided. It was truncated so I did not have maps for any states lower than Pennsylvania alphabeically. I downloaded all the maps a SS user posted here and put them into the SD card file structure, and copied this all onto a 4GB Sandisk SD card, and Nav has been flawless ever since. I have not been able to successfully copy my SD card, either by cloning or the original files and have the Nav work so I have not been able to make copies for others. Very strange problem.

      I would still suggest not buying Bluepower units and just go with a Kenwood/Pioneer/Alpine/CarPC unit.
      I had that exact broblem as you did and solve it same way. Original SD card was somehow internally crashed.
      I just copy files to my wife's iMac and transferred them to another SD card. After that everything works really fine w.navi.