Loud creaking from steering when turning and braking/accelerating
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Welcome to SwedeSpeed
    You're currently browsing Swedespeed as a guest. Please sign up or sign in and take part in the conversation with other Volvo owners and enthusiasts. With more than 2 million posts our community is one of the most active groups of Volvo owners in the world. Take a moment to sign up and enjoy all of the features our forums have to offer.
    Results 1 to 5 of 5
    1. #1

      Loud creaking from steering when turning and braking/accelerating

      Hi.
      I have a problem with my 2005 XC90 2.5T.
      I had my xc90 in for a service, and got the control arm bushings replaced in the front, as they said they were broken.
      Then just a couple of weeks later I had the car in for a tire change and wheel alignment.

      After this wheel alignment and tirechange(literally right after), the car is making an awful loud creaking-noise when I'm braking a little hard, and accelerating. Also the sound appears in some turns(most often at slow sharp turns), and when turning the wheel when the car is not in motion.

      Any idea what might be wrong? Here is two videos showing the sounds. The first one with the car standing still, and me turning the wheel slowly from side to side. And in the second one I'm braking and accelerating, and you can hear the creaking(most noticeable when accelerating).

      Sorry about the dark video.

      http://www.youtube.com/watch?v=qTkEi31JMEM

      http://www.youtube.com/watch?v=vBXUsyiDKXA

      Thanks in advance for all your help!

    2. #2
      That is loud. I would inspect the subframe bushings and the Strut Bearing Plates (this would be my guess).

    3. #3
      Anyone else? I think my car has early signs of the same problem.

    4. #4
      Finally got this problem fixed!
      Was at the volvo dealer today, and they found out both ball joints in the front had to be changed. Also one of the control arm bushings was making a noise, so they changed that as well.
      The creaking sound is all gone!

    5. #5
      Moderator BLUEtheC30's Avatar
      Join Date
      May 2013
      Location
      NEW YAWK
      Posts
      283
      Quote Originally Posted by hiTmanhiT View Post
      Hi.
      I have a problem with my 2005 XC90 2.5T.
      I had my xc90 in for a service, and got the control arm bushings replaced in the front, as they said they were broken.
      Then just a couple of weeks later I had the car in for a tire change and wheel alignment.

      After this wheel alignment and tirechange(literally right after), the car is making an awful loud creaking-noise when I'm braking a little hard, and accelerating. Also the sound appears in some turns(most often at slow sharp turns), and when turning the wheel when the car is not in motion.

      Any idea what might be wrong? Here is two videos showing the sounds. The first one with the car standing still, and me turning the wheel slowly from side to side. And in the second one I'm braking and accelerating, and you can hear the creaking(most noticeable when accelerating).

      Sorry about the dark video.

      http://www.youtube.com/watch?v=qTkEi31JMEM

      http://www.youtube.com/watch?v=vBXUsyiDKXA

      Thanks in advance for all your help!
      heyy had this same issue with my 07 90... the control arm bushings needed to be changed, so to make things simple, i had both control arms changed along with the bushings... apparently there was an issue with the bushings so they had to be upgraded.. something to do with the weight of the car from my understanding. Did u have an issue with ur wheel alignment? we did.. the car would always pull to the left and would have no return on the steering when making left turns... at first.. we thought it was the struts.. so we did new struts, new strut bearing plates, still the same noise... thats when we did the new control arms with the upgraded bushings.. since then... no more noise!!
      http://i.imgur.com/69xqQ2j.jpg
      2013 C30 R-Design Polestar LE #50 of 250 Rebel Blue 6spdMT

      2007 XC90 3.2 AWD