My bluepower stereo has arrived - Page 2
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Page 2 of 2 FirstFirst 1 2
    Results 36 to 64 of 64
    1. #36
      That install doesn't really look too hard....

      Looking at the last page where they talk about having difficulty getting the LCD screen out after installation, I wonder if it would be possible to try and cut away a very small portion of the very top or bottom edge of the frame where it meets the aluminum waterfall panel to create a sort of "coin slot" where you could get a weatherstrip tool or butter knife in to help pop out the panel?

    2. Remove Advertisements

      Advertisements
       

    3. #37
      Junior Member
      Join Date
      Apr 2015
      Location
      Devon, England
      Posts
      75
      I have mine fitted just finished wiring in the reversing camera. I have a 2005 s40 & the icm isn't compatible with the Bluepower headunit as they have 2 lcd strips opposed to 1. The only way around it is to use a icm out of a newer car. I spoke to bluepower & they are sending out the required icm free of charge. Also there customer service has been spot on always replying within 1 hour & they gave me there mobile number for WhatsApp so they could help if required.

      I've tried uploading a short video but it keeps on crashing so pictures will have to do.

      It's a awesome thing to have, the sat is very good, screens very responsive, the Bluetooth is excellent I can now link my songs from my phone & my dab app so have a lot more radio stations available.









      Sent from my SM-G920F using Tapatalk

    4. #38
      It looks like I'm getting another a40 on Monday and I might just have to get one of these

      Sent from my HTC M9 using Tapatalk

    5. Remove Advertisements

      Advertisements
       

    6. #39
      Junior Member
      Join Date
      Apr 2015
      Location
      Devon, England
      Posts
      75
      Reversing camera all working with the guided lines. These can be erased by removing the green wire from the reversing camera.



      Sent from my SM-G920F using Tapatalk

    7. #40
      Junior Member One's Avatar
      Join Date
      Jan 2016
      Location
      Germany, BW
      Posts
      288
      Quote Originally Posted by shinys40 View Post
      Reversing camera all working with the guided lines. These can be erased by removing the green wire from the reversing camera.



      Sent from my SM-G920F using Tapatalk
      Looks very OEM! Also my god how much is on your keychain

      Gesendet von meinem C6833 mit Tapatalk
      2005 Volvo V50 T5 FWD Manual - Maintenance Queen

    8. #41
      Junior Member
      Join Date
      Apr 2015
      Location
      Devon, England
      Posts
      75
      Quote Originally Posted by One View Post
      Looks very OEM! Also my god how much is on your keychain

      Gesendet von meinem C6833 mit Tapatalk
      Haha, way to many keys but I need them all.

      Sent from my SM-G920F using Tapatalk

    9. #42
      Any thoughts on your first few weeks/months with the unit?
      Any more pictures or video? I wish the designer had more up on their site...

    10. #43

    11. #44
      Junior Member
      Join Date
      Feb 2016
      Location
      California
      Posts
      21
      I haven't taken any videos, but I did post some odd bugs/quirks in the other thread.

      In addition to that, I had another thought. This unit needs a "skip to next folder" button for music. There's no way to easily do that. When you press the List button, you are shown the first ~6 items stored on the USB/SD, and have to scroll for more. Not easy when driving.
      2007 S40 T5 AWD

    12. #45
      I just got mine in the mail last week, I'll be installing it tomorrow. I do have a question for anyone that has installed it.. What are the loose wires hanging off the main harness? There's 8, so I thought they were speaker wires or something, but it says to plug in the blue wire from the antenna into the blue wire on harness a, which leaves 7 random wires there and nothing says what they do.

      And the blue wire coming off the antenna adapter has a strange connector on it


      Meanwhile the blue wire they say to connect it to has a totally different circular connector. So they don't even appear to be compatible.



      Sent from my HTC M9 using Tapatalk
      Last edited by Ou2mame; 08-26-2016 at 11:31 PM.

    13. #46
      Well I spoke to bluepower and they're sending me the upgraded antenna. So i guess I'll be installing it next month lol

      Sent from my HTC M9 using Tapatalk

    14. #47
      Junior Member
      Join Date
      Oct 2012
      Location
      Northern Va
      Posts
      273
      Let us know who everything goes. I'm still really interested in getting one.
      2010 S40 T5 AWD M66 R-Desgin (The Unicorn) - KW V1 - FastCo FC04A - Elevate rear sway bar - Massive RaceSpec Adjustable Camber Arms - GoVo ecu spacer

    15. #48
      It looks good haha that's about all I can say

      Sent from my HTC M9 using Tapatalk

    16. #49
      Junior Member
      Join Date
      Sep 2014
      Location
      Seattle, WA
      Posts
      46
      Did they give an explanation? Mine arrived yesterday, and I haven't had a chance to look at the wiring that closely. Does your car have Premium sound?

    17. #50
      No, no premium sound. I asked them what to do with that blue antenna wire and he sent me a pic of a black antenna. Mine was silver. He said he would send me the black one. I realized after talking to him that the antenna is just a generic Chinese powered antenna, and that connector is probably not related to the bluepower wiring so I'll have to cut the ends off and use a regular connector or something to connect them.

      I wish they would give you a diagram of every wire included. There's one harness with 12v wires and a "brake" wire, there's a ton of rca cables in and out and then the loose wires on harness a i don't know what any of them do.

      Sent from my HTC M9 using Tapatalk

    18. #51
      Junior Member Leo Kalme's Avatar
      Join Date
      Jul 2015
      Location
      Estonia
      Posts
      119
      Well, if you are going to install it or already have, maybe pictures of installation/working unit or some video of its usage? It makes me wonder of why they went with WinCE on this unit - this is a real turn-off. From videos so far, UI seems sloppy,

      How would you say it stands up against modern day android-based units? And please, post pictures if you have any
      Volvo S40 2.0D 100kW 2004.5 Titanium

    19. #52
      Have you ever used an underpowered Android device? It's terrible. From what I've read, this system is pretty quick for what it is. I've used windows mobile and windows ce since the 90s so I have faith it can be tweaked to run well. It's a task driven os. Anyways, I'll be taking some install pics so that I can help anyone decide if they want to do this. We ordered a reverse cam as well since we have to wait for the antenna anyways. I've also got to change the ignition switch while I'm in there.

      Sent from my HTC M9 using Tapatalk

    20. #53
      Junior Member Leo Kalme's Avatar
      Join Date
      Jul 2015
      Location
      Estonia
      Posts
      119
      Quote Originally Posted by Ou2mame View Post
      Have you ever used an underpowered Android device? It's terrible. From what I've read, this system is pretty quick for what it is. I've used windows mobile and windows ce since the 90s so I have faith it can be tweaked to run well. It's a task driven os. Anyways, I'll be taking some install pics so that I can help anyone decide if they want to do this. We ordered a reverse cam as well since we have to wait for the antenna anyways. I've also got to change the ignition switch while I'm in there.

      Sent from my HTC M9 using Tapatalk
      Sure I have. And I have also used well-powered Android device and it is really slick.
      Well, anyway, I was talking about sloppy graphical UI from last installation. Android is easy to use and experiences few graphical glitches. Windows Mobile is alright but CE looks like straight out of 90s. Would need lots of tinkering.
      Volvo S40 2.0D 100kW 2004.5 Titanium

    21. #54
      In don't think there's any access to the underlying os, just the interface app running on top of it so you're not going to see the start menu or a desktop or anything like that.

      Sent from my HTC M9 using Tapatalk

    22. #55
      Junior Member Leo Kalme's Avatar
      Join Date
      Jul 2015
      Location
      Estonia
      Posts
      119
      Quote Originally Posted by Ou2mame View Post
      In don't think there's any access to the underlying os, just the interface app running on top of it so you're not going to see the start menu or a desktop or anything like that.

      Sent from my HTC M9 using Tapatalk
      That interface of this interface app IS my concern Well, I am quite sure what this unit is so I am going another route but something I found recently on YT.

      Volvo S40 2.0D 100kW 2004.5 Titanium

    23. #56
      How many units are there that interface with the hvac display? That was the selling point for me.

      Sent from my HTC M9 using Tapatalk

    24. #57
      Junior Member Leo Kalme's Avatar
      Join Date
      Jul 2015
      Location
      Estonia
      Posts
      119
      Quote Originally Posted by Ou2mame View Post
      How many units are there that interface with the hvac display? That was the selling point for me.

      Sent from my HTC M9 using Tapatalk
      I understand you perfectly. If I was little more settling, I could perhaps toss my money on it and call it a day but for some reason I am very difficult to please and aesthetics are as important as function.

      Sorry to hi-jack your thread, I was just interested if there has been any changes to that interface or any improvement with some updates.
      Volvo S40 2.0D 100kW 2004.5 Titanium

    25. #58
      I'll definitely post some more info when I get it installed. I've seen videos of the interface from a few years ago snd recent videos and the recent ones look a lot better. I'm not going to be 100% happy with it, I'm sure. But it's better than the current radio and there aren't any other options that I know about so that's why we decided on it. And the exchange rate changes helped too. Honestly though, the build quality looks very good, it's not like it's some hack job or anything.

      Sent from my HTC M9 using Tapatalk

    26. #59
      Junior Member
      Join Date
      Sep 2014
      Location
      Seattle, WA
      Posts
      46
      Anyone with with a 2005ish S4/V50 T5 with Premium Sound want to buy a BLP-990 with rear view camera?

      After removing half of my interior, I came to discover that my stock wiring harnesses had been replaced with aftermarket wiring. So yeah, I'm screwed. Don't be like me. Inspect your system before ordering this product. I'm going to talk to Bluepower about my options since it's they have a 30 Day return policy.

      Oh yeah, the replacement harnesses that route from the rear unit/amp to the dash costs $805.

    27. #60
      Member AutoGeek's Avatar
      Join Date
      Jan 2008
      Location
      MD, Howard Co.
      Posts
      1,452
      So how is the sound quality of the Bluepower? It has pre-outs; anyone running an external amp?
      Stan
      2005 V50 T5 FWD M66 Passion Red (Radio Flyer)

      1998 V70 NA - Sold, 2002 S40 1.9T - R.I.P., 2005 V50 T5 - RIP

      Remember kids, Speed doesn't kill ... impact does!

    28. #61
      Well I installed it today. I had a neck injury that prevented me from doing it sooner. It went pretty smoothly, the only issues I ran into was the antenna power, not knowing where to splice it into because the instructions say blue wire, but there is no blue wire on the power harness (A), so I ended up using the red wire that goes to the amp since it turns off with the ignition. It seems to work well, no issues. I was surprised that the track info didn't show up on the screen when playing music from my phone using bluetooth. We have a reverse cam but I haven't installed it yet. We ran out of time today and its supposed to dump 2' of snow soon, so maybe next weekend i'll get that done too.

    29. #62
      Junior Member
      Join Date
      Sep 2014
      Location
      Seattle, WA
      Posts
      46
      Quote Originally Posted by Ou2mame View Post
      ...the instructions say...
      Wait, yours came with instructions?

    30. #63
      Quote Originally Posted by teXas View Post
      Wait, yours came with instructions?
      I had emailed them previously about the antenna issue because I didn't see any blue wires, and they ended up sending me a new antenna, and in an email sent me a PDF installation instruction manual. Here's a download link for anyone else who needs it. I'm sure you can also email them.

      I just made another thread but maybe you know... I want to install a reverse camera, and need to know which wire on the passenger tail light harness is the positive reverse light wire so that I can tap into that to power the camera.


      http://www.filehosting.org/file/deta...90%20Basic.pdf

    31. #64
      One issue I'm having is that after shutting the car off, the radio still plays music for about 30 seconds after I shut the door. And sometimes I can't lock the car for about that amount of time. Has anyone else had this issue?

      Sent from my HTC M9 using Tapatalk

    32. Remove Advertisements

      Advertisements
       

    Page 2 of 2 FirstFirst 1 2