Hesitation under full throttle - 2001 V70 T5
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 5 of 5
    1. #1

      Hesitation under full throttle - 2001 V70 T5

      I have a 2001 V70 T5 manual with 145k miles that I've owned for almost 2 years now. Since I've owned it I've noticed a slight hesitation or "lurching" under full throttle between 4-6k RPM. It's barely noticeable to most people but drives me nuts.

      In the last couple months I've replaced all the coil packs, spark plugs, and air filter. I always run premium gas and there's currently no engine check light.

      Last week the check light came on (P0456 - small evaporative emissions system leak). I reset the computer using an OBD2 reader and for the first hundred or so miles, the slight hesitation was gone and the car made noticeably more power. Now the hesitation is back again (no check engine light).

      Any ideas on what I should try next? I was going to try cleaning the mass air flow sensor to see if that fixes it. Could these symptoms be caused by a failing ETM? I've noticed some occasional idle fluctuations... I've read that this could indicate my ETM could be on the way out. Any advice would be greatly appreciated. Thanks

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Have you checked your PCV system? A clogged up pcv can allow your throttle to get dirty and stick which can cause surging.

    4. #3
      i didn't think it could be a PVC issue because my car temporarily runs just fine with an ECU reset. If my throttle was dirty or sticky, I doubt resetting the computer would fix it. But... I don't know these cats very well, maybe a clogged PVC could be causeing my issues. I don't have any oil leaks and my dip stick hasn't ever "popped out" to indicate a clogged system.

    5. Remove Advertisements

      Advertisements
       

    6. #4
      Member T501's Avatar
      Join Date
      Mar 2005
      Location
      Florida
      Posts
      5,394
      Have you ever replaced the TCV? Kind of a wild guess but I know when they start to go, you lose boost and you will feel hesitation and lurching. If they get real bad they will throw a code.
      David - '01 S60 T5 GT 178K+ miles OWNED SINCE DAY ONE - Bilstein Sport + TME, ipd sway bar + endlinks, UR chassis braces (upper F+R), Powerslot /Akebono pads, Snabb Intake, HD coils, iMIV Original engine, transmission replaced at 79k miles
      Wife -'13 C30 T5 R-Design Dad - '98 S70 T5 160K + miles, Bilstein TCs, IPD HD rear springs, SAS delete Mom -'10 S80 V8 Executive Sis - '02 S80 T6 Backup car -'13 S60 T5

    7. #5
      Member LloydDobler's Avatar
      Join Date
      Aug 2007
      Location
      Littleton, CO
      Posts
      6,724
      It absolutely could be an ETM. Does it have a yellow label or white? Yellow means it's been replaced once. If you've never replaced it it's well beyond the normal failure point. You can have a test run or just get a xemodex unit and be done with it. Or if you know how to solder and trust your mechanical instincts, get the optical sensor off ebay and replace it yourself for 1/4 the cost.

      My ETM failed with throttle hesitation symptoms by around 110k miles. Now whenever I get surging I know it's time to change my spark plugs. Runs perfect otherwise at 191k now.
      2003 C70 T5M Convertible - Eibachs, Koni FSDs, Enkei RSF5s, OBX downpipe, Snabb intake, RIP kit, & drop-in intercooler, Quaife LSD, 19T, Green Giants, 22 psi Hilton tune.
      2006 V70R M66 - Sonic Blue/Nordkap, 2.4 T5 motor, Pure Turbos Hybrid, Snabb intake & intercooler, IPD oval exhaust, JZW tune.
      1966 122s - Collectible project, restoration and many mods on the way.

    8. Remove Advertisements

      Advertisements