Car stalling randomly
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 7 of 7
    1. #1
      Junior Member
      Join Date
      Sep 2013
      Location
      Niagara Falls, NY
      Posts
      28

      Car stalling randomly

      Hello all. Having trouble with my S40 again. It keeps stalling on me randomly, no check engine light, but i still have a code P0629 "OBD-II Trouble Code: Fuel Pump "A" Control Circuit High." Once I clear the code it's usually fine for a few days. I did replace the PEM last year when I was having issues, with a Xemodex one (which was "refurbished"). So I'm thinking that went, even though it's behaving slightly differently than it was last year. Even when it's working fine, fuel pressure will occasionally spike to 85 psi. Fuel pressure sensor was replaced last year with a new unit last year as well. It only has 85k miles, so I can't imagine it being anything else.

      Any ideas before I drop a few hundred for a new PEM?

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Aug 2016
      Location
      Ohio, USA
      Posts
      197
      Do you have VIDA? I know inside of VIDA with a DiCE unit you can test the fuel pump and stuff. Worth a thought before you drop a lot of money. It'll also tell you where exactly to look, etc. But I suspect it might be the OEM since you got a refurbished from xeMODex. Contact them as there might be a warranty as well

      Sent from my XT1575 using Tapatalk
      2006 S40 2.4i FWD

    4. #3
      Junior Member
      Join Date
      Sep 2013
      Location
      Niagara Falls, NY
      Posts
      28
      Unfortunately I do not have a vida, and even worse, the closest dealership tends to be less than cooperative.

    5. Remove Advertisements

      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Aug 2016
      Location
      Ohio, USA
      Posts
      197
      Quote Originally Posted by notreadytorock View Post
      Unfortunately I do not have a vida, and even worse, the closest dealership tends to be less than cooperative.
      I would highly suggest you get VIDA. The first scan really will pay for itself. You can pick it up on Amazon for under 100$. I've already diagnosed the issue I've been having with my car since I bought it last March and I've only had VIDA for 9 days 😃😃

      Sent from my XT1575 using Tapatalk
      2006 S40 2.4i FWD

    7. #5
      Junior Member
      Join Date
      Sep 2013
      Location
      Niagara Falls, NY
      Posts
      28
      At this point, with all of the issues I've had with my car, I just want to fix it long enough to save up some money to trade it in and be done with this godforsaken car.

    8. #6
      Member GRat9717's Avatar
      Join Date
      Jan 2013
      Location
      NJ, USA
      Posts
      1,874
      Quote Originally Posted by notreadytorock View Post
      At this point, with all of the issues I've had with my car, I just want to fix it long enough to save up some money to trade it in and be done with this godforsaken car.
      Better just get rid of it sooner than later then...
      Garage Queen - 2010 C30 R-Design Vrooooooom
      Daily - 2016 V60 T5 Drive-E Vrooooooom
      Zichrona Livracha - 2004.5 S40 T5

    9. #7
      Junior Member
      Join Date
      May 2016
      Location
      Mount Vernon, WA
      Posts
      50
      Buy a used PEM on eBay from a 2007 or newer car. I got mine for $65 and haven't had any issues with it.
      2005 V50 T5 AWD 6MT

    10. Remove Advertisements

      Advertisements