AWD not engaging?
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 7 of 7
    1. #1

      AWD not engaging?

      Hi Guys-
      it snowed a few inches here on monday, and on my drive to work I spun the front tires pulling away from every other red light, which surprised me (v50 t5 awd).
      Anyway got home from work today and jacked up the car to test the haldex system. I was expecting to not see the rear wheels spin at all, but what I get is bizzare- only 3 wheels spin - both rears (very slowly), and the front drivers side. Also, I'm able to stop the rear wheels with my hand. Ideas as to what can cause this ? is it as simple as the haldex fluid being low? where should I be looking?


      EDIT: the car shakes a ton, and the wheel that isn't spinning spins very jerk-ily when I give the car some throttle up on the stands
      EDIT2: I have an ABS code for the wheel that isn't spinning. would this explain the problem? bad ABS sensor?
      Last edited by austratton; 04-20-2017 at 12:20 AM.

    2. Remove Advertisements

      Advertisements
       

    3. #2
      First steps are the simplest steps: get it scanned by a volvo specific scanner for codes, then start with the haldex fluid/filter changeout and a diff fluid changeout.
      2006 Volvo S40 AWD T5 M66 - Dusty Rusty
      2012 Subaru Outback 2.5i CVT - Slowmobile - CAI only, Powerstop Rotors+Pads.
      1996 HD Electra Glide - Big Bertha 10:1 Pistons; EV13 Cam: Ultima Digital Ignition; Buell Head Conversion; E85 Carb Tuned;

    4. #3
      Junior Member V50R's Avatar
      Join Date
      Nov 2014
      Location
      Rochester Hills MI
      Posts
      792
      Vote #2 for fluid and filter change. Once that screen clogs almost no oil can pass through it.
      The kit is fairly cheap. Filter is around 24$ on FCPEURO.com and fluid is roughly that as well. I bet once you change everything it will function again!
      SOLD:: 2006 V50 T5 AWD AW55, 320mm FR Brake upgrade, Elevate Intake, OBX Exhaust.
      2010 XC90 V8 Executive Latest Addition.
      2008 XC90 V8 Executive Edition, w/Muffler Delete.
      2005 XC90 V8 Black, VB replaced, S60R Brake Swaped
      2013 Jetta Sportwagen TDI 6spd. Malone S2 tuned 200hp/350tq.

    5. Remove Advertisements

      Advertisements
       

    6. #4
      Quote Originally Posted by avenger09123 View Post
      First steps are the simplest steps: get it scanned by a volvo specific scanner for codes, then start with the haldex fluid/filter changeout and a diff fluid changeout.
      I scanned with VIDA - I get the code "BCM-0021 wheel sensor front right, faulty signal" for the front wheel that isn't spinning.
      ordered haldex fluid/filter and will change this weekend, but the front wheel not spinning seems unrelated. Is this just a consequence of the car having an open diff? I was under the impression that the car would apply the brakes to the wheel that was spinning fastest on an axle if it detects slippage?
      Last edited by austratton; 04-20-2017 at 01:14 PM.

    7. #5
      So the lack of ABS signal on that side prevents the computer from seeing that that wheel is spinning/sliding and either applying the brakes or shunting power to the rear. Only the front driverside is reporting ABS data, which means that it can only judge to turn on/off the rears or apply the brakes to prevent spinning on the front driverside.

      I don't know if it's an "open differential" or a limited slip, considering if drivers side front wheel spins, even though it's first in line for power, power still goes through to the right and down the driveshaft to the rear.
      Last edited by avenger09123; 04-20-2017 at 01:54 PM.
      2006 Volvo S40 AWD T5 M66 - Dusty Rusty
      2012 Subaru Outback 2.5i CVT - Slowmobile - CAI only, Powerstop Rotors+Pads.
      1996 HD Electra Glide - Big Bertha 10:1 Pistons; EV13 Cam: Ultima Digital Ignition; Buell Head Conversion; E85 Carb Tuned;

    8. #6
      Member
      Join Date
      Dec 2013
      Location
      Northern CA
      Posts
      2,376
      All open diffs


      Sent from my iPhone using Tapatalk
      2005 V50 T5 AWD M66

    9. #7
      After poking around in VIDA, it would seem that the code can be generated because of a faulty signal, or an "implausible" one.
      VIDA says: "Feasibility assessment by comparing the difference in speed between the wheel with the lowest speed and the wheel with the highest speed".
      What I interpret this to mean is that the code is just a by-product of the wheel not spinning - ie when comparing the wheel speed between front left (spinning) and front right (not spinning) - the computer is deciding that the front right signal is "implausible".. So the problem isn't just the abs sensor.

    10. Remove Advertisements

      Advertisements