Anti-skid and brake failure--CAN bus issues?
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 5 of 5
    1. #1

      Anti-skid and brake failure--CAN bus issues?

      Hey Guys,
      Been lurking here since I bought my 2004 R back in September of last year, it was a bit of a mess when I bought it and is slowly coming together. Was hoping to get some input on the thing I'm currently chasing--Anti-skid and brake failure messages. I had a host of SUM codes in VIDA and speculated after finding wet carpet on the drivers side that maybe the leaky evap drain had killed the SUM module but replacement didn't change anything, also sprayed some Deoxit on the contacts hoping that maybe corrosion was the issue. Here are some screenshots from VIDA:



      Messages/codes just about always come up in the morning and 50/50 later in the day after it warms up and the car has been run which would lead me to believe it wasn't a CEM issue but I could be wrong there as it does appear the SUM has 0V supply at times as you can see. Ran across this thread this morning and will be checking fuses/relays for potential sources of contact resistance as well, any other input/ideas would be greatly appreciated!
      Thanks!
      Last edited by dok33; 05-18-2017 at 10:11 AM.

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Started off looking at fuses, here is the 15A fuse for the SUM:



      Broke it apart and appears to have corrosion/carbon deposits, seems odd that it's at the top and not in the contact area! Upon looking further, quite a few of the fuses look like this, guess I'll start by swapping them out...

    4. #3
      A lot of times some of them codes can be brought about because the steering angle sensor is out of whack but that happens if you've taken out the wheel before.

      My first guess is the 4C struts are cooked, or at least the passenger rear side. It seems more likely the sum connector got corroded some but still
      '06 S60R GT | Blurple w/Sport Kit | 19" FC04A's | KW V2 | Hilton Stage 2.25 | DevilsOwn W/M | IPD:3" Oval Catless Exhaust | HD CA's | Adj. Toe Bars | Trunk Brace | Snabb: Turbo Intake | Airbox | Big FMIC | Synapse DV | Colder Plugs | XC90 Trans Cooler | Strut Brace | Subframe Brace | 20mm R/Spacers | 90mm Studs | Fancy Rotors | A-Pillar Boost/Trans/Volt Gauges | ScanGauge II | All Lights HID | My BUILD THREAD

    5. #4
      What codes show up under the delivery tab? Your screen shot is of unselected csc.

      Any codes from other modules?

    6. #5
      Sorry, didn't get a notification of the reply for some reason. Here's what shows up under the delivery tab (lots of stuff):


      Cleared everything and did another scan and got these:


      After another round of clearing/scanning just 1 remains:


      Will run another scan after driving home from work this afternoon and see what else comes up. Thanks for the responses and input!
      Last edited by dok33; Today at 12:05 PM.

    7. Remove Advertisements

      Advertisements