Finally lowered the R... my noise woes continue...
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 20 of 20
    1. #1
      Junior Member AHI's Avatar
      Join Date
      Jan 2007
      Posts
      340

      Finally lowered the R... my noise woes continue...

      Somewhere from the front right, we CANNOT figure out where the noise is coming from, but when I drive around in comfort and sport, there are HUGE bangs and rattles when I hit little ruts and bumps in the road... when I put it into ADVANCED, the noises go away... Everything is tight, double and triple checked..... I have a little play in the control arm bushings but we have pretty much ruled that out.....

      I've searched, and read, and searched, and read... but have not found any answers...

      The only think I can think of is that the strut may be blown? how do I know if it is? I really hope it isin't but I have to figure this out... any ideas?


    2. Remove Advertisements

      Advertisements
       

    3. #2
      Senior Member gradyjoseph's Avatar
      Join Date
      Oct 2006
      Posts
      441

      Re: Finally lowered the R... my noise woes continue... (AHI)

      mines lowered with eibachs, and i have A LOT of squeaking sounds, loud squeaking sounds, that i do not particularily enjoy. I too would love some insight into these noise woes...

      thanks


    4. #3
      Member PhilUp's Avatar
      Join Date
      Mar 2003
      Location
      West LA, CA
      Posts
      3,582

      Re: Finally lowered the R... my noise woes continue... (gradyjoseph)

      I get some squeaking on big bumps from the rear left suspension. I've had it checked twice and couldn't find anything wrong with it. I suspect the spring is just rubbing against something causing the squeaking. I also get a clunking noise when going up a driveway at an angle and I think it's also due to the spring getting caught on something and then when I clear the driveway it releases and causes a clunk.

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Senior Member gradyjoseph's Avatar
      Join Date
      Oct 2006
      Posts
      441

      Re: Finally lowered the R... my noise woes continue... (PhilUp)

      thats what im thinking as well, i would like to find a permanent fix for this though, each time i get it aligned i tell them about it and it doesnt make the noises for a few weeks but it always comes back

    7. #5
      Member PhilUp's Avatar
      Join Date
      Mar 2003
      Location
      West LA, CA
      Posts
      3,582

      Re: Finally lowered the R... my noise woes continue... (gradyjoseph)

      Slab some lithium grease liberally to the area and repeat as necessary.

    8. #6
      Senior Member gradyjoseph's Avatar
      Join Date
      Oct 2006
      Posts
      441

      Re: Finally lowered the R... my noise woes continue... (PhilUp)

      word. thanks for the tip!

    9. #7
      when going over road imperfections /potholes and the elongated speed bumps by my house, I always seem to hear a sort of thump coming from the rear even as the front hits
      Silver 2004-R Man Trans, 15% Tints, K&N Air Filter, sport body kit.

    10. #8
      Member chinaonnitrous1's Avatar
      Join Date
      Nov 2003
      Location
      Left Coast
      Posts
      7,941
      Dissassemble & Reassemble after a week.

      Chances are your rubber spring seats weren't in the right place, and self-twisted themselves.

      That happend to me, after a week the spring was still in the right place (aligned at the bottom metal strut mount) It was just the rubber on top that wasn't sitting properly. It had twisted and the spring wasn't sitting properly.

      Stock 2004 S60r
      Totalled: Stock 1991 Toyota Mr2 w/ 309k miles.
      Current: Turbo 1991 Mr2 w/ 220k Miles & 2013 Scion Iq

    11. #9
      Member Short Circuit's Avatar
      Join Date
      Mar 2005
      Location
      Baltimore, MD
      Posts
      2,964

      Re: Finally lowered the R... my noise woes continue... (AHI)

      Two things come to my mind: LINKS: Either loose or one/both are bad. Tighten, tighten, and then tighten. If you have QBM's, throw them out and get IPD's. SUM: When you lower, you must re-SUM the car. Was this done? The SUM calibrations change w/pressing the buttons, so that is why I think this might be the culprit. If you're not able to get a SUM to load, slightly raise the REAR of the car about 1", and then perform the re-SUM. This is a known issue w/some lowered cars & re-SUMMING.
      SOLD!!! 2005 S60R. Mods: IPD (Stage 2 ECU, Trak Spec F&R sways, 3" DP, HD-TCV, HD-coils, HD-endlinks, SS brake lines), HEICO (CATback, 18" Volution wheels), Phuz PhMIC, JRL resonator delete, RKelly CAI, PLX OLED Boost Gauge, VST roof spoiler, 35% 3M window tint, other littler things.

    12. #10
      Junior Member AHI's Avatar
      Join Date
      Jan 2007
      Posts
      340
      I just want to add that I can deal with squeaks, this noise I'm talking about is an incredibly loud clunk, almost like the wheel is loose and is about to fall off... BANG... only in comfort mode and sport mode...

      Car was "SUM'd" at the dealer.... She drove beautifully for the first 200kms, but started loosening up and ineveitably started making these horrible noises...


    13. #11
      Senior Member FEO's Avatar
      Join Date
      May 2006
      Posts
      1,578

      Re: (AHI)

      perhaps you didn't let the springs settle before SUM'ing?

    14. #12

    15. #13
      Member Short Circuit's Avatar
      Join Date
      Mar 2005
      Location
      Baltimore, MD
      Posts
      2,964

      Re: (Token)

      Did you replace the spring seats when you put on new springs?
      SOLD!!! 2005 S60R. Mods: IPD (Stage 2 ECU, Trak Spec F&R sways, 3" DP, HD-TCV, HD-coils, HD-endlinks, SS brake lines), HEICO (CATback, 18" Volution wheels), Phuz PhMIC, JRL resonator delete, RKelly CAI, PLX OLED Boost Gauge, VST roof spoiler, 35% 3M window tint, other littler things.

    16. #14
      Member IwantaS60R's Avatar
      Join Date
      Nov 2003
      Location
      Jersey City, NJ
      Posts
      1,812

      Re: (Short Circuit)

      Quote, originally posted by Short Circuit »
      Did you replace the spring seats when you put on new springs?

      Bad spring seats would be my guess as well.

      HERS - 2007 XC90 3.2
      MINE - 2004 S60R : List of modifications - PhMIC, EST grille, K&N filter w/velocity stack, Eibach springs, iPd rear camber bushings, ELEVATE front and rear sways, Powerflex front LCA bushings, superflex rear LCA bushings, Turbo back exhaust, Aquamist, TWM short shifter, TWM shift knob (Big Type R), Black Forgestar F14 18x8.5 wheels, roof spoiler

    17. #15
      Member chinaonnitrous1's Avatar
      Join Date
      Nov 2003
      Location
      Left Coast
      Posts
      7,941

      Re: (IwantaS60R)

      Spring seats could definatly be a culprit.

      Stock 2004 S60r
      Totalled: Stock 1991 Toyota Mr2 w/ 309k miles.
      Current: Turbo 1991 Mr2 w/ 220k Miles & 2013 Scion Iq

    18. #16
      Member Short Circuit's Avatar
      Join Date
      Mar 2005
      Location
      Baltimore, MD
      Posts
      2,964

      Re: (chinaonnitrous1)

      IPD just came out with replacement spring seats, made of a superior rubber and center design than stock. I'd check that out first and if no joy, then get stock XC90 front spring seats, which fit our cars and apparently are more beefy. I think the IPD version is better than the XC90's.
      SOLD!!! 2005 S60R. Mods: IPD (Stage 2 ECU, Trak Spec F&R sways, 3" DP, HD-TCV, HD-coils, HD-endlinks, SS brake lines), HEICO (CATback, 18" Volution wheels), Phuz PhMIC, JRL resonator delete, RKelly CAI, PLX OLED Boost Gauge, VST roof spoiler, 35% 3M window tint, other littler things.

    19. #17
      Junior Member AHI's Avatar
      Join Date
      Jan 2007
      Posts
      340
      Hey guys... I'm not dealing with your average run of the mill clunks... this noise is actually so hard and loud that my wife refuses to sit in the car. Spring seats were not changed, installer said they looked pretty good....

      Tonight I actually drove it around on the highway at lower speeds and noticed that the front right of the car was not absorbing the bumps like the other three corners... I'm after a bump, (loud noise), the front right goes up higher than the front left, and comes down harder...

      Am I looking at a blown strut?


    20. #18
      Junior Member AHI's Avatar
      Join Date
      Jan 2007
      Posts
      340
      I'm being told a strut can cost me up to $800.00... is this true? I can't believe I just dumped $3K into this car and now this...

    21. #19

      Re: (AHI)

      Quote, originally posted by AHI »
      I'm being told a strut can cost me up to $800.00... is this true? I can't believe I just dumped $3K into this car and now this...

      Maybe with labor included. I paid around 540.00 for mine when it went out. Add the mark up JRL warned about and I think it might be 600.00 now.

      BTW, 3K is a drop in the bucket in the modding game.

      Quote, originally posted by AHI »

      Am I looking at a blown strut?

      Jack up the car, reach in and look for leakage out of the strut seal.

      Also, take a peak here:
      https://forums.swedespeed.com/zerothread?id=68014

      2006 S60R, Electric Silver, 19' V7's, full factory options, fully modded, rebuilt Stage 3 engine w/ uprgaded turbo and Black Flagged from Volvo. Thank goodness for the onboard LIDAR jammer. BLack Flag info: https://forums.swedespeed.com/showthr...ighlight=black Mod List: https://forums.swedespeed.com/showthr...roadband-users)

    22. #20
      Member chinaonnitrous1's Avatar
      Join Date
      Nov 2003
      Location
      Left Coast
      Posts
      7,941

      Re: (AHI)

      Quote, originally posted by AHI »
      Hey guys... I'm not dealing with your average run of the mill clunks... this noise is actually so hard and loud that my wife refuses to sit in the car. Spring seats were not changed, installer said they looked pretty good....

      Tonight I actually drove it around on the highway at lower speeds and noticed that the front right of the car was not absorbing the bumps like the other three corners... I'm after a bump, (loud noise), the front right goes up higher than the front left, and comes down harder...

      Am I looking at a blown strut?

      Why dont you jack up the car, and possibly take that wheel off and just stare at the spring/strut combo.

      See if you notice anything weird.


    23. Remove Advertisements

      Advertisements