What Did You Buy/Do To Your Car Today? - Page 12
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Page 12 of 12 FirstFirst ... 2 8 9 10 11 12
    Results 386 to 416 of 416
    1. #386
      Junior Member
      Join Date
      Jun 2017
      Location
      Maryland
      Posts
      424
      Quote Originally Posted by odiespankers07 View Post
      I had the inner and outer tie rods replaced along with Febi Bilstein control arms from FCP. I had this terrible steering wheel vibration that would lead you to believe that the tires were out of balance or bent. It ended up being the arm bushings. No wander, no play. I am glad that fixed the problem as the tire balancing was not fixing the problem and was expensive repeatedly.
      Glad your vibration problem is solved!


      Sent from my iPhone using Tapatalk

    2. Remove Advertisements

      Advertisements
       

    3. #387
      Member
      Join Date
      Sep 2013
      Location
      New York
      Posts
      1,040
      Quote Originally Posted by anewman644 View Post
      Glad your vibration problem is solved!


      Sent from my iPhone using Tapatalk
      10 months of dealing with a steering wheel massager
      15 Volvo XC60 R-Design Platinum Pearl White Metallic, POLESTAR EXHAUST TDI Tuning Box, POLESTAR TUNED , IPD Rear Sway Bar and links, IPD POLY TORQUE ROD Koni FSD's, Eibach Loweing Springs, Powerflex Torque Bushing, Bloxsport wheel spacers
      Sold: 2008 Volvo C30 2.0 Java/Cosmic White, Manual, Elevate Tune, Weird OEM Mood Lighting Kit, EST Catback Exhaust, Koni STR.T, H&R Springs, Injen Intake, 19' BBS SR Wheels, Ion Yellow Fogs,
      SoldL 2006 Volvo V70R, Magic Blue, Stock

    4. #388
      Junior Member
      Join Date
      Jun 2017
      Location
      Maryland
      Posts
      424
      Quote Originally Posted by odiespankers07 View Post
      10 months of dealing with a steering wheel massager
      Mine was the engine mount.


      Sent from my iPhone using Tapatalk

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements

    6. #389
      Junior Member TheStillMan's Avatar
      Join Date
      Jun 2017
      Location
      Ohio
      Posts
      375
      I picked up this set of wheels and tires for a really good price this weekend. Fitment is just right! I might pick up a 5mm or 10mm spacer for the rear sometime.
      These are from a '17 XC90 - 18x8 42.5et
      Old were the Mantus wheels, 18x7.5 55et (both 235/60/18)

      IMG_20200302_174643.jpg
      2.jpg
      IMG_20200302_174739.jpg
      IMG_20200302_174719.jpg
      2010 XC60 T6 Sapphire Black Metallic (TFT DIM retrofit, DynoMax muffler, Eibach lowering springs & Koni struts, HardRace adjustable rear toe arms)
      2004 Subaru Legacy Outback wagon 2.5 White Frost Pearl (Also mine) | 2011 Chevy Equinox LT1 AWD Olympic White (Hers)

    7. #390
      Junior Member
      Join Date
      Feb 2020
      Location
      Upstate NY
      Posts
      3
      Installed a Drawtite hitch and Tekonsha wiring for it. Hitch was a bit challenging when i fished the upper side bolts and plates through the wrong holes. Got a little worried that I was going to lose the plates and have to remove the bumper. I know it's easy, I just hate removing bumpers : ). Looks pretty good. Not much hitch visible at all.

    8. #391
      Junior Member
      Join Date
      Jun 2019
      Location
      Chandler, AZ
      Posts
      27
      In the past 2 months or so I've installed new Powerstop front rotors/pads #KOE5702(also have the rear kit that have yet to install), bloxsport 20mm rear spacers, changed all engine/tranny mounts except passenger lower mount.
      I've also checked/inspected driveline components and STILL have a recurring & noticeable vibration when either 1) I'm in gear with the brakes applied(such as at a stop) or 2)When I press the brake to shift into Reverse. No vibration occurs while driving at any RPM or in neutral.
      Other than that this car is still chugging, have clocked 128,000miles.
      Anybody happen to have another idea as to the cause? Help is greatly appreciated. Thanks

    9. #392
      Quote Originally Posted by estradaccord View Post
      In the past 2 months or so I've installed new Powerstop front rotors/pads #KOE5702(also have the rear kit that have yet to install), bloxsport 20mm rear spacers, changed all engine/tranny mounts except passenger lower mount.
      I've also checked/inspected driveline components and STILL have a recurring & noticeable vibration when either 1) I'm in gear with the brakes applied(such as at a stop) or 2)When I press the brake to shift into Reverse. No vibration occurs while driving at any RPM or in neutral.
      Other than that this car is still chugging, have clocked 128,000miles.
      Anybody happen to have another idea as to the cause? Help is greatly appreciated. Thanks
      Perhaps it’s that lower mount? Not sure which lower mount you didn’t replace but there’s a lower mount directly underneath the upper torque mount and that is a mount known to wear and flatten and it in turn lowers the engine a bit and people say it’s a source of vibration. I think that’s what I’m experiencing currently with my 85k miles S60 T6...lots of extra noise and vibration, mainly at idle in my case, but worn mounts can cause different situations where a car gets vibration on a case by case basis. It could well be the same source of vibration even if your symptoms are slightly different.
      2011 S60 T6 with Polestar tune+TDI-Tuning : KW V3 coilovers : DO88 fmic : Ferrita downpipe : Powerflex "race" torque mount insert
      12.99 at 109mph

    10. #393
      Junior Member
      Join Date
      Jun 2019
      Location
      Chandler, AZ
      Posts
      27
      Hey thanks for the reply. Appreciate your feedback. I didn't change the passenger lower mount that sits near the turbo which is underneath the torque and engine mount on that side as it was in good condition when I removed and inspected it.
      So I put it back.
      Seems our symptoms are close but come in different ways.

    11. #394
      Glad to help, if that is what I did, lol. Perhaps check your exhaust to see if it’s making contact somewhere, or a heat shield might be rattling, or a hanger might be worn out? If motor mounts are fine, it could be an issue with the exhaust rattling or vibrating under certain conditions.
      2011 S60 T6 with Polestar tune+TDI-Tuning : KW V3 coilovers : DO88 fmic : Ferrita downpipe : Powerflex "race" torque mount insert
      12.99 at 109mph

    12. #395
      Junior Member
      Join Date
      Jun 2019
      Location
      Chandler, AZ
      Posts
      27
      Will also check your suggestions. You've been a help, nonetheless so thank you.

    13. #396
      Member
      Join Date
      Sep 2013
      Location
      New York
      Posts
      1,040
      Summer set on. Got bored and took the ixions off. I am posting them for sale as I have some different ideas for a winter setup next season. Attachment 60433
      15 Volvo XC60 R-Design Platinum Pearl White Metallic, POLESTAR EXHAUST TDI Tuning Box, POLESTAR TUNED , IPD Rear Sway Bar and links, IPD POLY TORQUE ROD Koni FSD's, Eibach Loweing Springs, Powerflex Torque Bushing, Bloxsport wheel spacers
      Sold: 2008 Volvo C30 2.0 Java/Cosmic White, Manual, Elevate Tune, Weird OEM Mood Lighting Kit, EST Catback Exhaust, Koni STR.T, H&R Springs, Injen Intake, 19' BBS SR Wheels, Ion Yellow Fogs,
      SoldL 2006 Volvo V70R, Magic Blue, Stock

    14. #397
      Member
      Join Date
      Sep 2013
      Location
      New York
      Posts
      1,040
      20200421_174137.jpg
      Summer set on. Got bored and took the ixions off. I am posting them for sale as I have some different ideas for a winter setup next season.
      15 Volvo XC60 R-Design Platinum Pearl White Metallic, POLESTAR EXHAUST TDI Tuning Box, POLESTAR TUNED , IPD Rear Sway Bar and links, IPD POLY TORQUE ROD Koni FSD's, Eibach Loweing Springs, Powerflex Torque Bushing, Bloxsport wheel spacers
      Sold: 2008 Volvo C30 2.0 Java/Cosmic White, Manual, Elevate Tune, Weird OEM Mood Lighting Kit, EST Catback Exhaust, Koni STR.T, H&R Springs, Injen Intake, 19' BBS SR Wheels, Ion Yellow Fogs,
      SoldL 2006 Volvo V70R, Magic Blue, Stock

    15. #398
      Junior Member
      Join Date
      Jun 2019
      Location
      Chandler, AZ
      Posts
      27
      Sweet summer set Spankers. What are the widths of that tire & wheel combo?

    16. #399
      Junior Member
      Join Date
      Jun 2017
      Posts
      108
      Quote Originally Posted by odiespankers07 View Post
      20200421_174137.jpg
      Summer set on. Got bored and took the ixions off. I am posting them for sale as I have some different ideas for a winter setup next season.
      Were those wheels a direct bolt-on to your P3 XC60, or did they need to be modified at all? Iím considering the 19Ē R-Design wheel from the SPA XC60 for my P3 XC60 as well, to replace the 20Ē Ixions.

    17. #400
      Junior Member
      Join Date
      Sep 2015
      Posts
      354


      Gave the wifeís XC a full clean and detail inside and gave her a wash and ceramic coating outside.


      Sent from my iPhone using Tapatalk Pro

    18. #401
      Junior Member MjollnirXC60's Avatar
      Join Date
      Mar 2018
      Location
      Collierville TN
      Posts
      57
      Bought a rear brake kit for our 2014 XC60. Got the Zimmerman rotors and Akebono pads. I noticed the Volvo OEM kits come with new bolts. Do you think I can reuse the old ones? Just put on some more locktite?

    19. #402
      Junior Member
      Join Date
      Jun 2019
      Location
      Chandler, AZ
      Posts
      27
      Quote Originally Posted by MjollnirXC60 View Post
      I noticed the Volvo OEM kits come with new bolts. Do you think I can reuse the old ones? Just put on some more locktite?
      Mjollnir, when I installed my Powerstop rear brake/rotor kit it came with a new set of bolts to hold the caliper to the caliper bracket. Are these the bolts you speak of?
      I don't know of a kit that comes with new Caliper bracket bolts that bolt the bracket to the hub mounts. I used the new ones just because but you can totally re-use the old bolts with a good cleaning and some locktite.

    20. #403
      Member
      Join Date
      Sep 2013
      Location
      New York
      Posts
      1,040
      Quote Originally Posted by CTXC60RD View Post
      Were those wheels a direct bolt-on to your P3 XC60, or did they need to be modified at all? Iím considering the 19Ē R-Design wheel from the SPA XC60 for my P3 XC60 as well, to replace the 20Ē Ixions.
      Direct fit
      15 Volvo XC60 R-Design Platinum Pearl White Metallic, POLESTAR EXHAUST TDI Tuning Box, POLESTAR TUNED , IPD Rear Sway Bar and links, IPD POLY TORQUE ROD Koni FSD's, Eibach Loweing Springs, Powerflex Torque Bushing, Bloxsport wheel spacers
      Sold: 2008 Volvo C30 2.0 Java/Cosmic White, Manual, Elevate Tune, Weird OEM Mood Lighting Kit, EST Catback Exhaust, Koni STR.T, H&R Springs, Injen Intake, 19' BBS SR Wheels, Ion Yellow Fogs,
      SoldL 2006 Volvo V70R, Magic Blue, Stock

    21. #404
      Junior Member
      Join Date
      Aug 2019
      Location
      Ontario
      Posts
      4
      P1260233.jpgP1260234.jpg
      New shoes. Just installed a set of Fast FC04 rims with Pirelli rubber.

    22. #405
      Member spiked60's Avatar
      Join Date
      Jul 2008
      Location
      Seattle
      Posts
      1,460
      Quote Originally Posted by Sage View Post
      P1260233.jpgP1260234.jpg
      New shoes. Just installed a set of Fast FC04 rims with Pirelli rubber.
      Nice! I've been wondering what color wheels would look good on the bronze, this actually works well
      The classic cruiser, 1972 164E, Alpine Blue Metallic.
      The new daily, 2011 XC60 T6 AWD, Terra Bronze Metallic.

      Previous:
      2009 S60 2.5T AWD, Ice White, Shark Stage 1
      2001 S60 fwd

      For the most current photos of the day, find me on Instagram

    23. #406
      Junior Member
      Join Date
      Aug 2016
      Location
      Stillwater, OK
      Posts
      250
      Replaced the PCV diaphragm in my XC60 today. Just used the Dorman part. Very simple job with it right on top. Eventually I'll replace the whole unit and the gasket, but for now this seems like a good preventative measure. The old one wasn't torn, I just wanted to replace it before any issues crop up.
      2013 XC60 T6
      2015 V60CC T5

    24. #407
      Junior Member volvofam's Avatar
      Join Date
      Jun 2011
      Location
      Western MA
      Posts
      25
      Changed out power steering fluid today. Just hit 100k. Will be changing out transmission fluid and differential fluid in the next week or so.



      Sent from my iPhone using Tapatalk
      2015 XC60 T6
      2015 XC60 3.2
      2013 C30 T5
      2008 XC70 3.2

    25. #408
      Junior Member MjollnirXC60's Avatar
      Join Date
      Mar 2018
      Location
      Collierville TN
      Posts
      57
      Quote Originally Posted by volvofam View Post
      Changed out power steering fluid today. Just hit 100k. Will be changing out transmission fluid and differential fluid in the next week or so.



      Sent from my iPhone using Tapatalk
      Did you pump out the power steering fluid or do it the old school way?

    26. #409
      Junior Member volvofam's Avatar
      Join Date
      Jun 2011
      Location
      Western MA
      Posts
      25
      Quote Originally Posted by MjollnirXC60 View Post
      Did you pump out the power steering fluid or do it the old school way?
      Iím guessing the old school way. I hooked up the clear hose to the return line and ran new fluid through the reservoir while steering back and forth until it ran clean. The fluid coming out actually looked really good. Iím guessing it degrades more from time than miles.


      Sent from my iPhone using Tapatalk
      2015 XC60 T6
      2015 XC60 3.2
      2013 C30 T5
      2008 XC70 3.2

    27. #410
      Member spiked60's Avatar
      Join Date
      Jul 2008
      Location
      Seattle
      Posts
      1,460
      Let there be light!
      The classic cruiser, 1972 164E, Alpine Blue Metallic.
      The new daily, 2011 XC60 T6 AWD, Terra Bronze Metallic.

      Previous:
      2009 S60 2.5T AWD, Ice White, Shark Stage 1
      2001 S60 fwd

      For the most current photos of the day, find me on Instagram

    28. #411
      Junior Member volvofam's Avatar
      Join Date
      Jun 2011
      Location
      Western MA
      Posts
      25
      Changed my transmission fluid at 100k for the first time a couple days ago. Did 3 drain and fills but was in a rush and didnít take any photos. The fluid was very dark and didnít have any red left in it but it didnít smell burnt. Shifts felt better right away other than a few spots where it seamed to be relearning after the counter reset. Itís been 250 miles now and the transmission is much smoother.


      Sent from my iPhone using Tapatalk
      2015 XC60 T6
      2015 XC60 3.2
      2013 C30 T5
      2008 XC70 3.2

    29. #412
      Junior Member MjollnirXC60's Avatar
      Join Date
      Mar 2018
      Location
      Collierville TN
      Posts
      57
      I also changed my transmission fluid last night with an oil change of Pennzoil Ultra Platinum. I swear my engine takes more oil than it's spec'd out to. Manual says 7.2L or something like that. It's more like 7.5-7.8 quarts to get to the top of the "XX" line on dipstick. I do check it with the engine hot after it is off for a few minutes too. I did a drain and fill of the trans about 30k ago, but just one drain and fill. I had enough to do 4 drain and fill's but after the third one I felt it was pretty red during draining. I had kind of a mix of fluids I bought on sale, mostly T-IV Toyota fluid with some Idemitsu T-IV. The clicking/clacking noise is starting to bother the wife where she wants a "real mechanic" to check it out. Maybe it is the CV joints going.... Guess I could buy the rebuild kits after I have a shop look at it.

    30. #413
      Member
      Join Date
      Sep 2013
      Location
      New York
      Posts
      1,040
      Quote Originally Posted by MjollnirXC60 View Post
      I also changed my transmission fluid last night with an oil change of Pennzoil Ultra Platinum. I swear my engine takes more oil than it's spec'd out to. Manual says 7.2L or something like that. It's more like 7.5-7.8 quarts to get to the top of the "XX" line on dipstick. I do check it with the engine hot after it is off for a few minutes too. I did a drain and fill of the trans about 30k ago, but just one drain and fill. I had enough to do 4 drain and fill's but after the third one I felt it was pretty red during draining. I had kind of a mix of fluids I bought on sale, mostly T-IV Toyota fluid with some Idemitsu T-IV. The clicking/clacking noise is starting to bother the wife where she wants a "real mechanic" to check it out. Maybe it is the CV joints going.... Guess I could buy the rebuild kits after I have a shop look at it.


      My transmission did not like the Toyota Type 4 fluid.. I ended up replacing with Volvo fluid and the car shifts much better.
      15 Volvo XC60 R-Design Platinum Pearl White Metallic, POLESTAR EXHAUST TDI Tuning Box, POLESTAR TUNED , IPD Rear Sway Bar and links, IPD POLY TORQUE ROD Koni FSD's, Eibach Loweing Springs, Powerflex Torque Bushing, Bloxsport wheel spacers
      Sold: 2008 Volvo C30 2.0 Java/Cosmic White, Manual, Elevate Tune, Weird OEM Mood Lighting Kit, EST Catback Exhaust, Koni STR.T, H&R Springs, Injen Intake, 19' BBS SR Wheels, Ion Yellow Fogs,
      SoldL 2006 Volvo V70R, Magic Blue, Stock

    31. #414
      Junior Member
      Join Date
      Jun 2020
      Posts
      23
      2017 XC60 Inscription T6.






      First I added a top tray to the arm rest storage area.

      A couple of days ago I installed 4 door handle cups. Nice to have the additional storage space.

      Before that, I bought a device that plugs into my cigarette lighter jack in the cup holder area and gives me 3 lighter jacks and 2 USB ports in the cubby behind the radio panel. USB ports were really lacking and I needed one jack for my phone holder/wireless charger. I'll need another if I install my Alexa Auto and one more if I use a radar detector.

      Last night I ordered a set of rubber liners for the cup holders, the door storage, the big armrest storage and a couple of other flat areas.

      Finally, I ordered a knee pillow for where my knee digs into the sloping chrome center console. Apparently I need a solid side because this physically hurts. I'm trying to make something permanent.

    32. #415
      Junior Member
      Join Date
      Jun 2019
      Location
      Chandler, AZ
      Posts
      27

      PCV, J-pipe Delete, OEM intake pipe Service

      Just Ticked over 130,500 miles and thought it time to do the PCV service on my T6 as well as replace the OEM intake pipe and j-pipe with an elevate j-pipe resonator delete.
      Hardest part of the job was getting the damn heat shield and foam mat out of there. The heat shield had some flat washer looking fasteners that were hard to get to, mostly because I have large hands and arms so it was quite the squeeze. Me and my dad did it together and all in it took about 5hrs to replace all 3 parts.

      Removing the cowl and battery plus the shield was not as hard as it sounded. Was worth it and the new VIDA SSD drive software helped make it an easy job, though time consuming.
      The OEM resonator pipe had so much oil in it I can't believe the turbo is still working!
      The OEM intake pipe broke off where it connects to the oil trap hose so It definitely had to be replaced.
      As you can see from the photos the Oil trap was loaded up with oil and definitely had to be replaced.
      The elevate j-pipe was a pain for fitment. The thing is so much larger than stock that it literally touches the passenger firewall.
      Now the intake noise is MUCH MORE pronounced in the cabin. You can hear every little suction noise through the cabin (with a/c off) and I'm quite pleased with it afterall.
      Not a bad way to spend some coin and time with my father installing these parts!

      [IMG] https://imgur.com/uECHm23 [/IMG]

      [IMG]https://imgur.com/WGOzEdt [/IMG]

      [IMG] https://imgur.com/tZCClTw[/IMG]

      [IMG]https://imgur.com/BN0jNGr [/IMG]

      [IMG]https://imgur.com/luMmIqS[/IMG]

      [IMG]https://imgur.com/Nc06l3R [/IMG]

      [IMG]https://imgur.com/6ikL5k7[/IMG]

      [IMG]https://imgur.com/GXxJhGU [/IMG]

      [IMG] https://imgur.com/JrtTbVt[/IMG]
      Last edited by estradaccord; 07-10-2020 at 01:20 PM.

    33. #416
      Junior Member
      Join Date
      Aug 2016
      Location
      Stillwater, OK
      Posts
      250
      Quote Originally Posted by spiked60 View Post
      Let there be light!
      Not sure why I didn't see this before, but sweet pics! Thing looks like a beast.
      2013 XC60 T6
      2015 V60CC T5

    34. Remove Advertisements

      Advertisements
       

    Page 12 of 12 FirstFirst ... 2 8 9 10 11 12