What did you do to your wagon today? - Page 204
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Page 204 of 223 FirstFirst ... 104 154 194 200 201 202 203 204 205 206 207 208 214 ... LastLast
    Results 7,106 to 7,140 of 7791
    1. #7106
      Junior Member
      Join Date
      Jul 2010
      Location
      Ontario, Canada
      Posts
      110
      I decided to take my timing belt cover off and check things out. Timing belt was walking off the edge of the cam pulleys. Dug a little further.. How does this tensioner look to you guys?


      2006 S40 2.4 and 2005 XC70 2.5T AWD

    2. Remove Advertisements

      Advertisements
       

    3. #7107
      Junior Member Drevolvo's Avatar
      Join Date
      Apr 2015
      Location
      Atlanta, GA
      Posts
      86
      Quote Originally Posted by Exocet View Post
      @skywolf would be proud!



      Sent from my iPhone using Tapatalk

    4. #7108
      Member Racer_S's Avatar
      Join Date
      Jan 2011
      Location
      Ithaca, NY
      Posts
      1,125
      Quote Originally Posted by vtl View Post
      Speakers are a wear items: you can't get quality from old speakers, even if they were "upscale" back in time.
      i can contest to that, i've been slowly replacing blown speakers in my wagons from my S60 partout years ago. i've started to run out of spares and have resorted to aftermarket at this point.
      2004 XC70 2.5T AWD Crystal Green Pearl/Charcoal [240K] Mud Guards, 05- Wiper Arms, 305mm brake upgrade, Full LED Exterior, 1-inch lift Pic
      2003 XC70 2.5T AWD Silver/Charcoal [190K] XeMODeX, Mud Guards, 05- Wiper Arms, LED Headlights
      2004 S80 2.5T AWD Crystal Green Pearl/Light Sand [240K] Bi-Xenon, LED Foglights, 07 Turbo and rear diff

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #7109
      Member Exocet's Avatar
      Join Date
      Nov 2017
      Location
      Southern Tier NY
      Posts
      2,494
      Quote Originally Posted by ScottishBrick View Post
      Depends on what they are? JY should be pretty safe compared to a lot of other places.


      Sent from my iPhone using Tapatalk
      An S60 and XC70. Nothing super special. But, you never know what you might find. Only see a handful of 05+ P2 models a year around here. Who knows how much contagion has been deposited on them. Of course, the longer they are there, the longer the exposure!
      2007 Volvo V70 2.5T - Mine
      2008 Nissan Titan SE 4x4, Crew Cab, Long Bed - Also Mine
      2012 Toyota Camry LE, 2.4 - Wife's
      2003 Mazda Protege5, 2.0 - Daughter #1
      2010 Mazda 6 Grand Touring, 2.5 - Daughter #2

    7. #7110
      Member Exocet's Avatar
      Join Date
      Nov 2017
      Location
      Southern Tier NY
      Posts
      2,494
      Quote Originally Posted by Racer_S View Post
      i can contest to that, i've been slowly replacing blown speakers in my wagons from my S60 partout years ago. i've started to run out of spares and have resorted to aftermarket at this point.
      What parts of the speakers are failing? I've run into a couple dead magnets from JY units. Drivers and surrounds have always been fine.
      2007 Volvo V70 2.5T - Mine
      2008 Nissan Titan SE 4x4, Crew Cab, Long Bed - Also Mine
      2012 Toyota Camry LE, 2.4 - Wife's
      2003 Mazda Protege5, 2.0 - Daughter #1
      2010 Mazda 6 Grand Touring, 2.5 - Daughter #2

    8. #7111
      Senior Member JaredR's Avatar
      Join Date
      Jan 2014
      Location
      Boston, MA
      Posts
      13,865
      Quote Originally Posted by Exocet View Post
      What parts of the speakers are failing? I've run into a couple dead magnets from JY units. Drivers and surrounds have always been fine.
      +1. Doesn't really make them a "wear item" imo.


      I would be way more worried about getting coronavirus going through the building to get in/out of the yard than getting it from a car in the yard.
      1995 850 T-5R Estate. AW50-42LE. Cream Yellow/Graphite. 297k.
      1997 850R Estate. B5234T9/M66D. Bright Red/Graphite. 270k.
      2007 S60 T5. M66W. Black Sapphire/Arena. 140k.
      Instagram: Jared's Volvo Page

      Past: |1997 855R. Bright Red/Light Beige. AW50-42LE. Totaled by wayward construction equipment. || 1996 854R. Black Stone/Graphite. AW50-42LE. Parts car || 1995 854 TURBO. Polar White/Tan. AW50-42LE. Parts car. |
      Dad: 1997 V70 T5 SE. AW50-42LE. Frost Green/Oak. 212k.Mom: NEW! 1999 S70 GLT Pewter/Oak. 101k. Past: 2004 V70 NA. AW55-50SN Ruby Red/Tan 269k. Sold to markj

    9. #7112
      Senior Member ScottishBrick's Avatar
      Join Date
      Dec 2014
      Location
      Connecticut
      Posts
      15,269
      Quote Originally Posted by Racer_S View Post
      i can contest to that, i've been slowly replacing blown speakers in my wagons from my S60 partout years ago. i've started to run out of spares and have resorted to aftermarket at this point.
      You've blown or worn out the premium audio speakers? Or just the stock paper speakers
      2003 V70 T5 - Mystic/Graphite - M56LK - 206k - K24/Greens/Do88/Quaife/SMF/P2R Clutch/DW300C/H&R/Bilstein TC/316mm & 308mm Brakes - SteveO Tuned
      1999 V70 T5 - Pewter/R Graphite & Alcantara - AW42 - 299k - Daily/Work Wagon
      1999 V70 T5 - Nautic/R Graphite & Alcantara - M56H - 177k - Rescued
      1999 V70 T5 - Emerald/Graphite - M56H - 119k - Garage Queen
      2000 V70 T5 - Mystic/Graphite - AW42 - 243k - Moms Unicorn
      2000 S70 GLT SE- Mystic/Graphite - AW42 - 218k - Sisters

    10. #7113
      Junior Member
      Join Date
      Oct 2010
      Posts
      581
      Quote Originally Posted by R-Pow3R3d View Post
      Is it a straight swap? What's it take to get the little side marker LED's to illuminate? The 07 XC70 I bought either has failed LEDs or they are non-existent and just the holes are there (couldn't quite tell, didn't try real hard). I ask because if everything is the same, I might take you up on an old set of lights so I can get rid of these and not risk getting dinged at inspection time for the LEDs not working.
      Maybe you need new bulbs or a fuse? Both the four side LEDs on the sets placed on a 2004 and a 2001 light up when the tails are illuminated.

    11. #7114
      Member Racer_S's Avatar
      Join Date
      Jan 2011
      Location
      Ithaca, NY
      Posts
      1,125
      Quote Originally Posted by Exocet View Post
      What parts of the speakers are failing? I've run into a couple dead magnets from JY units. Drivers and surrounds have always been fine.
      i've had what sounds like the coil starts scraping the magnet, or they just get really quiet.

      You've blown or worn out the premium audio speakers? Or just the stock paper speakers
      they were the stock paper speakers, ive had to replace 3 bad ones over the years.
      2004 XC70 2.5T AWD Crystal Green Pearl/Charcoal [240K] Mud Guards, 05- Wiper Arms, 305mm brake upgrade, Full LED Exterior, 1-inch lift Pic
      2003 XC70 2.5T AWD Silver/Charcoal [190K] XeMODeX, Mud Guards, 05- Wiper Arms, LED Headlights
      2004 S80 2.5T AWD Crystal Green Pearl/Light Sand [240K] Bi-Xenon, LED Foglights, 07 Turbo and rear diff

    12. #7115
      Member Exocet's Avatar
      Join Date
      Nov 2017
      Location
      Southern Tier NY
      Posts
      2,494
      Quote Originally Posted by JaredR View Post
      I would be way more worried about getting coronavirus going through the building to get in/out of the yard than getting it from a car in the yard.
      They no longer require you to go through the building. Sign in online. Discontinued the shuttle service. So, you have to schlep your treasures back up the hill on your own.
      2007 Volvo V70 2.5T - Mine
      2008 Nissan Titan SE 4x4, Crew Cab, Long Bed - Also Mine
      2012 Toyota Camry LE, 2.4 - Wife's
      2003 Mazda Protege5, 2.0 - Daughter #1
      2010 Mazda 6 Grand Touring, 2.5 - Daughter #2

    13. #7116
      Senior Member JaredR's Avatar
      Join Date
      Jan 2014
      Location
      Boston, MA
      Posts
      13,865
      Quote Originally Posted by Exocet View Post
      They no longer require you to go through the building. Sign in online. Discontinued the shuttle service. So, you have to schlep your treasures back up the hill on your own.
      That's fantastic. Wouldn't worry about it then. Gloves, work jacket, work pants, don't touch your face and take em off before you get in the car. Leave all your scores/tools/work clothes out in the sun for a day or two if you wanna be extra safe. Good to go.

      That said I've NEVER touched my face in public even before all this because that was always gross so I'm only worried about getting it through the air or from contaminated items coming into the house. Luckily we're pretty much in control of managing those risks as long as we can avoid going in a public building.
      Last edited by JaredR; 04-03-2020 at 07:06 PM.
      1995 850 T-5R Estate. AW50-42LE. Cream Yellow/Graphite. 297k.
      1997 850R Estate. B5234T9/M66D. Bright Red/Graphite. 270k.
      2007 S60 T5. M66W. Black Sapphire/Arena. 140k.
      Instagram: Jared's Volvo Page

      Past: |1997 855R. Bright Red/Light Beige. AW50-42LE. Totaled by wayward construction equipment. || 1996 854R. Black Stone/Graphite. AW50-42LE. Parts car || 1995 854 TURBO. Polar White/Tan. AW50-42LE. Parts car. |
      Dad: 1997 V70 T5 SE. AW50-42LE. Frost Green/Oak. 212k.Mom: NEW! 1999 S70 GLT Pewter/Oak. 101k. Past: 2004 V70 NA. AW55-50SN Ruby Red/Tan 269k. Sold to markj

    14. #7117
      Global Moderator R-Pow3R3d's Avatar
      Join Date
      Apr 2015
      Location
      Pittsburgh, PA
      Posts
      8,222
      Quote Originally Posted by zak View Post
      Maybe you need new bulbs or a fuse? Both the four side LEDs on the sets placed on a 2004 and a 2001 light up when the tails are illuminated.
      I just looked today with a flashlight to really illuminate and it doesn't look like the LEDs are in place. Here's a picture of a functional one:


      Mine just looks like 4 empty holes. I'm wondering if they've fallen out of place or something.
      2004 V70R MT TiGray/Nordkap - Replica 18" Pegs - Handbrake Mod
      2007 XC90 V8 Sport Passion Red/Off-Black - Serpentine Belt, Tensioner & Idler Pulleys - Spark Plug Replacement - Y-Pipe Replacement
      1990 745 Turbo Intercooler White/Beige
      2007 XC70
      VIDA/DICE Owner - SS Lurker Since 2009 - '06-'07 Transmission Valve Body Info - SR/VR Failing Throttle Body
      Current Non-Volvo: 2007 VTX 1800 F3, 2002 VT750DC
      Previous: 2006 S60R

    15. #7118
      Member Antherzoll's Avatar
      Join Date
      Dec 2013
      Location
      Toronto
      Posts
      4,962
      Washed it for the first time in months...

      Been too busy around here to do much else. Want to clean the interior, and I have a few small projects, but way too busy with the kids home full time and no way to escape...
      2005 XC70 Crystal Green | Hilton | 16T | Bad Swede | 145k mi

    16. #7119
      Member zmarshm1's Avatar
      Join Date
      Mar 2019
      Location
      Binghamton NY
      Posts
      1,062
      Thinking of getting my euro special wang on sometime soon with all this free time I've got, but it's not painted yet only primed
      has anyone used the 426 silver ebay touch up kits? Don't really feel like spending 100+ on getting it professionally done...

      https://www.ebay.com/itm/Scratchwiza...v2m3vqLxtGkKdQ
      https://www.ebay.com/itm/Color-Match...oYRSK4X2KKNjGA
      https://www.ebay.com/itm/For-Volvo-4....c100008.m2219

      Any recommendations other than these three? Also does anyone have a guide on putting the wing itself on?
      ||1998 s70 t5m - Stock, future gambler 500 car | 140k? miles
      ||2001 v70 t5 - IPD Sway bars | Delrin subframe bushings | Transmission cooler & mounted inline filter | Rostra long snout transmission solenoids | IPD catback exhaust & Rolling Motors 3" downpipe | Simota Carbon Charge Intake | Bilstein B4 & Eibach prokit lowering springs | 124k mi
      ||2003 v70 2.4t - First volvo | SOLD! Still driving around with 190k+ miles.
      Kanjo!!

    17. #7120
      Junior Member LukeFlynn's Avatar
      Join Date
      Feb 2019
      Location
      Knoxville, TN
      Posts
      193
      Quote Originally Posted by zmarshm1 View Post
      Thinking of getting my euro special wang on sometime soon with all this free time I've got, but it's not painted yet only primed
      has anyone used the 426 silver ebay touch up kits? Don't really feel like spending 100+ on getting it professionally done...

      https://www.ebay.com/itm/Scratchwiza...v2m3vqLxtGkKdQ
      https://www.ebay.com/itm/Color-Match...oYRSK4X2KKNjGA
      https://www.ebay.com/itm/For-Volvo-4....c100008.m2219

      Any recommendations other than these three? Also does anyone have a guide on putting the wing itself on?

      Did you do the ebay wing that doesn't have the brake light? I've been thinking about it
      '04 XC70 | Silver Metallic | Shimmed B5254T2 | K24 | M66 w/ SPEC single mass | IPD catback | Elevate sways | lowered on S60 AWD springs | Hilton Stage 3 Tune
      '09 S40 2.4i | Titanium Grey | Stock | 140k

    18. #7121
      Member zmarshm1's Avatar
      Join Date
      Mar 2019
      Location
      Binghamton NY
      Posts
      1,062
      Quote Originally Posted by LukeFlynn View Post
      Did you do the ebay wing that doesn't have the brake light? I've been thinking about it
      I think so, but I got it off Scottish who got it imported. Might be one of those ones from Lithuania? I know he does bulk orders so probably not but in essence prolly the same


      Sent from my iPhone using Tapatalk
      ||1998 s70 t5m - Stock, future gambler 500 car | 140k? miles
      ||2001 v70 t5 - IPD Sway bars | Delrin subframe bushings | Transmission cooler & mounted inline filter | Rostra long snout transmission solenoids | IPD catback exhaust & Rolling Motors 3" downpipe | Simota Carbon Charge Intake | Bilstein B4 & Eibach prokit lowering springs | 124k mi
      ||2003 v70 2.4t - First volvo | SOLD! Still driving around with 190k+ miles.
      Kanjo!!

    19. #7122
      Junior Member LukeFlynn's Avatar
      Join Date
      Feb 2019
      Location
      Knoxville, TN
      Posts
      193
      Quote Originally Posted by zmarshm1 View Post
      I think so, but I got it off Scottish who got it imported. Might be one of those ones from Lithuania? I know he does bulk orders so probably not but in essence prolly the same


      Sent from my iPhone using Tapatalk
      I see! Does he happen to have a thread for them, or just PM?

      Also, I'd probably try to spray paint, if it turns out great you saved yourself money, if it doesn't... guess you'll have to get it painted anyway.
      '04 XC70 | Silver Metallic | Shimmed B5254T2 | K24 | M66 w/ SPEC single mass | IPD catback | Elevate sways | lowered on S60 AWD springs | Hilton Stage 3 Tune
      '09 S40 2.4i | Titanium Grey | Stock | 140k

    20. #7123
      Member zmarshm1's Avatar
      Join Date
      Mar 2019
      Location
      Binghamton NY
      Posts
      1,062
      Quote Originally Posted by LukeFlynn View Post
      I see! Does he happen to have a thread for them, or just PM?
      I would just pm him good luck brother


      Sent from my iPhone using Tapatalk
      ||1998 s70 t5m - Stock, future gambler 500 car | 140k? miles
      ||2001 v70 t5 - IPD Sway bars | Delrin subframe bushings | Transmission cooler & mounted inline filter | Rostra long snout transmission solenoids | IPD catback exhaust & Rolling Motors 3" downpipe | Simota Carbon Charge Intake | Bilstein B4 & Eibach prokit lowering springs | 124k mi
      ||2003 v70 2.4t - First volvo | SOLD! Still driving around with 190k+ miles.
      Kanjo!!

    21. #7124
      Member zmarshm1's Avatar
      Join Date
      Mar 2019
      Location
      Binghamton NY
      Posts
      1,062
      Quote Originally Posted by LukeFlynn View Post

      Also, I'd probably try to spray paint, if it turns out great you saved yourself money, if it doesn't... guess you'll have to get it painted anyway.
      Yea they’re all spray I think, just didn’t wanna get a dollar store silver or bad brand, figured I’d try to paint match a bit. Guessed atleast someone here would have rattle canned something


      Sent from my iPhone using Tapatalk
      ||1998 s70 t5m - Stock, future gambler 500 car | 140k? miles
      ||2001 v70 t5 - IPD Sway bars | Delrin subframe bushings | Transmission cooler & mounted inline filter | Rostra long snout transmission solenoids | IPD catback exhaust & Rolling Motors 3" downpipe | Simota Carbon Charge Intake | Bilstein B4 & Eibach prokit lowering springs | 124k mi
      ||2003 v70 2.4t - First volvo | SOLD! Still driving around with 190k+ miles.
      Kanjo!!

    22. #7125
      Junior Member
      Join Date
      Jan 2020
      Posts
      27
      Tore apart the head unit on my new to me car.

      The HU-650 wouldn’t power on, even though all the wiring on the harness I repaired was showing proper voltage on the multimeter.

      Once I had the head unit apart, I found a copper inductor ring that had broken its’ solder. Once I fixed that, I had no issues from the radio. Pretty pleased with myself.

    23. #7126
      Senior Member ZZZZZZZ's Avatar
      Join Date
      Aug 2005
      Location
      Northern MD
      Posts
      14,444
      I sure wish you’d taken a video or some pics at least.
      Quote Originally Posted by JedisonsDad View Post
      Tore apart the head unit on my new to me car.

      The HU-650 wouldn’t power on, even though all the wiring on the harness I repaired was showing proper voltage on the multimeter.

      Once I had the head unit apart, I found a copper inductor ring that had broken its’ solder. Once I fixed that, I had no issues from the radio. Pretty pleased with myself.
      "The Real IPD" - ZZZZZZZ's thread
      2007 Passion Red/Gobi VRgt; 2005 Silver/Beige Leather S60 2.5T AWD; 2002 Silver/Off black leather V70XC
      Past: 1999 Tropic Blue/Green/Oak leather V70 (NAa); Mom traded 1975 Maroon/Maroon leather 164E

    24. #7127
      Junior Member
      Join Date
      Oct 2014
      Location
      Boston
      Posts
      677
      Quote Originally Posted by Antherzoll View Post
      Washed it for the first time in months...
      With new rubber it looks truly awesome, Antherzoll!

    25. #7128
      Junior Member
      Join Date
      Sep 2019
      Posts
      206
      Clay bar and wax




    26. #7129
      finally installed that tail light I bought like 3 years ago to replace a cracked one.
      painted the backup camera bracket that was looking terrible.

      and today maybe I'll go out and install this new pioneer head unit to repace the old one.
      android auto here we comes.

    27. #7130
      Member Antherzoll's Avatar
      Join Date
      Dec 2013
      Location
      Toronto
      Posts
      4,962
      Quote Originally Posted by vtl View Post
      With new rubber it looks truly awesome, Antherzoll!
      Thanks!

      Loving these tires. Fit is tight, but they're working well so far.

      Sanded and polished the head lights today. They weren't that bad, but there were some bigger scratches from bush wacking. POS plastic lenses.

      Before


      1000grit


      2000grit


      After


      Quick and easy project. I also have a Wipe New trim restore kit that I may get into is this isolation goes on long enough, seems like the application would be quite time consuming. I've got other projects that I'd like to get out of the way before I attempt it.
      2005 XC70 Crystal Green | Hilton | 16T | Bad Swede | 145k mi

    28. #7131
      Junior Member
      Join Date
      Jan 2020
      Posts
      27
      Quote Originally Posted by ZZZZZZZ View Post
      I sure wish you’d taken a video or some pics at least.
      Quote Originally Posted by JedisonsDad View Post
      Tore apart the head unit on my new to me car.

      The HU-650 wouldn’t power on, even though all the wiring on the harness I repaired was showing proper voltage on the multimeter.

      Once I had the head unit apart, I found a copper inductor ring that had broken its’ solder. Once I fixed that, I had no issues from the radio. Pretty pleased with myself.
      Ask and you shall receive.



      The head unit is fairly easy to take apart. Start with the cast iron back piece, and then remove the top “lid”. Once those panels are apart, the circuit board with the connectors on it slides up and out of the unit. The copper coil ring is what had broken solder on it. Dropped a new bit of solder and it works great now. Additionally, if you’re having issues with your volume knob being wonky, just turn the radio off and quickly spin the volume knob back and forth to clean the contacts.
      Last edited by R-Pow3R3d; 04-05-2020 at 03:52 PM.

    29. #7132
      Junior Member LukeFlynn's Avatar
      Join Date
      Feb 2019
      Location
      Knoxville, TN
      Posts
      193
      Uh oh, I've ordered an IPD catback for my XC. I went back and forth, I've heard a custom magnaflow and IPD in person, my R has an EST. I think the custom setup sounded best, but I slightly prefer the IPD to the EST, so that's what I went with. I toyed with a custom setup, but I really just wanted something I could buy and put in one evening at work with no fuss (sans the 210k downpipe bolts)
      '04 XC70 | Silver Metallic | Shimmed B5254T2 | K24 | M66 w/ SPEC single mass | IPD catback | Elevate sways | lowered on S60 AWD springs | Hilton Stage 3 Tune
      '09 S40 2.4i | Titanium Grey | Stock | 140k

    30. #7133
      Member Exocet's Avatar
      Join Date
      Nov 2017
      Location
      Southern Tier NY
      Posts
      2,494
      Installed new wiper blades up front and cleaned the cargo cover I got from the JY over the winter. It had a couple of footprints on it. Go figure. But, almost like new. Finished up by swapping the right axle with the Trakmotive unit to see if the vibration that developed a month ago got better. It didn't. Also, noticed a little oil seepage around the axle seals. They were dry last fall.
      2007 Volvo V70 2.5T - Mine
      2008 Nissan Titan SE 4x4, Crew Cab, Long Bed - Also Mine
      2012 Toyota Camry LE, 2.4 - Wife's
      2003 Mazda Protege5, 2.0 - Daughter #1
      2010 Mazda 6 Grand Touring, 2.5 - Daughter #2

    31. #7134
      Member zmarshm1's Avatar
      Join Date
      Mar 2019
      Location
      Binghamton NY
      Posts
      1,062
      Made some quarantine plans for tomorrow


      Sent from my iPhone using Tapatalk
      ||1998 s70 t5m - Stock, future gambler 500 car | 140k? miles
      ||2001 v70 t5 - IPD Sway bars | Delrin subframe bushings | Transmission cooler & mounted inline filter | Rostra long snout transmission solenoids | IPD catback exhaust & Rolling Motors 3" downpipe | Simota Carbon Charge Intake | Bilstein B4 & Eibach prokit lowering springs | 124k mi
      ||2003 v70 2.4t - First volvo | SOLD! Still driving around with 190k+ miles.
      Kanjo!!

    32. #7135
      Member TGO's Avatar
      Join Date
      Mar 2007
      Location
      Staten Island NY
      Posts
      2,466
      More than a year after buying then I finally installed my replacement seat covers from lseat.com.

      Also replaced the seat cushion on the driver's side because it was shot as well.

      Quality is ok. They seem a little more loose than factory even though I stretched and got them as tight as I could.

      Hoping the heat from the sun smooths them out over time.

      Easier just to replace the seats if you can get good quality ones locally. I couldn't. And you can only get the fronts so I'm still on the lookout for a replacement rear seat.
      Attached Images Attached Images
      2002 XC70 2.4T - "Orca"
      White/Sand(Beige)

    33. #7136
      Junior Member
      Join Date
      Oct 2014
      Location
      Boston
      Posts
      677
      Quote Originally Posted by Antherzoll View Post
      Sanded and polished the head lights today. They weren't that bad, but there were some bigger scratches from bush wacking. POS plastic lenses.
      Had to polish my headlight regularly, typically twice a year. Last one was ~2.5 years ago. This was the cure: https://www.lamin-x.com/precut-film-...ht-covers.html

      Few days after application (trapped water needs time to evaporate):


      Quote Originally Posted by Antherzoll View Post
      Quick and easy project. I also have a Wipe New trim restore kit that I may get into is this isolation goes on long enough, seems like the application would be quite time consuming. I've got other projects that I'd like to get out of the way before I attempt it.
      It is time consuming, but take all time you need for the best result! Degrease well, take care not to touch paint with Wipe New applicator. Properly done Wipe New lasts for years!

    34. #7137
      Junior Member
      Join Date
      Oct 2014
      Location
      Boston
      Posts
      677
      Took apart my old frozen IPD HD TCV: stopped working within a year. Also known as Snabb, VIVA, name it. Cheap junk sold with huge premium.


    35. #7138
      Junior Member LukeFlynn's Avatar
      Join Date
      Feb 2019
      Location
      Knoxville, TN
      Posts
      193
      Quote Originally Posted by vtl View Post
      Took apart my old frozen IPD HD TCV: stopped working within a year. Also known as Snabb, VIVA, name it. Cheap junk sold with huge premium.

      I knew something was up when all the tuners started refusing tunes for cars with these. I guess pierburg is the way to go
      '04 XC70 | Silver Metallic | Shimmed B5254T2 | K24 | M66 w/ SPEC single mass | IPD catback | Elevate sways | lowered on S60 AWD springs | Hilton Stage 3 Tune
      '09 S40 2.4i | Titanium Grey | Stock | 140k

    36. #7139
      Senior Member ZZZZZZZ's Avatar
      Join Date
      Aug 2005
      Location
      Northern MD
      Posts
      14,444
      How long would normally fogged plastic lenses take to do? Didn’t look too hard at the link but I’d venture to say those ought to fit an 05 s60, right?
      Quote Originally Posted by vtl View Post
      Had to polish my headlight regularly, typically twice a year. Last one was ~2.5 years ago. This was the cure: https://www.lamin-x.com/precut-film-...ht-covers.html

      Few days after application (trapped water needs time to evaporate):



      It is time consuming, but take all time you need for the best result! Degrease well, take care not to touch paint with Wipe New applicator. Properly done Wipe New lasts for years!
      Last edited by ZZZZZZZ; 04-05-2020 at 09:25 PM.
      "The Real IPD" - ZZZZZZZ's thread
      2007 Passion Red/Gobi VRgt; 2005 Silver/Beige Leather S60 2.5T AWD; 2002 Silver/Off black leather V70XC
      Past: 1999 Tropic Blue/Green/Oak leather V70 (NAa); Mom traded 1975 Maroon/Maroon leather 164E

    37. #7140
      Member Antherzoll's Avatar
      Join Date
      Dec 2013
      Location
      Toronto
      Posts
      4,962
      Quote Originally Posted by vtl View Post
      Had to polish my headlight regularly, typically twice a year. Last one was ~2.5 years ago. This was the cure: https://www.lamin-x.com/precut-film-...ht-covers.html

      Few days after application (trapped water needs time to evaporate):



      It is time consuming, but take all time you need for the best result! Degrease well, take care not to touch paint with Wipe New applicator. Properly done Wipe New lasts for years!
      Interestingly my headlight have the Laminx. I applied it on April 2017, 3yrs later and there's light oxidation on the upper edge which get hit by the harshest rays.. They've held up well over the years, much better than the plastic lenses would have, but yeah, I sanded and polished the laminx film and it actually turned out much better than expected.

      Before


      After


      I could replace the film, but for 15mins a side I gave it a try and I'm happy with it.
      2005 XC70 Crystal Green | Hilton | 16T | Bad Swede | 145k mi

    38. Remove Advertisements

      Advertisements
       

    Page 204 of 223 FirstFirst ... 104 154 194 200 201 202 203 204 205 206 207 208 214 ... LastLast