Electrical Problem w/ Driver's Door
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 20 of 20
    1. #1
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363

      Unhappy Electrical Problem w/ Driver's Door

      I have this problem intermittently for the past year. Sometimes when I first start my XC, all of the switches and lights on the driver's door are dead. The lock/ unlock switch, the mirror controls, and the window switches all do not work. The backlighting in these switches does not function either. If I begin to drive away and the auto-lock fires, all of the doors lock except for the driver's door. I can reach across the vehicle and operate the windows and lock/ unlock switches at the other doors while the driver's door switches remain non-functional. After a few minutes, the switches on the driver's door light up and everything works normally. I've never had the problem last for more than 2-3 minutes.

      I have video footage of this problem happening multiple times and the XC has been at the dealer once already for this problem (they reprogrammed something but the problem persists). The XC will be going back to the dealer in 2 weeks for a second attempt at a fix. It's a 2013 T6 with 42K miles.

      Has anyone else had a similar or identical problem? If so, what was the fix? I'd like to help point my dealer in the correct direction. When I picked the vehicle up from the dealer last time, the service advisor admitted that they would have to call Volvo if the reprogramming did not fix the problem. I am worried that something expensive is dying and I'm afraid that it won't completely die until after the warranty expires @ 50K. I do not want to be stuck with the repair bill for a problem that began while the warranty was still effective.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Jan 2011
      Location
      Arizona
      Posts
      988
      My guess would be the Driver Door Module (DDM). I have seen a few in P3 cars with burnt pins that have symptoms you describe.

      Very easy to check, too. Remove door panel, unplug both connectors at DDM and look at the pins.
      2007 S40 T5

    4. #3
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      I confirmed this weekend that the problem actually affects both the driver's front door and also the driver's side rear door. To add to the frustration, today the vehicle would not lock for me. I have the PCC and I could not lock my XC after a short trip. I tried pressing the buttons on the driver's front door, the driver's side rear door, and the buttons on the PCC itself. When I then opened the driver's door, the alarm went off.

      I had an appointment at the dealer scheduled for this past Friday but my dealer called and cancelled two days before the appointment; they told me that they "had overbooked themselves." I made the appointment 3 weeks prior so I was and remain frustrated.

      Could it still be the DDM if the problem affect the driver's side rear door as well?
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Oct 2015
      Location
      Alabama
      Posts
      22
      Have not experienced the problem you describe in my 2010 (and hope I don't), but we did have an issue right at 49k+, just before the warranty expired, where our driver's rear view mirror stopped adjusting. The problem perplexed the Volvo service Dept. in Montgomery so badly, that it took us three trip's there to finally learn that it was a wiring harness problem and to allow for the painstaking process of repairing it.
      Not exactly the same problem, but perhaps your problem also stems from faulty wire harnesses?

      WAS

    7. #5
      Junior Member
      Join Date
      Jul 2013
      Location
      Belarus
      Posts
      77
      Before blaming DDM I would check wire harness first.
      Properly check power and ground cables.
      In these cars wires are worse than in the previous generation.

    8. #6
      Junior Member
      Join Date
      Oct 2015
      Location
      Alabama
      Posts
      22
      My Volvo service department originally suspected the DDM too, but quickly eliminated it from the list of potential problems on our first visit there.

    9. #7
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      I dropped my XC60 off Friday morning at the dealer to get this issue sorted. They ordered a part and said that the part would be in Monday (tomorrow). I didn't ask what part they ordered, but I will share what was replaced after I pick it up. I'm guessing the DDM; hopefully this fixes my electrical problem.

      On a side note, they gave my 2016 T5 AWD Premier as a loaner. The T5 definitely doesn't move the XC as effortlessly as the T6 does.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    10. #8
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      Just as you all suggested, the dealer replaced the DDM.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    11. #9
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      I think I spoke too soon. Two nights ago, both doors on the driver's side were again dead after a short drive to a local restaurant. The vehicle would not lock with the keyfob or the buttons on the door handles. I haven't noticed the dead doors after initial startup since they made the repair, but with the temperature dropping, I am not trying to roll my window down as soon as I get in my XC like I do in the warmer months.

      Perhaps the wiring harness is to blame after all?

      Back again to the dealer I will go...
      Last edited by Thomas.brian23; 11-11-2015 at 09:53 AM.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    12. #10
      Junior Member
      Join Date
      Jun 2014
      Location
      TN
      Posts
      226
      After almost a full year with no issues, I got a couple of Urgent Airbag warnings. The first time the dealer said there was a software update that they installed.
      The second time, they replaced the wiring harness, which is located in the driver door. Obviously, my electrical issue was different, but the problem was in the door. The replacement harness seems to have solved the issue. Dealer could not have handled this situation any better. They gave me a loaner & called every day to keep me posted on parts arrival, etc.
      2018 XC60 T6 Inscription, Pine Grey, Maroon Brown Interior, Polestar, Advanced, Vision, Convenience, Protection, Air Suspension, B&W, etc

    13. #11
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      I figured I should post an update. The problem persists and seems to becoming more frequent. My XC is back at the dealer for the second time since the DDM was replaced back in October (this is now the 4th repair attempt). I emailed some video footage of the problem to the service advisor this time. The car currently sits at 49,5XX so the warranty will be expiring very shortly. The service advisor asked me if a technician could drive the vehicle home at night, a request to which I agreed. I told the service advisor that I didn't want the vehicle back until they had figured it out so I expect to be in this loaner XC60 T5 AWD for a few more days. The backup camera, nav, BLIS, and power tailgate are nice features for sure, but I do miss my T6 and heated seats. Brrr!

      It seems like the power comes back to the door after a minute has passed. Is there anything in these vehicles that comes online or is tied to a 1:00 minute timing after starting the car?
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    14. #12
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      The dealer kept my XC for almost 2 weeks and was only able to verify the problem once. It did act up once when I was explaining to the service advisor what was happening. He jiggled the connection between the driver's door and the instrument panel and the door went live (it was dead when the service advisor was messing around). While investigating the issue, the dealer did find a bunch of inactive codes for loss of communication with the DDM.

      The morning I took it to the dealer, the door was dead upon startup. It turned back on (as usual) after about minute. I then opened the driver's door again and the panel went dead again for another minute. This makes me think that the problem surfaces after the door is opened/ closed and actually has nothing to do with the car's initial start-up. All that leads me to believe that it's the physical connection between the driver's door and instrument panel that is faulty.

      Despite me explaining all of the above to the service manager, they replaced the DDM for the second time. I told my service advisor and the service manager that I had very low confidence in this actually fixing the problem but they assured me that "they did what Volvo told them to do." I find it extremely unlikely that I got 2 DDMs with the same odd electrical problem, but we will see. My XC has been behaving since I picked it up.

      On an unrelated note, they found an oil leak off the turbo that was also repaired. Yikes. I am currently considering trading the vehicle for a 2015 w/ 16K miles and a 7 year/ 100K warranty. I am very nervous about owning this 2013 out of warranty.
      Last edited by Thomas.brian23; 03-11-2016 at 09:20 AM.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    15. #13
      If problem persists, or if you care to look.

      Open the door. See the wiring running from the body to the door. It's inside that rubber cover. Pull the cover back from the door side. It just pulls off. Inspect the wiring where the zip tie is.

      I have seen more than a few wires break at that location. Opening and closing the door reveals the problems as it breaks contact. Driving for a minute may hit a bump and cause reconnection.

      Just repaired one the other day.

    16. #14
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      Thanks for the direction, CB. I'll try to take a look this afternoon.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    17. #15
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      The problem reappeared after driving the vehicle less than 200 miles. It's back at the dealer again for repair attempt #5.

      I did try to pull back the rubber cover to inspect the wiring but I was afraid to pull too for fear of breaking something.

      I already contacted Volvo customer care about extending the warranty on my vehicle because of this issue and they denied me any assistance. I'm going to contact them again since my vehicle is now back again for repair. Are there any tips for language I could use to better my case?
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    18. #16
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      It's back from repair attempt #5. This time, the dealer replaced the DDM for a 3rd time (doh!) and also a wiring harness. I cannot believe they replaced the DDM again. I think that it's very unlikely that I had 3 "bad" DDMs that all caused the same strange problem. Hopefully the new wiring harness will finally cure this problem.

      In total, Volvo has had my XC60 for 26 calendar days over 5 separate repair attempts for this same issue. I am still waiting to hear back from Volvo customer care to see if they are willing to offer me any assistance towards an extended warranty for my vehicle.

      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    19. #17
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      Volvo Customer Care denied me any extended warranty assistance for the second time. I suppose that their answer would have been different had I purchased the vehicle new. (I bought it when it was a year old with 12K.)

      Oh well :/
      Last edited by Thomas.brian23; 04-30-2016 at 09:52 AM.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    20. #18
      Junior Member Maddo's Avatar
      Join Date
      Dec 2014
      Posts
      158
      Do you have a consumer regulator who you can complain to?
      MY15.5 XC60 D5 AWD Luxury. P*. Driver Support Package. Front Blind View. Savile Grey
      1983 240 DL Beige (The old family car which lasted 17yrs)

    21. #19
      Junior Member
      Join Date
      Feb 2019
      Posts
      1
      Did replacing the wire harness do the trick? I am starting to experience similar problems on my XC70 and now suspect that might be the issue.

    22. #20
      Junior Member Thomas.brian23's Avatar
      Join Date
      Apr 2014
      Location
      USA
      Posts
      363
      Yes, replacing the wiring harness fixed my problem. It’s been fine for nearly four years now.
      2013 XC60 T6 AWD
      2018 VW GTI SE 6MT

    23. Remove Advertisements

      Advertisements