Any update on throttle lag? - Page 3
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Page 3 of 3 FirstFirst 1 2 3
    Results 71 to 80 of 80
    1. #71
      Junior Member
      Join Date
      Apr 2018
      Location
      Boston, MA
      Posts
      96
      Anybody with a 2018 experiencing this? I haven't, but I do notice that sometimes at full throttle the car accelerates effortlessly and sometimes it seems to struggle. Never a hesitation and then go, just sometimes not as fast as others.

    2. Remove Advertisements

      Advertisements
       

    3. #72
      Junior Member
      Join Date
      Jan 2016
      Posts
      45
      I have had a 2017 T8 for 2 years, and I just experienced this issue for the first time a few weeks ago. It happens pretty consistently when I'm at a low speed, basically idling, and I hit the gas. It's just a complete lack of response from the vehicle almost as if the gas input wasn't recognized. It's horrible and dangerous. I see no one has posted about this since April. Has anyone with this issue had any luck diagnosing the problem yet?

      I have experienced this throttle lag issue in Pure, Hybrid, and Power modes.

    4. #73
      Junior Member
      Join Date
      Sep 2015
      Posts
      26
      I had the same thing. Went to the dealer, they diagnosed a pressure leak in the turbo system. Took a few hours to fix and the car was as good as new.

      Quote Originally Posted by crazycabbie View Post
      I have had a 2017 T8 for 2 years, and I just experienced this issue for the first time a few weeks ago. It happens pretty consistently when I'm at a low speed, basically idling, and I hit the gas. It's just a complete lack of response from the vehicle almost as if the gas input wasn't recognized. It's horrible and dangerous. I see no one has posted about this since April. Has anyone with this issue had any luck diagnosing the problem yet?

      I have experienced this throttle lag issue in Pure, Hybrid, and Power modes.

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #74
      Junior Member
      Join Date
      Jan 2016
      Posts
      45
      Quote Originally Posted by mykel View Post
      I had the same thing. Went to the dealer, they diagnosed a pressure leak in the turbo system. Took a few hours to fix and the car was as good as new.
      Good to know. Thanks for the response!

    7. #75
      Junior Member
      Join Date
      Jan 2018
      Location
      Boston
      Posts
      209
      The only remedy for me in my 2016 T6 is to drive exclusively in dynamic mode. If I am going around town and need to make a left across traffic, I do not feel safe in Comfort mode but the added pep from Dynamic feels right.
      It's too bad, because I like the ride quality of Comfort mode but the throttle response is unacceptable

    8. #76
      Junior Member
      Join Date
      Jul 2017
      Posts
      259
      Quote Originally Posted by LukeyBL View Post
      The only remedy for me in my 2016 T6 is to drive exclusively in dynamic mode. If I am going around town and need to make a left across traffic, I do not feel safe in Comfort mode but the added pep from Dynamic feels right.
      It's too bad, because I like the ride quality of Comfort mode but the throttle response is unacceptable

      Setup individual mode to use the throttle mapping of Dynamic but the handling/steering of comfort.
      '18 XC90 Inscription
      Crystal White, Maroon Brown, 4C, B&W, Convenience, 21" 8 Spoke Wheels, P*

    9. #77
      Junior Member
      Join Date
      Mar 2016
      Posts
      261
      Makes me think the problem is not necessarily a turbo pressure issue solely. There definitely seems to be a problem with the ECM.

      Quote Originally Posted by ADM17 View Post
      Quote Originally Posted by LukeyBL View Post
      The only remedy for me in my 2016 T6 is to drive exclusively in dynamic mode. If I am going around town and need to make a left across traffic, I do not feel safe in Comfort mode but the added pep from Dynamic feels right.
      It's too bad, because I like the ride quality of Comfort mode but the throttle response is unacceptable

      Setup individual mode to use the throttle mapping of Dynamic but the handling/steering of comfort.

    10. #78
      Junior Member
      Join Date
      Sep 2015
      Posts
      26
      From what I read on the forum, you're most probably right. It just seems there might actually be two issues. If you have sluggish performance in all modes like I did, plus jerky movements sometimes, it might be a pressure problem.
      If it just happens in one drive mode then it seems to be a software issue.

      Quote Originally Posted by LuminousSands View Post
      Makes me think the problem is not necessarily a turbo pressure issue solely. There definitely seems to be a problem with the ECM.

    11. #79
      Awaiting Approval
      Join Date
      Sep 2019
      Posts
      2
      Am considering a XC90 T6 but came across this thread from 2 years ago.

      Does anybody still experience the throttle lag issue with their 2018 or 2019 XC90? Would really appreciate some candid advices. Did this problem go away with recent XC90 model years? Or did people just adapt to this issue by accelerating harder to compensate for the throttle lag?

    12. #80
      Junior Member
      Join Date
      Sep 2019
      Posts
      26
      Did a summary on this lag issue, as its not easy to find it when needed

      Option 1. (recommended, I am using after each 2-3K Km)
      https://forums.swedespeed.com/showth...=1#post5478553

      Option 2. (from this topic)
      https://forums.swedespeed.com/showth...=1#post5889273

      Option 3.

      https://forums.swedespeed.com/showth...=1#post6774386

      p.s. Probably need to be sticky, a its applied to all SPA with its 'learning feature'.

    13. Remove Advertisements

      Advertisements
       

    Page 3 of 3 FirstFirst 1 2 3