New member with some R issues
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 12 of 12
    1. #1
      Junior Member
      Join Date
      Jan 2019
      Location
      Atlanta, GA
      Posts
      20

      New member with some R issues

      Hello everyone! I'm new to R world but had an 850 wagon in the past. I've always wanted a V70R and recently got the chance to buy one with relatively low miles for its age. It's a 2004 and I got it for a steal but that means it also came with its fair share of issues that I've been slowly picking at a few at a time.
      IMG_0225 by brandon harder, on Flickr
      It's had a check engine light caused by an evap code pretty much since I got it (the light came on on the way home after buying the car of course). I replaced the gasket on the gas cap but no luck. However, I think I just found the problem. I'm doing some tuneup items and an oil change and just got under the car for the first time and spotted this broken line. It runs from the fuel tank area to just under the intake on the front of the engine. Nothing is leaking out of it so I'm guessing it's emissions related. Is it just a broken line or is there a part missing?
      IMG_0228 by brandon harder, on Flickr
      IMG_0233 by brandon harder, on Flickr
      I also discovered my turbo is leaking oil. In addition to the external leak, there was some in the metal intake tube that runs across the top of the motor at both ends. I remember coming across some articles related to a common turbo oil leak but don't remember what it was.
      IMG_0231 by brandon harder, on Flickr
      IMG_0229 by brandon harder, on Flickr
      Lastly, it seems as though my transmission might be leaking around the drivers side axle input. This doesn't appear to be oil from the turbo as it's just concentrated around the axle area and is not directly under the turbo. Sadly, it's an automatic. I'm guessing there is a gasket or seal there that will need to be replaced. Good thing I saw it before flushing my trans with a bunch of expensive Redline oil!
      IMG_0232 by brandon harder, on Flickr

      P.S. If anyone is in the Atlanta area and can recommend a reputable shop to install some BC coilovers, IPD rear alignment kit, and do an alignment I'm all ears. I'm new to the area and have no idea where to go.

      Thanks for all your help!!

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Senior Member ZZZZZZZ's Avatar
      Join Date
      Aug 2005
      Location
      Northern MD
      Posts
      13,033
      Reach out to skywolf. He knows Atlanta well, and is all about the wagons.
      Subscribed, as I have the save evap code time to time and will have to inspect that area on next oil change (maybe this holiday weekend). I do think it's emissions related. I replaced my cap gasket too. Not eliminated.
      "The Real IPD" - ZZZZZZZ's thread
      2007 Passion Red/Gobi VRgt; 2005 Silver/Beige Leather S60 2.5T AWD; 2002 Silver/Off black leather V70XC
      Past: 1999 Tropic Blue/Green/Oak leather V70 (NAa); Mom traded 1975 Maroon/Maroon leather 164E

    4. #3
      Member BlkT5's Avatar
      Join Date
      Oct 2003
      Location
      Victoria, BC
      Posts
      1,363
      The cracked hose is the EVAP line. Fix that and it should fix the EVAP code.

      It's somewhat common to see oil on the turbo compressor housing. Make sure your intake pipe to the turbo isn't cracked at the bottom. You'll need to remove it to inspect.

      The oil on your angle gear is likely a separate problem. Could be an axle seal, it's difficult to tell from the picture. I would clean all the oil off, go for a drive and re-inspect.
      Yellow 95 850 T-5R - SOLD
      Black 98 S70 T5M - Heavily modded
      Laser 00 V70 R 6MT - 03 T5 motor M66 AWD swapped
      Sappicama 04 V70 R 6MT - Hilton Stage 1
      Magicama 05 S60 R 6MT - Stock

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Senior Member Wayne T5's Avatar
      Join Date
      Nov 2002
      Location
      Russell Twp, OH
      Posts
      10,964
      Good catch on that hose - that's more than likely causing the evap code.

      A little bit of oil on the outside of the turbo or in the plumbing is pretty typical on these cars at this point (15 years old) so I don't know that I'd worry about that at this point.

      The second to last picture you posted appears to be the angle gear and it looks pretty wet so I'd check the fluid level asap and look into having the seals replaced - it's not cheap but at least it's cheaper than a new angle gear.
      Past: '94 854, '99 S70 T5 SE, '99 S70 GLT, '04 S60R M, '12 S60 T5, '13 S60 T5, '15 S60 RD, '05 V70R GT
      Present: '95 854 T-5R, '06 XC70, '15.5 XC60 T6, '16 V60 P*

    7. #5
      Senior Member ZZZZZZZ's Avatar
      Join Date
      Aug 2005
      Location
      Northern MD
      Posts
      13,033
      If this is you, nice work.
      You need to update the site...
      "The Real IPD" - ZZZZZZZ's thread
      2007 Passion Red/Gobi VRgt; 2005 Silver/Beige Leather S60 2.5T AWD; 2002 Silver/Off black leather V70XC
      Past: 1999 Tropic Blue/Green/Oak leather V70 (NAa); Mom traded 1975 Maroon/Maroon leather 164E

    8. #6
      Junior Member
      Join Date
      Jan 2019
      Location
      Atlanta, GA
      Posts
      20
      Thanks everyone! So the hose is just broken, there isn't a part missing or anything? I'll see if I can fix it with a barbed nipple and some zip ties. It looks as though the oil on the angle gear is coming from the turbo directly above it but I'll definitely clean it and see what happens.

    9. #7
      Junior Member
      Join Date
      Jan 2019
      Location
      Atlanta, GA
      Posts
      20
      Quote Originally Posted by ZZZZZZZ View Post
      If this is you, nice work.
      You need to update the site...
      Yep, that's me. And thanks! You're correct, the site hasn't been updated in a long time. I'm currently in transition to a new site that encompasses more of what I'm currently up to (less sculpture, more art installation and furniture construction). Check out www.BHADforyou.com. It's still a work in progress however.

    10. #8
      Senior Member ZZZZZZZ's Avatar
      Join Date
      Aug 2005
      Location
      Northern MD
      Posts
      13,033
      Been a crunched and tight week as I'm out tomorrow and Friday. I was surfing at lunch and thought I'd look you up.
      Brian (skywolf) may be in Europe on a trip this week, but he's a good dude, and a little OCD about his cars, so you'll know who's good and bad to work on them from him.
      Quote Originally Posted by brandonharderart View Post
      Yep, that's me. And thanks! You're correct, the site hasn't been updated in a long time. I'm currently in transition to a new site that encompasses more of what I'm currently up to (less sculpture, more art installation and furniture construction). Check out www.BHADforyou.com. It's still a work in progress however.
      "The Real IPD" - ZZZZZZZ's thread
      2007 Passion Red/Gobi VRgt; 2005 Silver/Beige Leather S60 2.5T AWD; 2002 Silver/Off black leather V70XC
      Past: 1999 Tropic Blue/Green/Oak leather V70 (NAa); Mom traded 1975 Maroon/Maroon leather 164E

    11. #9
      Junior Member
      Join Date
      Mar 2016
      Posts
      14
      I'm the first one to say, stay away from the "Stealership", buttttt...Jim Ellis of Volvo of Marietta has serviced my car from day one. They do excellent work, never had a problem out of them, and all of their work (less wear and tear stuff, brakes, tires..etc) is warrantied for life. Ask for Grant. They are really a great group.

    12. #10
      Junior Member
      Join Date
      Jan 2019
      Location
      Atlanta, GA
      Posts
      20
      Quote Originally Posted by ATL-GP View Post
      I'm the first one to say, stay away from the "Stealership", buttttt...Jim Ellis of Volvo of Marietta has serviced my car from day one. They do excellent work, never had a problem out of them, and all of their work (less wear and tear stuff, brakes, tires..etc) is warrantied for life. Ask for Grant. They are really a great group.
      Thanks! Are they okay with installing aftermarket parts?

    13. #11
      Junior Member
      Join Date
      Mar 2016
      Posts
      14
      Yes; however, they can not give you the lifetime warranty on aftermarket parts. Now, will they do a meth injections system...probably not, but exhaust, headers, new turbo...I think they will. I know for a fact they will do an exhaust, no problem. To this end, if your're thinking about heavily modifying the car, you may be better off finding an independent shop to do that, as they will probably be cheaper. My main reason for using the dealership is the lifetime warranty on parts and labor. They recently replaced my throttle body (about 1300 bucks!), couple weeks later, I had a reduce engine performance message. Took it right back, they found that the connections to the new throttle body were having a signal issue, they replaced all the wires and everything for NOTHING!! Apparently, there is a kit from Volvo that address the issues with connections to the TB after a replacement. ...stuff like that keeps me coming back to them.

    14. #12
      Junior Member
      Join Date
      Jan 2019
      Location
      Atlanta, GA
      Posts
      20
      Just an update. After putting that broken hose back together and driving several days the CEL has not returned! I love it when the fix is free.

      I also wanted to point out that while doing other maintenance, spark plugs and coil packs, the old plugs I pulled out had a gap of .043!

      I did clean the underside of the turbo and the trans and angle gear housing to determine where the leaks may be coming from but haven't had a chance to get back under the car.

    15. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. new member 220 member
      By 122344gt in forum Amazon P120, P130 & P220 (1956-1970)
      Replies: 3
      Last Post: 02-20-2016, 06:05 PM
    2. V50 brake issues, or maybe garage issues, or maybe just issues
      By acezero in forum S40 & V50 (2005-2012)
      Replies: 10
      Last Post: 09-27-2014, 10:49 PM
    3. Replies: 12
      Last Post: 10-26-2011, 04:36 PM
    4. Senoir member, Member, Junior member... I don't get it?
      By TheDane in forum S40 & V50 (2005-2012)
      Replies: 37
      Last Post: 07-29-2010, 12:39 AM
    5. New member, new ride - Some questions
      By drevilkep in forum XC90 (2003 - 2014)
      Replies: 7
      Last Post: 03-21-2009, 12:42 PM