Installed new headunit and now I have SRS service urgent warning
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 9 of 9
    1. #1
      Junior Member
      Join Date
      Jan 2019
      Location
      Atlanta, GA
      Posts
      20

      Installed new headunit and now I have SRS service urgent warning

      I installed a new head unit in my '04 V70R yesterday and everything worked fine except I was getting engine whine through the speakers. Pulled it back out today to make some adjustments after researching issues with the factory amp adapter cable. I hooked the battery back up to test it out and noticed I had an SRS Service Urgent warning on the dash that wasn't there before. The only thing that was different from yesterday is I forgot to plug the AC unit back in before hooking the battery back up. Could that have tripped the warning or is there something else in that area that I could have hit? I didn't unplug anything else.
      Thanks

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Mar 2018
      Posts
      135
      The climate tripped the message. Just plug it back in and clear the code

      Sent from my SM-G955U1 using Tapatalk

    4. #3
      Junior Member
      Join Date
      Jan 2019
      Location
      Atlanta, GA
      Posts
      20
      Thanks, I was hoping that's what it was. Can I clear it by unplugging the battery again or does it need to be done with a reader and software?

      Quote Originally Posted by Rm81 View Post
      The climate tripped the message. Just plug it back in and clear the code

      Sent from my SM-G955U1 using Tapatalk

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Mar 2018
      Posts
      135
      Best to use vida

      Sent from my SM-G955U1 using Tapatalk

    7. #5
      Member Exocet's Avatar
      Join Date
      Nov 2017
      Location
      Southern Tier NY
      Posts
      2,010
      Always disconnect the battery before disconnecting the CCM. I think you need VIDA to clear it.
      2007 Volvo V70 2.5T - Mine
      2008 Nissan Titan SE 4x4, Crew Cab, Long Bed - Also Mine
      2012 Toyota Camry LE, 2.4 - Wife's
      2003 Mazda Protege5, 2.0 - Daughter #1
      2010 Mazda 6 Grand Touring, 2.5 - Daughter #2

    8. #6
      Junior Member
      Join Date
      Jan 2019
      Posts
      72
      I made the mistake of unplugging my CCM to change a bulb, and now the warning won't clear on the console. It doesn't show up on vida, only on the dash...

    9. #7
      Junior Member
      Join Date
      Mar 2018
      Posts
      135
      Quote Originally Posted by neonshaun View Post
      I made the mistake of unplugging my CCM to change a bulb, and now the warning won't clear on the console. It doesn't show up on vida, only on the dash...
      You probably have a faulty cluster. It's a known issue

      Sent from my SM-G955U1 using Tapatalk

    10. #8
      Junior Member
      Join Date
      Feb 2014
      Location
      outside Boston area
      Posts
      183
      had same problem when I pulled radio out of S80 when I owned one. Only way to clear is with a tool such as vida. Removing battery etc is no help.

    11. #9
      Member LloydDobler's Avatar
      Join Date
      Aug 2007
      Location
      Littleton, CO
      Posts
      7,444
      This is from memory so it may not be 100% right, but: It won't show an active code in vida once it's plugged back in, but on the clear codes page there's an additional box that says clear SRS. You want to click that.
      2003 C70 T5M Convertible - Eibachs, Koni FSDs, Enkei RSF5s, OBX downpipe, Snabb intake, RIP kit, & drop-in intercooler, Quaife LSD, 19T, Green Giants, 22 psi Hilton tune.
      2006 V70R M66 - Sonic Blue/Nordkap, 2.4 T5 motor, Snabb intake & intercooler, IPD oval exhaust, stock turbo and tune (for now).
      1966 122s - Collectible project, restoration and many mods on the way.
      2005 V50 T5 AWD - Daughter's first car. No mods unless she does 'em herself.

    12. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. SRS Service Urgent - Passenger Occupancy Sensor - SRS-1012,1013
      By LittleRedRidingHood in forum S40 & V50 (2005-2012)
      Replies: 5
      Last Post: 03-10-2019, 12:06 PM
    2. Replies: 19
      Last Post: 05-18-2018, 11:09 AM
    3. SRS - AIRBAG SERVICE URGENT - Warning
      By sudheendrar in forum XC90 (2003 - 2014)
      Replies: 4
      Last Post: 11-06-2014, 04:10 PM
    4. SRS - AIRBAG SERVICE URGENT Warning after BLP-890 Install
      By volvofla in forum Car Audio, Video & Mobile Electronics Forum
      Replies: 4
      Last Post: 03-12-2010, 09:33 AM
    5. SRS-Airbag Service Urgent warning
      By lazzerj in forum XC90 (2003 - 2014)
      Replies: 1
      Last Post: 06-27-2004, 08:22 AM