Adding an AUX port
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 5 of 5
    1. #1
      Junior Member
      Join Date
      Sep 2017
      Posts
      254

      Adding an AUX port

      I tried to post this before but I think that I hit the wrong button.

      I have a 2002 S60 with the factory radio (I think HU-613), CD and cassette.

      I want to add an AUX port. I see a few options.

      First is that I can get an iPod adapter and modify it by adding a 3.5mm jack to the end.

      The second is by getting a used Volvo radio at the junkyard for $20 but I don't know if I'd have to change out other parts if I did that.

      The third would be something like this https://www.ebay.com/itm/Yatour-YT-B...-/272223078887

      Any thoughts?

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Senior Member ZZZZZZZ's Avatar
      Join Date
      Aug 2005
      Location
      Northern MD
      Posts
      13,805
      Looks interesting. If you get one, let me know - I'll likely try and do this for the 05 and the 02. I have the aux in the 07 (in the console and I added a long cord).
      "The Real IPD" - ZZZZZZZ's thread
      2007 Passion Red/Gobi VRgt; 2005 Silver/Beige Leather S60 2.5T AWD; 2002 Silver/Off black leather V70XC
      Past: 1999 Tropic Blue/Green/Oak leather V70 (NAa); Mom traded 1975 Maroon/Maroon leather 164E

    4. #3
      Junior Member
      Join Date
      Feb 2010
      Location
      Dallas, TX.
      Posts
      643
      Try looking here: Grom Audio Looks like the first and third products would both do what you want, although the first one will get you bluetooth as well.
      2007 SapphiCama V70R 400K+/Km
      R-Kelly Intake/CFE/H&R 5/15 spacers

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Sep 2017
      Posts
      254
      Quote Originally Posted by ZZZZZZZ View Post
      Looks interesting. If you get one, let me know - I'll likely try and do this for the 05 and the 02. I have the aux in the 07 (in the console and I added a long cord).
      Well, I finally got around to installing the Yatour YTM-06-VOLHU unit today. That was interesting. I was attempting to test it without the AC controls installed and things weren't working right. The steering wheel buttons didn't work and I couldn't change "disks." However, after the AC controls were reinstalled, everything started working correctly.

      The radio recognized the unit as a CD changer and the SD card as having a bunch of CDs. Changing songs worked properly. Random play worked. Changing "disks" worked as well. I was happy.

      I was happy until I started the engine and heard a high pitched whine from the speakers. I have hearing like a dog, so others may not hear it. The whine varied with engine speed. When I disconnected the Yatour unit, the whine went away. I've contacted tech support and I'll report what they say.

    7. #5
      Junior Member
      Join Date
      Sep 2017
      Posts
      254
      Ok, all problems are solved. I installed a filter on the power line, one of these https://www.amazon.com/gp/product/B0049MWUMQ. The whine has gone away.

      I'm pretty happy with the unit. You put your songs on an SD card in folders named CD02, CD03,... CD99. The radio will only display CD numbers up to ten so after that you have to guess. Sound quality is nice enough for me. Now the problem is to fill up that SD card. Unfortunately, it doesn't use "playlists" like an MP3 player. First world problems.

    8. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Port sitting time and adding accessories
      By El4258 in forum XC90 (SPA: 2016 - )
      Replies: 9
      Last Post: 11-08-2015, 04:53 PM
    2. Replies: 10
      Last Post: 03-08-2015, 05:25 PM
    3. Long inspection at the port? 123 miles driven at the port...
      By wsu108 in forum XC60 (2010 - 2017)
      Replies: 28
      Last Post: 12-10-2009, 01:52 PM
    4. AUX port ?
      By Omar in forum S60 (2001-2010)
      Replies: 4
      Last Post: 08-10-2007, 09:18 AM
    5. aux-port for -07
      By Daaoak in forum S40 & V50 (2005-2012)
      Replies: 19
      Last Post: 04-17-2006, 05:13 PM