valve sticking on cold start
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 3 of 3
    1. #1
      Awaiting Approval
      Join Date
      May 2019
      Posts
      1

      valve sticking on cold start

      Hello,
      Looking at buying an '07 S40 T5 AWD.

      Seller reports:
      Cylinder head must be replaced due to valve sticking on cold start. "Check engine" and "high engine temp" lights come on when driving
      Anyone care to weigh in on what all this might be - in addition to pulling the head?

      I'm no mech/tech but have done many head gaskets on Subarus and timing belts on Fords and Toyotas....but maybe the B5254T7 (?) is a much different beast.

      Thanks for any feedback.

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Apr 2018
      Posts
      33
      These engines suffer very bad damage from over heating. So unless you can get proof that it's a simple fix, and I'd bet it's not, I'd avoid. Unless you want a project

    4. #3
      Junior Member
      Join Date
      Mar 2018
      Posts
      543
      I can't see how this could be much worse or better than needing the head replaced or rebuilt.

    5. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Finished head gasket install, won't start, cams sticking?
      By Rudabaugh in forum S60 (2001-2010)
      Replies: 8
      Last Post: 01-29-2014, 02:31 PM
    2. Rough cold start, and rough acceleration(when cold)
      By Body Massage in forum R Forum (2004-2007)
      Replies: 13
      Last Post: 04-05-2011, 12:57 PM
    3. Where is the cold start valve on a '86 B230F?
      By AndytheNissanBoy in forum 240, 242, 244 & 245 (1974-1993)
      Replies: 2
      Last Post: 09-23-2005, 06:12 PM
    4. cold start valve on a 92 engine
      By redbull 325is in forum 240, 242, 244 & 245 (1974-1993)
      Replies: 1
      Last Post: 05-26-2005, 12:32 PM
    5. "Cold oil flogging" how cold is too cold?
      By Britspeed in forum R Forum (2004-2007)
      Replies: 16
      Last Post: 12-24-2004, 09:31 AM