AWD Not Working
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 2 of 2

    Thread: AWD Not Working

    1. #1
      Junior Member skatesnownick's Avatar
      Join Date
      Jan 2018
      Location
      Tecumseh, Michigan
      Posts
      33

      AWD Not Working

      My 2007 S40 T5 AWD has had a few problems with AWD. The Anti-Skid light is on and only the front wheels work. The Haldex unit was replaced and still no luck. Vida shows that it’s not getting power but all connections are good. Any ideas?
      @trpsdn
      2009 Volvo S40 T5 AWD Silver R-Design (Summer Fun)
      2000 Volvo S70 2.4T Beige AWD (Beater Rally)
      2004 Volvo S60 R AWD Passion Red (Parts)
      2001 Volvo S60 2.4T Silver FWD (Parts and Crushed)
      2006 Volvo S40 2.4i M56 Passion Red (Sold)
      2007 Volvo S40 T5 AWD Titanium Gray (Sold)
      2007 Volvo V50 2.4i Titanium Gray FWD (Sold)

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Member LizardOfBodom's Avatar
      Join Date
      Aug 2016
      Location
      Rainy Island (aka Ireland)
      Posts
      1,125
      Quote Originally Posted by skatesnownick View Post
      My 2007 S40 T5 AWD has had a few problems with AWD. The Anti-Skid light is on and only the front wheels work. The Haldex unit was replaced and still no luck. Vida shows that it’s not getting power but all connections are good. Any ideas?
      1)did you replace haldex unit with the exact same part number & from confirmed working car?
      2) did you check the haldex oil level? if its too low, AWD wont engage
      3) did you check/replaced both pump and solenoid (that attached to haldex unit)? if one fails, it will also trigger warning

      Seen all of those warnings and issues when fiddling with haldex controller swap, every part of the puzzle may trigger the error light
      Titanium Grey 2005 V50, T5AWD, M66, Stage 1 Hilton tune<-Click me
      E-Focus Torque mount, E-46 bi-xenon retrofit (see the PDF for pictures and full story) , de-nanny mod, Brembo discs+ATE ceramic pads

    4. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. AWD not working; driveshaft not turning
      By kjhiggins in forum S40 & V50 (2005-2012)
      Replies: 14
      Last Post: 03-02-2017, 07:12 PM
    2. Replies: 2
      Last Post: 02-15-2017, 09:07 AM
    3. s40 oem hid not working, then working, then not working etc
      By ser_98 in forum S40 & V50 (2005-2012)
      Replies: 4
      Last Post: 04-10-2014, 09:28 AM
    4. Replies: 2
      Last Post: 11-04-2011, 11:08 AM
    5. Replies: 2
      Last Post: 06-07-2011, 08:33 PM