Whatís this part?
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Page 1 of 2 1 2 LastLast
    Results 1 to 35 of 37
    1. #1
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160

      Whatís this part?

      Hello all

      I was wondering what this part (see pics) is.
      It looks broken to me





      Sent from my iPhone using Tapatalk

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Iím thinking itís an engine mount...

      Looks like the rubbers are deteriorating a little


      Sent from my iPhone using Tapatalk

    4. #3
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      It's your upper torque rod and yours needs to be replaced.

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements

    6. #4
      Junior Member Torsen's Avatar
      Join Date
      Mar 2018
      Location
      Paris, France
      Posts
      259
      Yup, that's one shot engine mount.. I'd see a dealer ASAP.

      Out of curiosity- what engine/model yr?

    7. #5
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Quote Originally Posted by Tech View Post
      It's your upper torque rod and yours needs to be replaced.
      Thanks tech. Iíll get onto it


      Sent from my iPhone using Tapatalk

    8. #6
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Quote Originally Posted by Torsen View Post
      Yup, that's one shot engine mount.. I'd see a dealer ASAP.

      Out of curiosity- what engine/model yr?
      Thanks Torsen. Itís a 2016 xc90 inscription.... B4204T27

      Done around 55000 kms


      Sent from my iPhone using Tapatalk

    9. #7
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      It looks like heat damage to me


      Sent from my iPhone using Tapatalk

    10. #8
      Junior Member
      Join Date
      Aug 2018
      Posts
      4
      @brett_xc90 sent you a PM

    11. #9
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Discovered today that the car is still under factory warrant for a couple more months.
      This item is covered (part #: 31330590) so is being replaced on Friday


      Sent from my iPhone using Tapatalk

    12. #10
      Junior Member
      Join Date
      Jun 2018
      Posts
      207
      Besides visual inspection, are there any symptoms to look out for?
      2018 XC90 T6

    13. #11
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Quote Originally Posted by RyVolvo View Post
      Besides visual inspection, are there any symptoms to look out for?
      Hi RyVolvo
      I donít drive the car much these days but I did notice a few jerky shifts over the weekend. And also one really rough shift...Iíll possibly be able to feel a difference on Friday when the replacement is in. Will let you know

      As far as acceleration from 0...itís been a bit laggy but I was putting that down to the learning algorithm. Even though Iíve set up two profiles, only one key has held its value so often when my wife drives the car, itís set to my profile.
      Kinda defeats the purpose and I just wish theyíd let go of the learning idea and just make it perform like the rockstar it is when itís ďfreshĒ


      Sent from my iPhone using Tapatalk

    14. #12
      Junior Member
      Join Date
      Apr 2018
      Posts
      54
      how much heat do you need to do somethign like that? looks like it was on fire...

    15. #13
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      It's not heat damage. I've seen a handful wear out like that.

    16. #14
      Junior Member taofen_wang's Avatar
      Join Date
      Dec 2015
      Location
      Canada
      Posts
      567
      Quote Originally Posted by Tech View Post
      It's not heat damage. I've seen a handful wear out like that.
      Yep. Mine is fine but someone had to replace it after 16000 KM.

    17. #15
      Member
      Join Date
      Mar 2016
      Location
      EU
      Posts
      1,284
      Quote Originally Posted by Tech View Post
      It's not heat damage. I've seen a handful wear out like that.
      Do you have an idea how that could have happened?
      2018 XC90 T5 (5-seater)

    18. #16
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      Quote Originally Posted by Zahra View Post
      Quote Originally Posted by Tech View Post
      It's not heat damage. I've seen a handful wear out like that.
      Do you have an idea how that could have happened?
      Wear and tear. It's a rubber engine mount basically. It wears out.

    19. #17
      Member
      Join Date
      Mar 2016
      Location
      EU
      Posts
      1,284
      Quote Originally Posted by Tech View Post
      Wear and tear. It's a rubber engine mount basically. It wears out.
      Ok, so it's not something one can cause or avoid.
      2018 XC90 T5 (5-seater)

    20. #18
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Quote Originally Posted by Zahra View Post
      Ok, so it's not something one can cause or avoid.
      Donít drive the car will avoid all problems


      Sent from my iPhone using Tapatalk

    21. #19
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      Quote Originally Posted by Zahra View Post
      Quote Originally Posted by Tech View Post
      Wear and tear. It's a rubber engine mount basically. It wears out.
      Ok, so it's not something one can cause or avoid.
      No, it's not something he did.

    22. #20
      Member
      Join Date
      Dec 2017
      Location
      PNW
      Posts
      5,139
      Quote Originally Posted by Tech View Post
      Wear and tear. It's a rubber engine mount basically. It wears out.
      So is it covered if still within warranty? Seems not normal worn out so early.

      Fusion ∑ Red ∑ T8 ∑ XC60
      Rolling, Fusion Red - 2018 XC60 - T8
      Running to retire, 2000 V70XC 234+k miles

    23. #21
      Member
      Join Date
      Mar 2016
      Location
      EU
      Posts
      1,284
      Quote Originally Posted by brett_xc90 View Post
      Donít drive the car will avoid all problems
      Does it also mean that I won't have to buy new tyres when they become too old?
      2018 XC90 T5 (5-seater)

    24. #22
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Quote Originally Posted by FusionRedXC60 View Post
      So is it covered if still within warranty? Seems not normal worn out so early.

      Fusion ∑ Red ∑ T8 ∑ XC60
      Yes itís covered by factory warranty.
      Not if itís an extended warranty (factory or otherwise) though.


      Sent from my iPhone using Tapatalk

    25. #23
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Quote Originally Posted by Zahra View Post
      Does it also mean that I won't have to buy new tyres when they become too old?
      Haha. Yep


      Sent from my iPhone using Tapatalk

    26. #24
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      It is covered by factory warranty. Extended warranties vary. I haven't had to get one of these specific ones covered by an extended warranty but haven't had a problem in the past with other torque rods or engine mounts.

    27. #25
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      New one fitted.

      There is a difference. Only minor but still, itís noticeable.

      Drove home in peak hour traffic, got pole position at the lights. Was able to give it a poke and noticed that I needed slightly less accelerator and there was better pickup.

      Like I said, itís only a minor difference but itís something.

      The rubber on the old one had delaminated from the housing making it effectively redundant.
      It looks to me if they simply filled the whole housing with rubber all the way to the ends, then this problem wouldnít happen....but what would I know

      Iím sure the engineers have looked into it properly.


      Sent from my iPhone using Tapatalk

    28. #26
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      If it was solid, it would transmit more vibration through the car.

    29. #27
      Junior Member brett_xc90's Avatar
      Join Date
      Feb 2018
      Posts
      160
      Quote Originally Posted by Tech View Post
      If it was solid, it would transmit more vibration through the car.
      Thanks for that, Tech. Thatís interesting. I wouldnít have thought it possible but itís confirmed in this link here:

      https://www.ipdusa.com/products/2154...39884-31670126

      Perhaps these guys could develop a better UETM for the B4204T27


      Sent from my iPhone using Tapatalk

    30. #28
      Member rumyn's Avatar
      Join Date
      Dec 2015
      Location
      New Jersey
      Posts
      1,199
      Quote Originally Posted by Tech View Post
      It's not heat damage. I've seen a handful wear out like that.
      Mine looked even worse after 6K (on XC60). They replaced it. New one looks like that in 1000 miles again...
      His: Osmium Grey - 2019 S60 T6 R-Design AWD, Polestar, Advanced, 19" wheels, Heated Steering Wheel & Rear Seats
      Hers: Onyx Black - 2019 XC60 T6 Inscription AWD, Maroon Brown, Advanced, Luxury, 20" wheels, Heated Steering Wheel & Rear Seats
      Lemon Law Buyback thread

    31. #29
      Junior Member
      Join Date
      Feb 2019
      Location
      Long Island NY
      Posts
      198
      Could the auto start/stop be putting some extra stress on it? It occasionally jumps the car forward with some force. Just a thought.


      Sent from my iPhone using Tapatalk

    32. #30
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      Got a pic of yours being shot at 1000 miles? Sounds unlikely.
      Last edited by Tech; 10-20-2019 at 09:24 AM.

    33. #31
      Member rumyn's Avatar
      Join Date
      Dec 2015
      Location
      New Jersey
      Posts
      1,199
      Quote Originally Posted by Tech View Post
      Got a pic of yours being shot at 1000 miles? Sounds unlikely.
      I will, if I ever see the car again.
      His: Osmium Grey - 2019 S60 T6 R-Design AWD, Polestar, Advanced, 19" wheels, Heated Steering Wheel & Rear Seats
      Hers: Onyx Black - 2019 XC60 T6 Inscription AWD, Maroon Brown, Advanced, Luxury, 20" wheels, Heated Steering Wheel & Rear Seats
      Lemon Law Buyback thread

    34. #32
      Junior Member
      Join Date
      Mar 2018
      Location
      Sycamore, Illinois
      Posts
      165
      I see very very small Crack in the rubber. Is this a cause for concern and get it changed before my factory warranty tun out in a month?

      Sent from my Aura Glow Note 10+ using Tapatalk
      Our first Volvo - Optimus Prime - 2016 XC90 T6 Momentum Onyx Black, HUD, Momentum+, Convenience, Vision, Climate, Pilot Assist II + Mitigation Upgrades + May 2019 Update

      My Fuel Log for real life Optimus Prime fuel efficiency - http://www.fuelly.com/car/volvo/xc90...wdarygm/910536

    35. #33
      Member
      Join Date
      Aug 2017
      Posts
      2,870
      I don't see anything in that mount that would get it replaced under warranty.

    36. #34
      Junior Member neandertal's Avatar
      Join Date
      Mar 2017
      Location
      New Jersey
      Posts
      55
      Quote Originally Posted by brett_xc90 View Post
      Hello all

      I was wondering what this part (see pics) is.
      It looks broken to me





      Sent from my iPhone using Tapatalk
      Where in the engine is this located? I am not so familiar with the layout of the car shown in this image.

      I have been having vibration issues for almost two years now and would like to rule this out as a potential vibration culprit.

      Thanks in advance.
      -------------------------------------------------------------------------------
      2006 XC70 willow green (SOLD)
      2013 Tesla Model S (TOTALED 5/2019 )
      2017 XC90 T6 Inscription Magic Metallic Blue (1st OSD)
      2019 Tesla Model S 100D - Deep Blue Metallic

    37. #35
      Member rumyn's Avatar
      Join Date
      Dec 2015
      Location
      New Jersey
      Posts
      1,199
      Quote Originally Posted by neandertal View Post
      Where in the engine is this located? I am not so familiar with the layout of the car shown in this image.

      I have been having vibration issues for almost two years now and would like to rule this out as a potential vibration culprit.

      Thanks in advance.
      Passenger side.
      FWIW, after mine got replaced the vibration got even worse.
      His: Osmium Grey - 2019 S60 T6 R-Design AWD, Polestar, Advanced, 19" wheels, Heated Steering Wheel & Rear Seats
      Hers: Onyx Black - 2019 XC60 T6 Inscription AWD, Maroon Brown, Advanced, Luxury, 20" wheels, Heated Steering Wheel & Rear Seats
      Lemon Law Buyback thread

    38. Remove Advertisements

      Advertisements
       

    Page 1 of 2 1 2 LastLast

    Similar Threads

    1. Replies: 7
      Last Post: 03-05-2011, 01:54 PM
    2. Part Number Needed, or part.
      By hibrad2005 in forum S80 (1998-2006)
      Replies: 4
      Last Post: 07-28-2009, 12:03 PM
    3. Name this part, part deux
      By tdskip in forum Amazon P120, P130 & P220 (1956-1970)
      Replies: 3
      Last Post: 03-17-2009, 09:22 PM
    4. Need part number or the name of the part
      By N4BOOST in forum R Forum (2004-2007)
      Replies: 4
      Last Post: 03-17-2007, 02:05 PM
    5. Replies: 16
      Last Post: 11-14-2005, 04:46 AM