Slight Vibration in Gas Pedal
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 8 of 8
    1. #1
      Junior Member
      Join Date
      Feb 2018
      Posts
      13

      Slight Vibration in Gas Pedal

      I have a 2015.5 Volvo XC70 T5 Drive-e with about 33k miles. Car is great with no issues other than this annoying vibration/scratchy issue Iím having in the gas pedal. Itís almost always there and it varies from faint to noticeable in steering wheel.

      The tires have been road force balanced, but theyíre the original tires and Iím not putting it past them to be the culprit, but donít want to spend $900 on new tires if thatís not the cause, as they still have another year or more of life in them.

      Iím worried itís the piece of crap drive-e 4 cyl. Engine causing the vibration.

      Any thoughts?

      Thanks!

      BTW, posted in this spot of the forum due to increased traffic!

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Jun 2017
      Location
      Maryland
      Posts
      346
      Quote Originally Posted by Acb5456 View Post
      I have a 2015.5 Volvo XC70 T5 Drive-e with about 33k miles. Car is great with no issues other than this annoying vibration/scratchy issue Iím having in the gas pedal. Itís almost always there and it varies from faint to noticeable in steering wheel.

      The tires have been road force balanced, but theyíre the original tires and Iím not putting it past them to be the culprit, but donít want to spend $900 on new tires if thatís not the cause, as they still have another year or more of life in them.

      Iím worried itís the piece of crap drive-e 4 cyl. Engine causing the vibration.

      Any thoughts?

      Thanks!

      BTW, posted in this spot of the forum due to increased traffic!
      Do you have aftermarket or factory wheels ?


      Sent from my iPhone using Tapatalk

    4. #3
      Junior Member
      Join Date
      Feb 2018
      Posts
      13
      Factory, 17" wheels! The vibration occurs more often when the engine is cold--and it's felt in the gas pedal, brake pedal, a little in the floorboard and a little in the seat. I'm stumped.

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements

    6. #4
      Member
      Join Date
      Jun 2012
      Location
      Pittsburgh, PA
      Posts
      1,634
      Sounds like the engine is running rough. Have you tried using fuel injector cleaner in the gas tank?
      Or maybe let the engine warm up good and give it the old Italian tune up The car needs that every once in a while.
      2012 S60 T5 Savile Gray/Beachwood

    7. #5
      Junior Member
      Join Date
      Jun 2017
      Location
      Maryland
      Posts
      346
      Quote Originally Posted by Almaz View Post
      Sounds like the engine is running rough. Have you tried using fuel injector cleaner in the gas tank?
      Or maybe let the engine warm up good and give it the old Italian tune up The car needs that every once in a while.
      What technique is the old Italian tune up ?


      Sent from my iPhone using Tapatalk

    8. #6
      Member
      Join Date
      Jun 2012
      Location
      Pittsburgh, PA
      Posts
      1,634
      Quote Originally Posted by anewman644 View Post
      What technique is the old Italian tune up ?


      Sent from my iPhone using Tapatalk
      That's when you you drive it hard for a little. Let the RPMs hang close to the redline.

      Sent from my ASUS_Z017DA using Tapatalk
      2012 S60 T5 Savile Gray/Beachwood

    9. #7
      Junior Member
      Join Date
      Aug 2019
      Location
      Mesa, AZ
      Posts
      39
      You ever figure it out? I have a similar issue in my 2013 S60 T5 (2.5)

      I'm leaning toward the lower control arms. I've seen multiple people replace them (even when they look fine) and it seems to sort it all out.
      I'm in AZ, so the weather is pretty good in the winter, so I'll probably replace them soon.
      My 2013 only has 50k miles.

    10. #8
      Junior Member
      Join Date
      Jun 2017
      Location
      Maryland
      Posts
      346
      Quote Originally Posted by baileyw813 View Post
      You ever figure it out? I have a similar issue in my 2013 S60 T5 (2.5)

      I'm leaning toward the lower control arms. I've seen multiple people replace them (even when they look fine) and it seems to sort it all out.
      I'm in AZ, so the weather is pretty good in the winter, so I'll probably replace them soon.
      My 2013 only has 50k miles.
      Did you replace your control arm ? And also do you still experience this issue ? I just experience one today. Usually I remote warm my car for 15mins. This time I didnít and experience vibration in the gas pedal. I am leaning towards the fact I did not warm the engine. Kindly let me know if changing your control arm solved the issue


      Sent from my iPhone using Tapatalk

    11. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Slight Vibration in Gas Pedal
      By Acb5456 in forum V70 & XC70 (2008 - 2016)
      Replies: 2
      Last Post: 11-20-2019, 08:42 AM
    2. 2010 XC70 - Vibration and Noise in Gas Pedal
      By maggior in forum V70 & XC70 (2008 - 2016)
      Replies: 22
      Last Post: 07-15-2011, 05:40 PM
    3. Slight gas pedal tension at beginning of drive
      By XC60-Shawn in forum XC60 (2010 - 2017)
      Replies: 5
      Last Post: 05-11-2011, 08:43 PM
    4. Replies: 3
      Last Post: 06-21-2008, 05:22 PM
    5. Brake Pedal too close to Gas Pedal?
      By theparkers in forum S40 & V50 (2005-2012)
      Replies: 7
      Last Post: 07-04-2007, 03:27 PM