2004 XC90 radio/audio unit dead
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 4 of 4
    1. #1
      Junior Member
      Join Date
      Jun 2019
      Location
      ON, Canada
      Posts
      3

      2004 XC90 radio/audio unit dead

      Hi all.
      first thing- I did my fare bit of research on this problem - leaky sunroof, main amp failure due to moisture, checked all fuses, etc.
      The problem is - radio is dead, it used to turn on randomly before, but completely dead for last 3 months.
      When I try to scan for the code - tool goes into indefinite loop, says - scanning...100% and freezes, tool won't respond to any buttons, have to unplug to re-set. It dose it when I try to scan any modules from audio/infotainment section.
      Any ideas?
      and I don't have a sunroof, audio amp is nice and dry.
      Thanks in advance.

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Oct 2018
      Location
      San Diego, CA.
      Posts
      188
      What are you scanning with? I removed or disabled most of my original sound system and installed aftermarket. When I run VIDA, it tells me every little thing that's not working on the original sound system. Before I replaced it, VIDA reported that the left front speaker was having some kind of connection problem. I don't know what iteration of the sound system you have, but mine had a surprising number of electronic modules for the basic rig. Maybe if you could get a VIDA read out it will pinpoint exactly what isn't working. There are also a surprising number of fuses all over the car for the sound system, and they may not be all that obvious as sound system related. A printed glossary of the acronyms that identify the components is essential for me to navigate the Volvo tech stuff. Sometimes this forum, too!
      2009 XC90 FWD 3.2, 2013 S60 T5
      In the past: '89 745, '91 940, '82 242, '67 122S, '67 123GT, '71 142E, '62 PV544.

    4. #3
      Junior Member
      Join Date
      Jun 2019
      Location
      ON, Canada
      Posts
      3
      I'm using iCARSOFT VOLII for VOLVO. Works perfect on my other Volvo, and on this one, everuwhere other than audio.

    5. #4
      Junior Member
      Join Date
      Jun 2018
      Posts
      21
      My 05 xc90 radio band stopped working on and off for a couple months, then finally not working at all. Fuses are OK, the CD works, just no radio band, any ideas, was considering changing radio head first.
      Last edited by FREE; 11-27-2019 at 08:30 PM.

    6. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. xc90 navi unit (cd-rom unit) w/ disc
      By corvette535 in forum Miscellaneous Classifieds
      Replies: 9
      Last Post: 03-01-2012, 03:39 PM
    2. DEAD DEAD DEAD
      By Kodabear in forum XC90 (2003 - 2014)
      Replies: 15
      Last Post: 04-30-2008, 04:05 PM
    3. Petition to add AUX audio input to MOST audio on XC90 and other models
      By simonmason in forum Car Audio, Video & Mobile Electronics Forum
      Replies: 0
      Last Post: 04-18-2007, 09:41 PM
    4. Dead Light Warning but no dead lights?
      By yieldsign2 in forum 740 & 760 (1982-1992)
      Replies: 1
      Last Post: 09-04-2005, 01:05 AM
    5. Replies: 5
      Last Post: 05-25-2003, 11:47 PM