Climate control and Heater Issues
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 5 of 5
    1. #1
      Junior Member
      Join Date
      May 2012
      Posts
      109

      Climate control and Heater Issues

      Experiencing some climate control issues. Specifically, sometimes when the system is set to auto, the system will switch to manual and the fan will be set to low (2 green lights). Been seeing this issue sporadically for the last month.

      Now, the heater wasn't blowing any hot air through the vents. If it is on auto and I move the temps to maximum hot, nothing happens, the fans don't kick in. If I switch to manual and max heat, the heat eventually comes, but if I back the temps down, the heat drops dramatically.

      I just had the thermostat replaced last week, as it was leaking from the gasket. My independent shop only uses OEM Volvo parts. The car warms up fine and the temp gauge has been steady since he replaced the assembly. I also replaced the Blower Resistor about 18 months ago. I didn't use an OEM part for this.

      What should I be looking for to fix this problem?
      06 Volvo XC90 2.5
      05 Mazda RX8
      00 Aprilia RSV Mille
      95 Aprilia RS250 Chesterfield Edition

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Jul 2015
      Location
      Calgary
      Posts
      387
      With mine I found out that if I dropped the hood the fan would come on so it was kind of intermittent. I think you are going to literally have to rip out the blower motor once you get all accessible screws out. There is one behind that you can't get to until the blower motor is pulled out. I got the blower motor and rheostat as an assembly from an 04 in the junk yard and it has been working good in the 07 since.
      Last edited by vince1; 11-30-2019 at 06:01 PM.
      07 XC90 3.2

    4. #3
      Junior Member
      Join Date
      May 2012
      Posts
      109
      Quote Originally Posted by vince1 View Post
      With mine I found out that if I dropped the hood the fan would come on so it was kind of intermittent. I think you are going to literally have to rip out the blower motor once you get all accessible screws out. There is one behind that you can't get to until the blower motor is pulled out. I got the blower motor and rheostat as an assembly from an 04 in the junk yard and it has been working good in the 07 since.
      I already replaced the resistor on the blower motor about 18 months, not sure if that's causing it again or something else.
      06 Volvo XC90 2.5
      05 Mazda RX8
      00 Aprilia RSV Mille
      95 Aprilia RS250 Chesterfield Edition

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Member ggleavitt's Avatar
      Join Date
      Jun 2005
      Location
      Seattle
      Posts
      2,617
      • System is set for auto, you look later and see it in manual.
        When on auto, turning temp knob to max (or min?) does not directly affect fan speed.
        When on manual, temp control is not linear.

      Blower and thermostat we can set aside for a sec, please elaborate further if I'm not articulating the issue correctly.

      Try the temp test (turn temp knob) for left and right sides, see if both act the same or one is different from the other. And press some other climate buttons, see if anything else is not working (blend air for top/middle/bottom as one example).

      If you did a scan using a Volvo tool, my guess is you'll see the cause pretty quickly as a code. In the meantime, you could check the little white dot behind the grate on the climate panel right side. Area needs to be very clean and the white dot (thermocouple for interior temp) needs to not be broken. This can result in a high/low temp swing with little or nothing in between and is an easy check.

      Couple links to read, might not be your issue but decent reference to what I'm referring to-
      https://forums.swedespeed.com/showth...=1#post6460793
      https://www.volvoforums.org.uk/showthread.php?p=886879
      https://www.volvoforums.org.uk/showthread.php?t=107413

      More detail would probably help.
      2005 XC90 B5254T2 019 198k
      2008 XC90 B8444S Sport 452 127k

    7. #5
      Junior Member
      Join Date
      May 2012
      Posts
      109
      Quote Originally Posted by ggleavitt View Post
      [LIST]
      System is set for auto, you look later and see it in manual.
      When on auto, turning temp knob to max (or min?) does not directly affect fan speed.
      When on manual, temp control is not linear.

      More detail would probably help.
      My problems are intermittent and don't happen all the time.

      When it's set to Auto, it has switched to manual. As mentioned it's intermittent and has been doing it for about 2 months.

      Over the weekend, we had our first cold snap and it was the first time turning on the heater in 8 months. When it was on Auto and temp gauges were turned to full heat, the fans were barely blowing, with the majority of the heat coming through the bottom vents. If I switched to manual with full blower, everything works properly. If I immediately switch to Auto, it would continue to blow hot air at full speeds.

      I did clean the sensor vent, it was filled with dust. Haven't tested it yet, but hopefully that helps.
      06 Volvo XC90 2.5
      05 Mazda RX8
      00 Aprilia RSV Mille
      95 Aprilia RS250 Chesterfield Edition

    8. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Climate Control Seat Heater backlights not working (09 v8)...
      By juve021 in forum XC90 (2003 - 2014)
      Replies: 0
      Last Post: 12-13-2014, 05:02 PM
    2. Climate Control / Heater/AC blower failure?
      By URO_S6O in forum S60 (2001-2010)
      Replies: 3
      Last Post: 12-30-2012, 09:53 PM
    3. Possible to add climate control to a non climate car?
      By 95wave in forum S40 & V50 (2005-2012)
      Replies: 1
      Last Post: 07-04-2010, 11:39 AM
    4. Replies: 2
      Last Post: 11-15-2007, 08:47 PM
    5. Dual Climate Control - Climate Package on 2.4i
      By Tarik in forum S40 & V50 (2005-2012)
      Replies: 2
      Last Post: 03-23-2004, 04:25 PM