low coolant warning totally baffled
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 8 of 8
    1. #1
      Junior Member
      Join Date
      Dec 2015
      Location
      SLC Utah
      Posts
      419

      low coolant warning totally baffled

      Sorry to mix a little P2 problems over here but i'm stumped. I posted this a couple months ago in the P2 section but no one could suggest anything i haven't already tried. Here's the story, getting low coolant warning on S60. Son did loose a good amount coolant due to a bad small hose leak but never overheated. Replaced hose and refill and still getting warning. Replaced the expansion tank with a Behr and bought 2 OEM coolant level sensors from FCP. Light still on trying both sensors. Put one of the sensors on my S70 and no issues so i know they are fine. Thought maybe i got a bum tank from MFG so i swapped it out even though the float was operating correctly. New tank made no difference. Checked voltage at the harness that plugs into the sensor and getting 12V. I'm completely baffled. I don't like cry wolf error messages especially with something as important as coolant level.
      01 S60 T5M Black, middle sons
      00 S70 GLT Black, youngest sons
      01 E46 325 XI Touring Silver, Wifes, totalled, bought back, repaired, soon for sale
      00 S70 GLT SE T5 Swap MINE !

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member RYJS60's Avatar
      Join Date
      Sep 2015
      Location
      US
      Posts
      752
      Maybe the error needs to be cleared out from the computer. I would try disconnecting the battery. Or you may have air in the line???

    4. #3
      Senior Member ScottishBrick's Avatar
      Join Date
      Dec 2014
      Location
      Connecticut
      Posts
      14,092
      Can you wire tap the harness while you actuate the float? It should change the voltage. My understanding is that it’s not an I/O switch but I could be wrong.
      2003 V70 T5 - Mystic/Graphite - M56LK - 201k - K24/Greens/Do88 IC/SMF & P2R Clutch/DW300C/H&R/Bilstein TC/Delrin/316mm & 308mm Brakes - SteveO Tuned
      1999 V70 T5 - Pewter/R Graphite & Alcantara - AW42 - 292k - Daily/Work Wagon
      1999 V70 T5 - Nautic/R Graphite & Alcantara - M56H - 174k - Rescued
      1999 V70 T5 - Emerald/Graphite - M56H - 119k - Garage Queen
      2000 V70 T5 - Mystic/Graphite - AW42 - 240k - Moms Unicorn
      2000 S70 GLT SE- Mystic/Graphite - AW42 - 215k - Sisters

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Dec 2015
      Location
      SLC Utah
      Posts
      419
      Yeah we did a disconnect overnight with no luck
      01 S60 T5M Black, middle sons
      00 S70 GLT Black, youngest sons
      01 E46 325 XI Touring Silver, Wifes, totalled, bought back, repaired, soon for sale
      00 S70 GLT SE T5 Swap MINE !

    7. #5
      Junior Member
      Join Date
      Dec 2015
      Location
      SLC Utah
      Posts
      419
      Quote Originally Posted by ScottishBrick View Post
      Can you wire tap the harness while you actuate the float? It should change the voltage. My understanding is that it’s not an I/O switch but I could be wrong.
      Do you mean put a jumper on the harness and activate the float ?
      01 S60 T5M Black, middle sons
      00 S70 GLT Black, youngest sons
      01 E46 325 XI Touring Silver, Wifes, totalled, bought back, repaired, soon for sale
      00 S70 GLT SE T5 Swap MINE !

    8. #6
      Senior Member ScottishBrick's Avatar
      Join Date
      Dec 2014
      Location
      Connecticut
      Posts
      14,092
      Quote Originally Posted by UT OLI View Post
      Do you mean put a jumper on the harness and activate the float ?
      Thats one of the things to do.

      Check resistance through the sensor with the float in all positions. That should give you some indication of what the range is. Then, you want to look for that in the body harness too.
      2003 V70 T5 - Mystic/Graphite - M56LK - 201k - K24/Greens/Do88 IC/SMF & P2R Clutch/DW300C/H&R/Bilstein TC/Delrin/316mm & 308mm Brakes - SteveO Tuned
      1999 V70 T5 - Pewter/R Graphite & Alcantara - AW42 - 292k - Daily/Work Wagon
      1999 V70 T5 - Nautic/R Graphite & Alcantara - M56H - 174k - Rescued
      1999 V70 T5 - Emerald/Graphite - M56H - 119k - Garage Queen
      2000 V70 T5 - Mystic/Graphite - AW42 - 240k - Moms Unicorn
      2000 S70 GLT SE- Mystic/Graphite - AW42 - 215k - Sisters

    9. #7
      Junior Member
      Join Date
      Dec 2015
      Location
      SLC Utah
      Posts
      419
      Finally figured it out ! The first Brand new Behr expansion tank float magnet or whatever communicates with the level sensor was bad. I went back to exchange it for a new one and turns out that one was bad also. I figured this out when i swapped tanks from the black S70 to the S60 today and no more warning light on the S60. Bad week for Behr with me getting 2 bum tanks and Scottish having a failed heater core. Just ordered OEM tank from FCP to put back in the S70.
      01 S60 T5M Black, middle sons
      00 S70 GLT Black, youngest sons
      01 E46 325 XI Touring Silver, Wifes, totalled, bought back, repaired, soon for sale
      00 S70 GLT SE T5 Swap MINE !

    10. #8
      Senior Member ScottishBrick's Avatar
      Join Date
      Dec 2014
      Location
      Connecticut
      Posts
      14,092
      Quote Originally Posted by UT OLI View Post
      Finally figured it out ! The first Brand new Behr expansion tank float magnet or whatever communicates with the level sensor was bad. I went back to exchange it for a new one and turns out that one was bad also. I figured this out when i swapped tanks from the black S70 to the S60 today and no more warning light on the S60. Bad week for Behr with me getting 2 bum tanks and Scottish having a failed heater core. Just ordered OEM tank from FCP to put back in the S70.
      Cheap sh*t. Another brand to stay away.
      2003 V70 T5 - Mystic/Graphite - M56LK - 201k - K24/Greens/Do88 IC/SMF & P2R Clutch/DW300C/H&R/Bilstein TC/Delrin/316mm & 308mm Brakes - SteveO Tuned
      1999 V70 T5 - Pewter/R Graphite & Alcantara - AW42 - 292k - Daily/Work Wagon
      1999 V70 T5 - Nautic/R Graphite & Alcantara - M56H - 174k - Rescued
      1999 V70 T5 - Emerald/Graphite - M56H - 119k - Garage Queen
      2000 V70 T5 - Mystic/Graphite - AW42 - 240k - Moms Unicorn
      2000 S70 GLT SE- Mystic/Graphite - AW42 - 215k - Sisters

    11. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Coolant low Red Triangle, but coolant isn't low
      By kTaLgsTo in forum R Forum (2004-2007)
      Replies: 4
      Last Post: 09-20-2019, 08:41 PM
    2. "Coolant Level Low Stop Engine" -- But the Coolant Level Isn't Low.
      By itwontstopsnowin in forum S80 (2007-2016)
      Replies: 2
      Last Post: 09-10-2016, 11:30 PM
    3. Louder Turbo after other engine work...completely baffled!
      By Bigfieroman in forum R Forum (2004-2007)
      Replies: 7
      Last Post: 03-01-2011, 10:15 PM
    4. Baffled by Brakes
      By mgc in forum S70, V70 & V70XC (1998-2000)
      Replies: 6
      Last Post: 06-06-2010, 06:23 PM
    5. Need Help, strange noise from front end, dealer is baffled.
      By Vipergtsz3 in forum R Forum (2004-2007)
      Replies: 10
      Last Post: 02-20-2006, 10:56 PM