Bad battery causing "Reduced Engine Performance"?
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 10 of 10
    1. #1
      Junior Member
      Join Date
      Nov 2006
      Posts
      166

      Bad battery causing "Reduced Engine Performance"?

      So I bought a new car a couple months back and my 2007 S40 T5 sat for about 2 months without being driven. When I went to start it the battery was dead, charged it and started right away. When I drove it I got the "Reduced Engine Performance" light. I removed the negative terminal overnight thinking maybe light would clear up but no luck. The battery seems week but has started the car several times now. The battery is a 6yr Interstate that is about 5yrs old.

      Could a weak battery cause some voltage issue and the REP? I have blue driver scanner but it doesn't pickup any faults/codes.

      Thanks for your help!
      Chris

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Global Moderator tmtalpey's Avatar
      Join Date
      Jun 2004
      Location
      Eastern MA
      Posts
      8,923
      A weak battery can cause anything. But REP can have many other causes. You need a Volvo-specific scan, like from dealer, VIDA, or professional tool.

      Volvo offers free "Complimentary Diagnostics" service, if you have a dealer nearby, it may be your best bet. If no specific faults found, then, battery.
      2005 V50 T5 AWD 6MT w/Heico tune, Heico exhaust, Bell intercooler, IPD TCV, Viva Forge CBV, Elevate rear swaybar and torque mount, Snabb shift kit, etc.
      2016 XC60 T6 AWD
      1956 PV444 complete, running
      1956 PV444 very original, very rough

    4. #3
      Member mgm7890's Avatar
      Join Date
      Nov 2013
      Location
      USA
      Posts
      1,198
      Quote Originally Posted by tmtalpey View Post

      Volvo offers free "Complimentary Diagnostics" service, if you have a dealer nearby, it may be your best bet. If no specific faults found, then, battery.
      I've seen this is only at participating dealers. Have you, or anyone, run into one that won't check codes for free? It's a nice little perk.
      2005 S40 2.4i

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Jun 2012
      Location
      Tidewater, VA
      Posts
      787
      Quote Originally Posted by mgm7890 View Post
      I've seen this is only at participating dealers. Have you, or anyone, run into one that won't check codes for free? It's a nice little perk.
      That’s true, the TOS specifically say that. I haven’t had a dealer yet tell me they won’t though, only that it’s limited to CEL or other warnings on the dash. REP should qualify. Easiest is to call the service dept and confirm.

      BD
      Current Fleet:
      1998 S70 Base (New project), 2006 S40 T5 M66 FWD, 2008 C70 Premium Plus M66, 2011 XC90 V8, 2013 C70 Platinum P*

      RIP:
      1994 854T FWD, 2004 XC90 2.5T AWD, 2005 S60 2.5T FWD

    7. #5
      Global Moderator tmtalpey's Avatar
      Join Date
      Jun 2004
      Location
      Eastern MA
      Posts
      8,923
      Scroll down to "Complimentary Diagnostics". That said, some dealers may ignore Volvo corporate.

      https://www.volvocars.com/us/own/own...rvice-by-volvo
      2005 V50 T5 AWD 6MT w/Heico tune, Heico exhaust, Bell intercooler, IPD TCV, Viva Forge CBV, Elevate rear swaybar and torque mount, Snabb shift kit, etc.
      2016 XC60 T6 AWD
      1956 PV444 complete, running
      1956 PV444 very original, very rough

    8. #6
      Member EngTech's Avatar
      Join Date
      Jan 2007
      Location
      Knight's of the Round Table - TN
      Posts
      8,281
      It _ Poor Battery May Drag You Alternator so much and Strain it that Heated Condition Burns that Up ~ Next ~ so did You have the Battery Checked ? ( Told it was on the Way Out ) ?

      As I have seen those Part Sales - Places , completely Miss Proper Call on Battery & Starter . . even after Starter was Good Rebuilt one , Parts House called it Bad ~ so ~ Watch those Folks . .

      LOL had to Laugh - Gal from the Back - only there 3 months back up Front and Showed all the Guys how to do it Correctly on Their Testing Machine ~ Dam Good also . .
      ** V50 AWD - Handling & Performance Tweaks = New Stance / VW CC - Handling Tweaks - Testing & Porting - Intake Mods
      A Garden Gate will Last You a Life Time . http://s261.photobucket.com/user/Eng...0Trim%20%20etc

    9. #7
      Member AutoGeek's Avatar
      Join Date
      Jan 2008
      Location
      MD, Howard Co.
      Posts
      2,162
      I had a 10 month old AGM battery go bad that was showing good but needing charge according to Advance Auto Parts tester and measured 540 CCA instead of the rated 800 CCA. My alternator had gone bad at the same time so I don't know if the alternator caused the battery to fail a cell or if the battery caused the alternator to go.

      After I replaced the alternator, the battery would charge but would go down to 10V if the car sat for more than 24 hours. It had a weak cell but not a failed cell. This is more typical of AGM unless they vent. Most testers don't test AGM batteries properly. Also, you need a charger that is compatible with AGM.

      I let Advance charge the battery for an hour and it still said 540 CCA so they replaced it under warranty. All is good now.
      2005 V50 T5 FWD M66 Passion Red (Radio Flyer) Bilstein HD, ECU spacer, Snabb Turbo Pipe

      1998 V70 NA - Sold, 2002 S40 1.9T - R.I.P., 2005 V50 T5 - RIP

      Remember kids, Speed doesn't kill ... impact does!

    10. #8
      Junior Member 80sGuy's Avatar
      Join Date
      Nov 2013
      Location
      Los Angeles
      Posts
      983
      Quote Originally Posted by 95wave View Post
      So I bought a new car a couple months back and my 2007 S40 T5 sat for about 2 months without being driven. When I went to start it the battery was dead, charged it and started right away. When I drove it I got the "Reduced Engine Performance" light. I removed the negative terminal overnight thinking maybe light would clear up but no luck. The battery seems week but has started the car several times now. The battery is a 6yr Interstate that is about 5yrs old.

      Could a weak battery cause some voltage issue and the REP? I have blue driver scanner but it doesn't pickup any faults/codes.

      Thanks for your help!
      Chris
      If the battery is older than 5 years and you're not using it as often I'd suggest replacing before it fries up your alternator. A weak battery will strain (or burn out) the alternator's voltage-regulator which delegates power to the various accessories of your vehicle under load, hence the reduced engine performance and all other berserk warnings/behaviors. Just makes the generator work harder and hotter. My car once sent a message saying 'alarm system service required' during my 7 year-old genuine Volvo battery was giving me a sign. One Sunday morning out of the blue, the car would not start, just clicking away while trying to start. Battery went completely dead. Jump-started the car and everything was good. The car actually starts fine many times over but I decided to buy a new Volvo battery from the dealer first thing Monday morning, and so far everything went well. Been over 18 months now and running trouble-free with no weird message(s).

    11. #9
      Member AutoGeek's Avatar
      Join Date
      Jan 2008
      Location
      MD, Howard Co.
      Posts
      2,162
      80sGuy is correct. The car's alternator is not intended to recharge a dead battery, though it will (ie recharge after a jump start). It is really intended to maintain the battery charge. A dead battery should be recharged with a battery charger.
      2005 V50 T5 FWD M66 Passion Red (Radio Flyer) Bilstein HD, ECU spacer, Snabb Turbo Pipe

      1998 V70 NA - Sold, 2002 S40 1.9T - R.I.P., 2005 V50 T5 - RIP

      Remember kids, Speed doesn't kill ... impact does!

    12. #10
      Junior Member Okidiver's Avatar
      Join Date
      Jan 2008
      Location
      Tampa...sometimes
      Posts
      984
      A CTEK charger/conditioner seemed like a good investment for the AGM batteries I have in both my Volvos.
      Rapid Rick...I roll
      2008 C30 Matt Pearl Gold OSD-customized w/Elevate tune
      2015 V60 Seashell Metallic w/Platinum, BLIS, wood

    13. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Low battery mode Reduced Engine performance. help please.
      By Svën Höek in forum V70 & XC70 (2008 - 2016)
      Replies: 2
      Last Post: 08-09-2019, 02:27 PM
    2. Replies: 18
      Last Post: 01-04-2018, 08:48 PM
    3. 05 V50 CEL Codes causing reduced engine performance
      By qbcsvt in forum S40 & V50 (2005-2012)
      Replies: 14
      Last Post: 09-08-2017, 01:46 PM
    4. "Reduced Engine Performance"
      By Jeff in Ferndale Wa in forum S60 (2001-2010)
      Replies: 6
      Last Post: 01-04-2015, 03:35 PM