Premium Sound Center Speaker not working.
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 2 of 2
    1. #1
      Junior Member
      Join Date
      Aug 2019
      Location
      Fort Lauderdale, FL
      Posts
      51

      Premium Sound Center Speaker not working.

      Okay so after me finding and finding a new amplifier, I found one that fixed everything in my car and has been working for about two months now. But now all of a sudden the center speaker decided to stop working. Would I need to just pry off the grill to get access to it? I found a pretty cheap used replacement online.
      2012 Volvo S60 T5 | Caspian Blue Metallic | Premium Package | Climate Package | Multimedia Package | BLIS

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Aug 2019
      Location
      Fort Lauderdale, FL
      Posts
      51
      Okay I was able to pry off the grill which gave me access to the speaker. Pry from the left side because there is a wedge on the right side.

    4. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. "New" 2008 XC70 - Premium Sound...doesn't sound "Premium", help
      By collindaly in forum V70 & XC70 (2008 - 2016)
      Replies: 6
      Last Post: 04-28-2017, 03:48 AM
    2. Replies: 12
      Last Post: 03-31-2016, 09:17 AM
    3. Replies: 3
      Last Post: 08-29-2014, 09:09 AM
    4. s40 oem hid not working, then working, then not working etc
      By ser_98 in forum S40 & V50 (2005-2012)
      Replies: 4
      Last Post: 04-10-2014, 08:28 AM
    5. Getting Power to the Center Speaker (S60 R premium sound).
      By Capital R in forum Car Audio, Video & Mobile Electronics Forum
      Replies: 5
      Last Post: 06-07-2007, 06:51 PM