Upgrading battery specs - update software
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 10 of 10
    1. #1
      Junior Member
      Join Date
      Oct 2018
      Posts
      80

      Upgrading battery specs - update software

      Ok... I learned a lesson today. So 15 months ago, I replaced the battery with a higher AH and CCA rating. I did NOT update values in VIDA, just a manual BMS reset by unplugging the BMS unit. Lately I have been having a low voltage issue. First the start/stop Stopped working for charging, then I would eventually get the low voltage flag.

      I was a bit stumped.. battery would check good when tested. Battery at idle was 14.8. Parasitic amp draw tested good. On OBD diagnostics the battery SoC would never ever exceed 81% even when fully charged with external charger and would continually drop.

      Come to find out the 14.8 at idle was a little high. When driving the alternator module would request 14.8 to 15v. BMS values matter, It was over charging due to not changing the values within the computer. It was slowly killing my battery.

      Today I had the values changed in VIDA and not at idle it is hanging between 13.9 and 14.2. And now my SoC is slowly increasing... currently 86% after 30 miles of driving.

      Just wanted to pass this on, because nowadays a battery change isn’t just a simple battery change. Passing on my learned lesson.


      2015.5 XC60, 2.0L

      Current battery (15 months old): super start platinum 94R AGM 900 CCA

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Member Config's Avatar
      Join Date
      Jun 2003
      Location
      Mountain Time
      Posts
      1,018
      How did you come across this info? Interesting, especially since I know of dealers not even performing a BMS reset, I know mine didn't.
      '00 Mystic Silver metallic V70R, Rear Wing, Dolby
      '02 Desert Wind S40 Sports premium/winter pkg
      '12 Savile Gray metallic S60 T5, Premium/Climate/BLIS/City Safety/rear spoiler
      '13 Seashell metallic XC60 T6, Platinum/Climate/BLIS/Polestar-tuned/IPD anti-sway bar
      '16 Seashell metallic S60 T5 AWD (replaced '17 S60)
      '13A DICE/VIDA, x's '93 850 GLT, '04 XC90, '17 S60 T5 (Totaled!)

    4. #3
      Junior Member
      Join Date
      Oct 2018
      Posts
      80
      I have lived it... been chasing this issue down for 1.5 months... charging battery with tender... slowly draining.. repeat..

      If you are putting in the same spec battery, I would assume you won’t have an issue.

      In using the car scanner pro app through obd2 port, one of the sources of information was # days since BMS reset. Despite unplugging it many times, mine said 1820 taking it back to February 2015 (production)... Vida now set this to zero.

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Nov 2018
      Location
      new cumberland,pa.
      Posts
      275
      this has been discussed extensively in the s60 forum. If the bms counter is not reset with a new battery, it can cause these problems. Vida/dice is the preferred method.

    7. #5
      Junior Member
      Join Date
      Oct 2018
      Posts
      80
      Jlh3rd, thanks. I have been reading through that long thread. Interesting.

      The mechanic I talked to eluded that you have to input the values like the CCA and AH in VIDA. I know BMW is this way which he might have gotten the two confused since this mechanic specializes in Saab, Volvo and BMW. What I do know is the rest indeed made a difference in the way it was charging.... I think my SoC now increasing is a result of not overcharging.

      Just so I can confirm, have you done this in VIDA? I couldn’t tell in the Hack video. Does it take input values or just a date reset to determine charge by age? This way I know for future batteries and to perform that push button sequence to reset....

      Appreciate it..

    8. #6
      Junior Member
      Join Date
      Jan 2019
      Location
      North Carolina, USA
      Posts
      140
      Quote Originally Posted by VovoXC60 View Post
      one of the sources of information was # days since BMS reset. Despite unplugging it many times, mine said 1820 taking it back to February 2015 (production)
      I know you probably fully understand this, but I want to re-iterate for posterity... UNPLUGGING THE BMS DOES NOT RESET THE BMS COUNTER.

      Resetting the BMS must be done through VIDA, VDASH, or through the in car button sequence BMS Reset

    9. #7
      Member
      Join Date
      Aug 2017
      Location
      United States
      Posts
      3,256
      Quote Originally Posted by budleach View Post
      Quote Originally Posted by VovoXC60 View Post
      one of the sources of information was # days since BMS reset. Despite unplugging it many times, mine said 1820 taking it back to February 2015 (production)
      I know you probably fully understand this, but I want to re-iterate for posterity... UNPLUGGING THE BMS DOES NOT RESET THE BMS COUNTER.

      Resetting the BMS must be done through VIDA, VDASH, or through the in car button sequence BMS Reset
      I'm not even sure that in car button sequence does it. Next time I replace a battery I'll try to remember to try it and then check it.

    10. #8
      Member Config's Avatar
      Join Date
      Jun 2003
      Location
      Mountain Time
      Posts
      1,018
      Quote Originally Posted by Tech View Post
      I'm not even sure that in car button sequence does it. Next time I replace a battery I'll try to remember to try it and then check it.
      I would love to see if that work as well since my DICE/VIDA unit doesn't work on our '16 S60 and the battery might be near it's service life.
      '00 Mystic Silver metallic V70R, Rear Wing, Dolby
      '02 Desert Wind S40 Sports premium/winter pkg
      '12 Savile Gray metallic S60 T5, Premium/Climate/BLIS/City Safety/rear spoiler
      '13 Seashell metallic XC60 T6, Platinum/Climate/BLIS/Polestar-tuned/IPD anti-sway bar
      '16 Seashell metallic S60 T5 AWD (replaced '17 S60)
      '13A DICE/VIDA, x's '93 850 GLT, '04 XC90, '17 S60 T5 (Totaled!)

    11. #9
      Junior Member
      Join Date
      Oct 2018
      Posts
      80
      I can confirm it does work. Yesterday I had the BMS reset with Vida. Today using the car scanner pro app the number of days since reset was 1. I went through the button sequence and got the battery light. Let it sit locked for 4 hours. Rechecked the app and it went back to zero.

      2015.5 xc60, 2.0L

    12. #10
      Junior Member
      Join Date
      Jan 2019
      Location
      North Carolina, USA
      Posts
      140
      Quote Originally Posted by VovoXC60 View Post
      I can confirm it does work. Yesterday I had the BMS reset with Vida. Today using the car scanner pro app the number of days since reset was 1. I went through the button sequence and got the battery light. Let it sit locked for 4 hours. Rechecked the app and it went back to zero.

      2015.5 xc60, 2.0L
      I was going to check it myself, but my battery appears to be original to the car and the BMS hasn't been reset in 1731 days. So I don't really want to reset the BMS at this point unless I am actually putting in a new battery.

      Also, the Car Scanner app is awesome. Sooooo much data! When you go to All Sensors, there is over 200 values to scroll through. I can't recommend it enough for your average DIY mechanic.

    13. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Replies: 18
      Last Post: 01-04-2018, 07:48 PM
    2. Replies: 32
      Last Post: 06-05-2017, 02:08 PM
    3. November Software Update - additional software
      By lamme27 in forum XC90 (SPA: 2016 - )
      Replies: 23
      Last Post: 03-03-2016, 10:45 AM
    4. '11 S60 sound system specs, non-premium, worth upgrading/replacing?
      By hu8bert in forum S60, S60CC & V60, V60CC (2011-2018)
      Replies: 5
      Last Post: 12-12-2011, 10:50 PM
    5. Upgrading 850 GLT to 850 Turbo specs
      By twc in forum 850 (1993-1997)
      Replies: 10
      Last Post: 11-18-2002, 03:16 AM