2019 XC90 strange heater behavior
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 7 of 7
    1. #1
      Junior Member
      Join Date
      Jan 2015
      Posts
      8

      2019 XC90 strange heater behavior

      Hi, my 19 xc90 inscription shows some strange heater behavior.

      When the weather is cold, and I set the climate to auto/72°F/AC off, the air coming out of the vent does not seem to be hot if I start my car after a long parking. However, if I stop and restart it without changing any climate settings, the vent starts blow hot air. Is this normal? Thanks.

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member Heimdall's Avatar
      Join Date
      Jan 2018
      Posts
      831

      2019 XC90 strange heater behavior

      Seems the auto sensors are off or something
      Last edited by Heimdall; 02-09-2020 at 01:47 AM.

    4. #3
      Junior Member
      Join Date
      Sep 2012
      Posts
      164
      Quote Originally Posted by aday View Post
      Hi, my 19 xc90 inscription shows some strange heater behavior.

      When the weather is cold, and I set the climate to auto/72°F/AC off, the air coming out of the vent does not seem to be hot if I start my car after a long parking. However, if I stop and restart it without changing any climate settings, the vent starts blow hot air. Is this normal? Thanks.
      It takes time for your engine to warm up?

      The hvac is intelligent and doesn't start blowing air faster until the engine is warm enough to heat said air.

      Also, if left in fully auto mode, it will almost never blow hot air directly out the front facing vents. It prefers the windshield vents and foot vents. Not the face vents.

      In warm weather, this behavior is reversed.
      2018 XC 60 | T6 AWD P* | Momentum | Onyx Black/Amber | Convenience/Vision/Advanced/Nav/Cold Weather

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Member partridge's Avatar
      Join Date
      Mar 2005
      Location
      Maryland
      Posts
      1,515
      Quote Originally Posted by aday View Post
      Hi, my 19 xc90 inscription shows some strange heater behavior.

      When the weather is cold, and I set the climate to auto/72°F/AC off, the air coming out of the vent does not seem to be hot if I start my car after a long parking. However, if I stop and restart it without changing any climate settings, the vent starts blow hot air. Is this normal? Thanks.
      Do you have a T6 or T 8?



      Sent from my iPhone using Tapatalk
      Current:
      Linnéa: 2017 Osmium Grey XC90 T8 R-Design Vision/Climate/Conv/Air/B&W/Booster
      Deceased:
      Inga: 2004 Titanium Gray/Gobi S60R - Navigation, ipd tune, hood vent, rear window spoiler
      Astrid: 2015.5 Sapphire Black/Nubuck XC60 T6 AWD R-Design Platinum BLIS Climate Polestar

    7. #5
      Junior Member
      Join Date
      Jan 2015
      Posts
      8
      Quote Originally Posted by Heimdall View Post
      Seems the auto sensors are off or something
      Thanks, but I doubt about this, if sensors are off it should never work no matter restart or not.

    8. #6
      Junior Member
      Join Date
      Jan 2015
      Posts
      8
      Quote Originally Posted by partridge View Post
      Do you have a T6 or T 8?



      Sent from my iPhone using Tapatalk
      T6, sorry I forgot to mention it.

    9. #7
      Junior Member
      Join Date
      Jan 2015
      Posts
      8
      Quote Originally Posted by shammyh View Post
      It takes time for your engine to warm up?

      The hvac is intelligent and doesn't start blowing air faster until the engine is warm enough to heat said air.

      Also, if left in fully auto mode, it will almost never blow hot air directly out the front facing vents. It prefers the windshield vents and foot vents. Not the face vents.

      In warm weather, this behavior is reversed.

      Thanks for this information. Sounds reasonable. I will experiment with manual control of air direction.

      Another question, if outside temperature is at 50F and I set temperature to 65F - 72F, does the heater work? In my old 05 S80T6, I have to set temperature to be above 72F in order to have the hot air.

    10. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Strange AC behavior 2019 S60 T6 Inscription
      By ljjones in forum S60 & V60, V60CC (SPA: 2019- )
      Replies: 15
      Last Post: 08-14-2019, 03:52 PM
    2. Help with strange HU-650 behavior
      By obt in forum Car Audio, Video & Mobile Electronics Forum
      Replies: 4
      Last Post: 04-03-2009, 09:05 AM
    3. Strange noise and behavior
      By chrjen in forum S70, V70 & V70XC (1998-2000)
      Replies: 0
      Last Post: 07-31-2008, 10:16 AM
    4. R displays strange behavior during stressed driving.
      By stevectsai in forum R Forum (2004-2007)
      Replies: 5
      Last Post: 10-17-2005, 03:12 PM
    5. I did jinx myself! (strange fuel gauge behavior)
      By k2 in forum R Forum (2004-2007)
      Replies: 0
      Last Post: 08-02-2004, 09:00 AM