Navigation rebooting XC-60 2017
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 8 of 8
    1. #1
      Junior Member
      Join Date
      Mar 2017
      Location
      Asheville, NC
      Posts
      56

      Navigation rebooting XC-60 2017

      This afternoon, my navigation rebooted twice in 8 miles. The first time, it just went to the Volvo emblem on the screen and within a few seconds, the navigation showed. The second time, the screen went to the Volvo emblem and then said "Navigation Starting Up" and it came back on fine. We aren't doing an update or anything. Nothing changed since yesterday that I could tell. Any idea of what is going on?

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member scottvh's Avatar
      Join Date
      Jan 2016
      Location
      Central KY
      Posts
      22
      My Wife’s 2017 XC60 started exhibiting this same behavior yesterday as well. Interested to see what info there is on this situation.
      2017 Magic Blue XC60 T5 (hers)
      2016 Magic Blue S60 T6 (his)
      2012 Flamenco Red S60 T5 (sold)

    4. #3
      Junior Member
      Join Date
      Nov 2013
      Location
      NE Ohio
      Posts
      44
      Same thing happened to my wife in our 2016 XC60 today. Daylight Saving Time bug?
      Current:
      2016 XC60 T6 Drive-E AWD w/Polestar / Platinum + BLIS + Climate - Magic Blue Metallic / Light Tan
      2015.5 V60 T5 Drive E w/Polestar / Platinum + BLIS + Climate - Savile Gray / Off Black
      Past: 2014 S60 T5 AWD Platinum Sport - Gray / Off-Black

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Member
      Join Date
      Aug 2017
      Location
      United States
      Posts
      3,423
      Should be fixed. There was an issue with P3s rebooting that Volvo says should be resolved.

    7. #5
      Junior Member
      Join Date
      Aug 2018
      Posts
      64
      Same thing happened a bunch of times today. Is it supposed to resolve on its own?

    8. #6
      Member
      Join Date
      Aug 2017
      Location
      United States
      Posts
      3,423
      It should already be resolved.

    9. #7
      Junior Member ExBimmerBoy's Avatar
      Join Date
      Sep 2008
      Location
      California
      Posts
      151
      me too!

    10. #8
      Junior Member ExBimmerBoy's Avatar
      Join Date
      Sep 2008
      Location
      California
      Posts
      151
      Looks like it was a signal from Sirius that was making things go hey wire.

    11. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Rebooting Sensus
      By jjd416 in forum XC90 (SPA: 2016 - )
      Replies: 34
      Last Post: 07-27-2018, 10:10 AM
    2. Sensus rebooting issue
      By markvn in forum XC90 (SPA: 2016 - )
      Replies: 12
      Last Post: 02-25-2018, 03:12 PM
    3. 2015 XC 60 T6 AWD vs 2015 XC 60 T6 Drive E
      By kkl97 in forum XC60 (2010 - 2017)
      Replies: 26
      Last Post: 09-07-2016, 11:09 AM
    4. Sensus Rebooting
      By NickInLA in forum XC90 (SPA: 2016 - )
      Replies: 65
      Last Post: 05-01-2016, 08:27 AM
    5. Replies: 37
      Last Post: 08-24-2015, 04:20 PM