RPM sensor part number for M56
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 9 of 9
    1. #1
      Junior Member
      Join Date
      Aug 2016
      Posts
      416

      RPM sensor part number for M56

      I am getting codes for RPM sensor, dash displays reduced engine performance and it cranks longer than normal before starting. Also my tach bounces while cranking. Anyone know the part number for replacement RPM sensor for manual transmission cars? 2002 V70.

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Apr 2007
      Location
      Nashville
      Posts
      537
      You need a new starter, not the RPM sensor. The RPM sensor wires run behind the starter and as the starter wears it draws more current during cranking which causes the tach needles to jump and in some cases store RPM sensor codes.
      04 V70R Flash Green/Atacama6MT

    4. #3
      Junior Member jrach's Avatar
      Join Date
      Sep 2017
      Location
      Franklin, Ma
      Posts
      177
      Quote Originally Posted by Ihatespeedbumps View Post
      You need a new starter, not the RPM sensor. The RPM sensor wires run behind the starter and as the starter wears it draws more current during cranking which causes the tach needles to jump and in some cases store RPM sensor codes.
      Are you sure? I know for a fact that bouncing tach while cranking is indicative of a bad crank sensor.

      Sent from my Pixel XL using Tapatalk
      2002 V70 T5M 019 Black Stone on Black Slicktop 159k (IPD Poly torque mounts, IPD Black Boost gauge, Spacers 12mm Front 20mm Rear, 18" Rose Bronze Pegs)
      2005 V70 T5M M66 019 Black Stone on Black 240k (Four-C, Premium Audio, Oem Subwoofer, R Brembos with Stoptech rotors, Gates RPM Kevlar T-Belt, Spacers 12mm Front 20mm Rear, IPD Catback with chickenwire mod, Snaab 3" catless DP)
      2006 S60R Sapphire Black Nordkap M66 149k Stock
      2004 S60R M66 Electric silver metallic - Nordkap 215K (Ipd Poly torque mounts, Xemodex Cem) SOLD

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Jan 2013
      Location
      Champaign, IL
      Posts
      101
      https://www.fcpeuro.com/products/vol...713485#fitment

      If you are junkyarding, they changed in '02. You have to get an '02 up. The '99-'01's are different.

    7. #5
      Junior Member
      Join Date
      Aug 2016
      Posts
      416
      Do automatic cars use same crank sensor as manual? I am actually running 2001 sensor right now since that's what came on my manual donor car.

    8. #6
      Junior Member
      Join Date
      Apr 2007
      Location
      Nashville
      Posts
      537
      Quote Originally Posted by jrach View Post
      Are you sure? I know for a fact that bouncing tach while cranking is indicative of a bad crank sensor.

      Sent from my Pixel XL using Tapatalk
      Fixed more than I can count with bouncing tach's and RPM sensor codes by replacing the starter.
      04 V70R Flash Green/Atacama6MT

    9. #7
      Junior Member
      Join Date
      Jan 2013
      Location
      Champaign, IL
      Posts
      101
      Quote Originally Posted by Canadian Moose View Post
      Do automatic cars use same crank sensor as manual? I am actually running 2001 sensor right now since that's what came on my manual donor car.
      Well, I'll have to look in Dice tomorrow. My spare for my '01 came from an automatic and they physically look the same. The '02 up ones are completely different and I assumed they interchanged as well. They don't have a pigtail like the early ones so I just assumed the plug won't fit into the electrical connection.

      Does yours have a pigtail?

    10. #8
      Junior Member
      Join Date
      Aug 2016
      Posts
      416
      The 01' has a pigtail, 02' didn't but plugs are the same.

    11. #9
      Junior Member
      Join Date
      Aug 2016
      Posts
      416
      Replaced the starter this morning. Made no difference. Still looking at the RPM sensor.

    12. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Replies: 15
      Last Post: 02-04-2019, 08:01 PM
    2. Help needed~RPM fluctuating at low RPM after modification
      By jeang2000 in forum General FWD & AWD
      Replies: 0
      Last Post: 03-26-2017, 10:03 AM
    3. Replies: 7
      Last Post: 03-05-2011, 12:54 PM
    4. Cross referencing part number of MAF sensor...
      By chinaonnitrous1 in forum R Forum (2004-2007)
      Replies: 5
      Last Post: 04-30-2009, 11:27 PM
    5. R fuel pressure sensor Bosch part number
      By tecam in forum R Forum (2004-2007)
      Replies: 0
      Last Post: 06-01-2008, 04:32 PM