Trailer wiring
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 6 of 6

    Thread: Trailer wiring

    1. #1
      Junior Member
      Join Date
      Oct 2018
      Location
      McAllen, TX
      Posts
      49

      Trailer wiring

      Hi all, I will be installing an aftermarket 4 pin wiring harness and was curious if anyone that has done this, if you ran the power line all the way to the front to the battery or if you plugged into a fuse box in the cargo area.
      2010 S80 3.2 - 189000 miles
      2015.5 XC60 T5 AWD - 54000 miles

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Aug 2016
      Location
      Quincy, MA
      Posts
      242
      Quote Originally Posted by ATucker View Post
      Hi all, I will be installing an aftermarket 4 pin wiring harness and was curious if anyone that has done this, if you ran the power line all the way to the front to the battery or if you plugged into a fuse box in the cargo area.
      I have done this both ways in my XC60 and V60. In the XC60 I ran a line to the front battery and that works fine, but it’s more work. In the V60 I tapped into the fuse box in the back and that was a lot less work. That’s what I’d recommend.
      2013 XC60 T6
      2015 V60CC T5

    4. #3
      Junior Member BellevilleV70's Avatar
      Join Date
      Mar 2006
      Location
      Belleville,Ontario
      Posts
      713
      I hooked my up in back, and its worked great for thousands of towing miles
      2002 V70 2.4T - EST exhaust/Elbrus 18x8s/Conti DW/Eibach/Koni FSD/Polk Audio/Boston Acoustics/Infinity -beater duty now
      2013 XC60 T6R-design- IPD exhaust- Ice White
      2015.5 V60 Polestar- Black- do88/TDI/GFB/APATuned DownPipe/AirBox Mods/Elevate rear bar [email protected] mph
      Mopar Tech

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Oct 2018
      Location
      McAllen, TX
      Posts
      49
      For the install in the back, did you just use one of those add a circuits? Also, do you happen to recall which fuse you tapped into?
      2010 S80 3.2 - 189000 miles
      2015.5 XC60 T5 AWD - 54000 miles

    7. #5
      Junior Member BellevilleV70's Avatar
      Join Date
      Mar 2006
      Location
      Belleville,Ontario
      Posts
      713
      In the right lower side of the rear fuse box, there is a spot for a fuse that isn't used on mine....added a fuse holder to trailer wiring hot lead, and pluged spade connector on hot spade
      2002 V70 2.4T - EST exhaust/Elbrus 18x8s/Conti DW/Eibach/Koni FSD/Polk Audio/Boston Acoustics/Infinity -beater duty now
      2013 XC60 T6R-design- IPD exhaust- Ice White
      2015.5 V60 Polestar- Black- do88/TDI/GFB/APATuned DownPipe/AirBox Mods/Elevate rear bar [email protected] mph
      Mopar Tech

    8. #6
      Junior Member
      Join Date
      Aug 2016
      Location
      Quincy, MA
      Posts
      242
      For mine I just used a tap-a-fuse for the same one as the 12v in the rear. Though this means I'm not able to securely close the fuse cover now.
      2013 XC60 T6
      2015 V60CC T5

    9. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. S60 trailer hitch wiring
      By trondp in forum S60 (2001-2010)
      Replies: 0
      Last Post: 05-29-2010, 06:15 PM
    2. Trailer Hitch and/or Wiring for 04 XC90
      By Andre G in forum Want Ads
      Replies: 1
      Last Post: 05-19-2010, 06:32 PM
    3. Wiring for Trailer Hitch
      By gr8tires in forum V70 & V70XC & XC70 (2001-2007)
      Replies: 0
      Last Post: 03-20-2010, 09:45 AM