Carplay2air-connecting help?
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Results 1 to 6 of 6
    1. #1

      Carplay2air-connecting help?

      Just got the Carplay2Air adapter and having trouble getting it to display on the Sensus Any advice from those of you that have one?

      The instructions are to disconnect all connected phones, and also to shut off any other Bluetooth or WiFi connections on the phone. Then to plug the device into the CarPlay usb. The screen is then to pop up with the Carplay2air interface.

      Unfortunately it never pops up for me.

      Any suggestions? I‘m not using the car as a WiFi hotspot but wondered if I need to shut off the car modem?
      2020 XC60 T5 AWD Inscription with Advanced and Luxury package in Denim Blue with Blond interior

    2. Remove Advertisements

      Advertisements
       

    3. #2
      VOC / Connectivity Expert
      Join Date
      Mar 2017
      Posts
      438
      Quote Originally Posted by Blackjackmark View Post
      Just got the Carplay2Air adapter and having trouble getting it to display on the Sensus Any advice from those of you that have one?

      The instructions are to disconnect all connected phones, and also to shut off any other Bluetooth or WiFi connections on the phone. Then to plug the device into the CarPlay usb. The screen is then to pop up with the Carplay2air interface.

      Unfortunately it never pops up for me.

      Any suggestions? I‘m not using the car as a WiFi hotspot but wondered if I need to shut off the car modem?
      I've never used it, but does regular CarPlay work for you?
      Any comments made are of my own opinion and not that of my employer!

    4. #3
      Quote Originally Posted by WhoaVolvo View Post
      I've never used it, but does regular CarPlay work for you?
      Yes it does, and the Carplay2air works as well, and worked in my Volvo. I just had to get a different one due to a bad wire. I’ve never had to set it up through the Volvo. I had it configured Through my previous car and just plugged it into the Volvo and it worked just fine. .
      2020 XC60 T5 AWD Inscription with Advanced and Luxury package in Denim Blue with Blond interior

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Sep 2019
      Posts
      206

      Carplay2air-connecting help?

      Quote Originally Posted by Blackjackmark View Post
      Just got the Carplay2Air adapter and having trouble getting it to display on the Sensus Any advice from those of you that have one?

      The instructions are to disconnect all connected phones, and also to shut off any other Bluetooth or WiFi connections on the phone. Then to plug the device into the CarPlay usb. The screen is then to pop up with the Carplay2air interface.

      Unfortunately it never pops up for me.

      Any suggestions? I‘m not using the car as a WiFi hotspot but wondered if I need to shut off the car modem?
      I have it and it works as expected. The carplay interface comes up, you pair Bluetooth to is then it switches to WiFi. It may be worth noting that the CarPlay 2 has limitations and getting the newer Carlinkit with USB C would have been a better call. I swapped mine out for the USBC version.

      Have you told the left side sensus screen to use carplay? You need that enabled in the interface.

    7. #5
      Quote Originally Posted by D3ggy View Post
      I have it and it works as expected. The carplay interface comes up, you pair Bluetooth to is then it switches to WiFi. It may be worth noting that the CarPlay 2 has limitations and getting the newer Carlinkit with USB C would have been a better call. I swapped mine out for the USBC version.

      That's just it..for me the CarPlay interface never displays on the Sensus screen

      Quote Originally Posted by D3ggy View Post
      It may be worth noting that the CarPlay 2 has limitations and getting the newer Carlinkit with USB C would have been a better call. I swapped mine out for the USBC version.
      I have an iPhone so USB-C is a non-issue for me

      Quote Originally Posted by D3ggy View Post
      Have you told the left side sensus screen to use carplay? You need that enabled in the interface.
      I have no understanding of what you're suggesting. I've swiped from right to left to see where the CarPlay icon is normally found, but it isn't even there. Only the "Bluetooth" and "iPod" icon is grayed out. Not familiar with any CarPlay settings on the left Sensus screen? Regardless, CarPlay is enabled and does work hardwired, so I don't think that's the issue?
      2020 XC60 T5 AWD Inscription with Advanced and Luxury package in Denim Blue with Blond interior

    8. #6
      Junior Member
      Join Date
      Sep 2019
      Location
      So Cal, USA
      Posts
      350
      OP, FYI there are also other threads on this same subject you may want to explore. Also, if you've not been there yet, check out https://carplay2air.com/#home-faq as it has instructions how to perform updates, etc to the adapter -- be sure you're current.

      For me, with a 2020 XC60 T8 and iPhone 11 Pro... I've had a CarPlay2air adapter since I took delivery 6+ months ago. Most of the time all works as it should... But occasionally I have the issue that you may be -- after a few moments, Sensus display indicates for things like phone that they are being driven by CarPlay and integrated Nav is operational (all that is good), but the area where media display would be becomes blank with no CarPlay info. In that situation, I've found a couple of things:

      • The problem generally happens when I'm getting in the car, Sensus/CarPlay are initializing, and I believe something happens with the timing when I then turn on the car itself... I have not figured-out the exact sequence yet, but am convinced there is something to this... but if I let CarPlay completely initialize before turning on the car, or get the car turned-on before the adapter starts it's bluetooth then wireless connection thing, I don't have the issue.
      • When I have the problem, I reach down and unplug/replug the CarPlay2air adapter from the USB port (be sure of course you're in the proper slot with the white mark -- the other one will NOT work, ever). Within a few seconds Sensus seems to recognize what I did and goes back through the initialization process. I'd say 90-95% of the time, all connects as it should after that.
      • There are times when the unplug/replug trick still does not work. My impression is those failures are related to my iPhone itself having received a message or notification of some sort that is interfering with the way the CarPlay2air adapter is trying to hijack things... I don't fool with my phone while driving, so when I'm stuck with no CarPlay, I wait until I pull over, clear notifications, and magically all seems to connect as it should the next time I get going...
      • I have also found a few times that if I keep my iPhone in my right pocket where it normally is while I'm driving, connections can become problematic -- I suspect there is something about low Bluetooth reception in that area due to the seat belt or other equipment. I don't have the same connection problems when the phone is out and on my wireless charger on top of the center console.


      CarPlay2air is not perfect, but I still use it 100% of the time, even with the spurious failures. There has not been an update to the adapter firmware in quite a long time -- likely because developers are all in China. Hopefully some of my hints and tips help you -- otherwise, I'd suggest you return it while it's under warranty just in case you do have a hardware problem. I doubt very much though the issue is with Volvo -- after all, CarPlay2air and it's competitors are hacked devices that try to get around different car mfgr limitations... it's really up to the CarPlay2air developers to keep up with Apple and all the auto mfgr changes to keep their hack working -- unfortunately, COVID-19 seems to have slowed all they were doing in that regard. GOOD LUCK!
      Bert

      Present: ‘20 XC60 T8 Inscription
      Past: ‘15 Tesla S90D; ‘14 SLK250; '13 RX450h; ‘09 335i; ‘06 RX400h; ‘02 SC430; ‘99 RX300; ‘95 SC300; ‘91 Legend...

    9. Remove Advertisements

      Advertisements
       

    Similar Threads

    1. Wired to Wireless CarPlay Adapter CarPlay2Air
      By raeldor in forum XC60 (SPA: 2018- )
      Replies: 115
      Last Post: 05-30-2020, 12:22 PM
    2. Help connecting a subwoofer to factory sound system
      By ckracer76 in forum S80 (1998-2006)
      Replies: 3
      Last Post: 08-16-2018, 12:11 PM
    3. Dice not connecting to Vida help!
      By MFs60r in forum R Forum (2004-2007)
      Replies: 12
      Last Post: 08-04-2017, 05:56 PM
    4. Volvo DiCE problem connecting, HELP!!!!
      By bgainey in forum XC90 (2003 - 2014)
      Replies: 7
      Last Post: 09-05-2013, 10:46 AM