Some Questions about BLP 990
Username
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Page 1 of 2 1 2 LastLast
    Results 1 to 35 of 37
    1. #1
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54

      Some Questions about BLP 990

      Reference: https://www.bluepower.se/en/product/...ndroid-71.html

      Hi, wondering if anyone ever used the BLP 990 before. They're not responding to any of my emails so I'm not sure where else to ask but here.

      1. They seems to pump up the price with a ridiculous 90euros just for android auto support. Can't I just install this myself via the play store or is there more involved?
      2. How does it handle long term use? Does the screen get screen burn or faded over time?
      3. Bootup time since you started the car?
      4. How is their reverse camera? I couldn't find any videos with the BLP 990 hooked up to their reverse camera but it does seem like I can just hook up any other reverse camera.

      I've been planning on doing this for months but I seem to be struggling to make a decision with such a large price. Is it worth it? I drive long distances and using my phone on a mount is horrible with a FM transmitter. There are plenty of videos out there on how to install this so I'm not bothered with the install process.
      2006 V50 2.4i FWD

    2. Remove Advertisements

      Advertisements
       

    3. #2
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Get a GROM. If they're not responding to your emails now, they won't respond after you've paid them the $600 or whatever it is and have a problem. I've heard nothing but bad stuff about bluepower

    4. #3
      Junior Member Sysyphus61's Avatar
      Join Date
      Dec 2016
      Location
      Suburban Philadelphia
      Posts
      759
      Have one. Can’t recommend it.
      2009 C70 T5, Celestial Blue 130k
      2011 S60 T6 AWD Caspian Blue

    5. Remove Advertisements
      SwedeSpeed.com
      Advertisements
       

    6. #4
      Junior Member
      Join Date
      Feb 2018
      Location
      PNW
      Posts
      48
      Quote Originally Posted by Sysyphus61 View Post
      Have one. Can’t recommend it.
      +1 On this!! I have a love hate relationship with mine. It constantly has issues where the screen won't turn on, and I have to turn the car off and back on to get it to come on. The only plus is the backup camera. The android auto requires a dongle and that has it's own plethora of issues.

      The sound quality is good and it's awesome that it's all integrated, but the screen is just okay and by no means anything special.

    7. #5
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by V50unicorn View Post
      +1 On this!! I have a love hate relationship with mine. It constantly has issues where the screen won't turn on, and I have to turn the car off and back on to get it to come on. The only plus is the backup camera. The android auto requires a dongle and that has it's own plethora of issues.

      The sound quality is good and it's awesome that it's all integrated, but the screen is just okay and by no means anything special.
      Are you using the Android one or the original one?
      2006 V50 2.4i FWD

    8. #6
      Junior Member
      Join Date
      Feb 2018
      Location
      PNW
      Posts
      48
      Quote Originally Posted by Adriaan View Post
      Are you using the Android one or the original one?
      The Android version.

    9. #7
      Junior Member Sysyphus61's Avatar
      Join Date
      Dec 2016
      Location
      Suburban Philadelphia
      Posts
      759
      Had the original, then was stupid enough to believe that the Android one would be better... it’s a shame, the idea is good but the execution is definitely lacking... you’re basically getting a cheap and nasty small Android tablet and a wiring harness... after sale technical and customer support is essentially non-existent
      2009 C70 T5, Celestial Blue 130k
      2011 S60 T6 AWD Caspian Blue

    10. #8
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      I also seem to be only finding bad stuff about them. Grom I'm starting to think of getting a grom. Do you now of the steeringwheel buttons work with a grom?
      2006 V50 2.4i FWD

    11. #9
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by Sysyphus61 View Post
      Had the original, then was stupid enough to believe that the Android one would be better... it’s a shame, the idea is good but the execution is definitely lacking... you’re basically getting a cheap and nasty small Android tablet and a wiring harness... after sale technical and customer support is essentially non-existent
      Thanks for all the information. I'm ditching the idea of bluepower now. Cant understand why the price is so high for so much negative reviews.
      2006 V50 2.4i FWD

    12. #10
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      They do if you're using Bluetooth. Be warned the Bluetooth audio quality isn't as high as the line-in though. I had some connectivity issues with it as well, ended up just going with line-in for everything and ditching Bluetooth

    13. #11
      Junior Member
      Join Date
      Jun 2017
      Location
      USA
      Posts
      305
      I’m assuming your car doesn’t have an aux. If it has an aux or the factory USB, I’d leave it be. If it doesn’t, I’d definitely say get a GROM. Bluepower is massively overpriced for what it is. They know they’re the only real option for the every day garage warrior and they charge like it.
      Barents Blue Metallic S40 T5 AWD M66 Manual

    14. #12
      Junior Member
      Join Date
      Oct 2019
      Posts
      24
      In the V50 groups on FB there is a guy who sells a ~£50 Bluetooth adapter that plugs in inside the cd player. It doesn't replace the cd player, but overrides it if is recieving bt input, so the cd player also still remains functional unlike with the Grom.

      Sent from my CLT-L29 using Tapatalk

    15. #13
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Quote Originally Posted by woowar View Post
      In the V50 groups on FB there is a guy who sells a ~£50 Bluetooth adapter that plugs in inside the cd player. It doesn't replace the cd player, but overrides it if is recieving bt input, so the cd player also still remains functional unlike with the Grom.

      Sent from my CLT-L29 using Tapatalk
      You know I've seen that guy, anyone have any actual experience with that product?

      He says it supports aptX, which would be a big step up from the GROM bluetooth. I've also noticed that even with GROM line-in the signal isn't super-clean. Hard to tell if it's a GROM issue or what
      Last edited by muppetman342; 08-30-2020 at 08:42 AM.

    16. #14
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by woowar View Post
      In the V50 groups on FB there is a guy who sells a ~£50 Bluetooth adapter that plugs in inside the cd player. It doesn't replace the cd player, but overrides it if is recieving bt input, so the cd player also still remains functional unlike with the Grom.

      Sent from my CLT-L29 using Tapatalk
      Mind linking that?
      2006 V50 2.4i FWD

    17. #15
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Quote Originally Posted by Adriaan View Post
      Mind linking that?
      https://www.facebook.com/groups/8403...02948759734122

    18. #16
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      I just ordered a GROM MST4. Thanks to everyone for the information and help. You saved me a lot of time and money.
      2006 V50 2.4i FWD

    19. #17
      I am going to order one from that dude with the CD mod and try it out.

      We shall see how it goes.
      2006 Volvo S40 AWD T5 M66 - Dusty Rusty
      2012 Subaru Outback 2.5i CVT - Slowmobile - CAI only, Powerstop Rotors+Pads.
      1996 HD Electra Glide - Big Bertha - 10:1 Wisecos; EV13 Cam: Ultima Digital Ignition; Buell Head Conversion; E85 Carb Tuned;

    20. #18
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Quote Originally Posted by avenger09123 View Post
      I am going to order one from that dude with the CD mod and try it out.

      We shall see how it goes.
      Real curious to hear about it, please report back!

    21. #19
      Junior Member
      Join Date
      Oct 2019
      Posts
      24
      Quote Originally Posted by muppetman342 View Post
      Real curious to hear about it, please report back!
      Several people on the group have ordered one and say it works well. My only issue with it is you can't use steering wheel controls to skip track. In the Swedish V50 FB group there are two guys who have developed their own adapter which also connects to the cd player in a similar way, and has an additional module for steering wheel controls, but they are charging almost 3x the price.

      Sent from my CLT-L29 using Tapatalk

    22. #20
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      I got my GROM MST4 today. Took the whole day to install since I wanted to do it perfectly and into the dashboard. I got a bluetooth module and aux + charging. It's all inside of the dash and the cables are long and nicely tucked behind the waterfall console. The sound is great and tomorrow I will give it a real test on the highway.

      When I first tested it didn't want to work. It didn't want to change modes or do anything but just say Track 1. I resolved this by installing their latest firmware. They claim that it's up to date when shipped but I doubt it was since I had to do it to get it working
      2006 V50 2.4i FWD

    23. #21
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Interesting on the firmware. Especially considering their last update looks like it's from 2015 🤔 Hard to believe they've had one sitting around that long

    24. #22
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by muppetman342 View Post
      Interesting on the firmware. Especially considering their last update looks like it's from 2015 Hard to believe they've had one sitting around that long
      The firmware I got was from last year. https://gromaudio.com/software-mst4.html

      I chose the v50 one with a single CD. July 2019
      2006 V50 2.4i FWD

    25. #23
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Lol well if you navigate to the firmware page from the mst4 product page, it apparently sends you to: https://gromaudio.com/software-mst3.html

      I was duped

    26. #24
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by muppetman342 View Post
      Lol well if you navigate to the firmware page from the mst4 product page, it apparently sends you to: https://gromaudio.com/software-mst3.html

      I was duped
      Oh well. Now you can get the latest firmware. If you scroll to the very bottom of the website where the footer is you'll see there's a firmware link. Click there and then chose your product.
      2006 V50 2.4i FWD

    27. #25
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Quote Originally Posted by Adriaan View Post
      Oh well. Now you can get the latest firmware. If you scroll to the very bottom of the website where the footer is you'll see there's a firmware link. Click there and then chose your product.
      I wonder if updating the firmware will fix the audio quality issue I've been having. I get this weird peaking/distortion on certain frequencies. I can't discern if it's the speakers or what.

    28. #26
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by muppetman342 View Post
      I wonder if updating the firmware will fix the audio quality issue I've been having. I get this weird peaking/distortion on certain frequencies. I can't discern if it's the speakers or what.
      When I was using a fm transmitter or CDs I discovered the sound to be horrible and scratchy. Also thought it was the speakers. After I got the GROM to work with the latest firmware I honestly can't believe the sound system. I have the stock sound system with speakers but it sounds like some aftermarket stuff with sub. You can't lose anything by upgrading the firmware. Just follow the instructions and make sure you have at least one folder with at least one song in that folder on the USB.
      2006 V50 2.4i FWD

    29. #27
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by muppetman342 View Post
      I wonder if updating the firmware will fix the audio quality issue I've been having. I get this weird peaking/distortion on certain frequencies. I can't discern if it's the speakers or what.
      I'm a bit curious if you ended up upgrading the firmware and if it improved the sound quality?
      2006 V50 2.4i FWD

    30. #28
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Quote Originally Posted by Adriaan View Post
      I'm a bit curious if you ended up upgrading the firmware and if it improved the sound quality?
      Not yet. May try this weekend.

    31. #29
      Junior Member Adriaan's Avatar
      Join Date
      Jul 2020
      Location
      South Africa
      Posts
      54
      Quote Originally Posted by muppetman342 View Post
      Not yet. May try this weekend.
      Let me know took me less than a minute to do it.
      2006 V50 2.4i FWD

    32. #30
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Quote Originally Posted by Adriaan View Post
      Let me know took me less than a minute to do it.
      Process is weird, who knows if it even updated :shrug: Didn't make audio any better, but also didn't break anything.

    33. #31
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      In my ongoing quest to get better audio I picked a couple songs that I knew created the weird sound artifacts I'd been getting from the GROM, swapped the CD player back into the loop, and listened to those songs through the CD player instead...

      No artifacts. So the GROM is introducing noise into the system it appears.

      Avenger, you ever get that bluetooth dingy?

      I found this swedish thread suggesting the ICM and IAM from a 2007 P1 may be able to add "native" aux to the car. I may give that a go and see if it works.

      https://www.jagrullar.se/forum/viewt...ilit=Bluetooth

    34. #32
      Quote Originally Posted by muppetman342 View Post
      In my ongoing quest to get better audio I picked a couple songs that I knew created the weird sound artifacts I'd been getting from the GROM, swapped the CD player back into the loop, and listened to those songs through the CD player instead...

      No artifacts. So the GROM is introducing noise into the system it appears.

      Avenger, you ever get that bluetooth dingy?

      I found this swedish thread suggesting the ICM and IAM from a 2007 P1 may be able to add "native" aux to the car. I may give that a go and see if it works.

      https://www.jagrullar.se/forum/viewt...ilit=Bluetooth
      I bought that harness from Aliexpress. I can confirm my bluetooth did connect, but it never produced any audio on my P1, and it certainly doesn't enable AUX since that is a software update. After 2 months of advertising on here to give it to someone to test on a P2 to add to bluetooth and no one wanting to try, I put it away.
      2006 Volvo S40 AWD T5 M66 - Dusty Rusty
      2012 Subaru Outback 2.5i CVT - Slowmobile - CAI only, Powerstop Rotors+Pads.
      1996 HD Electra Glide - Big Bertha - 10:1 Wisecos; EV13 Cam: Ultima Digital Ignition; Buell Head Conversion; E85 Carb Tuned;

    35. #33
      Junior Member
      Join Date
      Mar 2012
      Location
      Charlottesville VA
      Posts
      234
      Quote Originally Posted by avenger09123 View Post
      I bought that harness from Aliexpress. I can confirm my bluetooth did connect, but it never produced any audio on my P1, and it certainly doesn't enable AUX since that is a software update. After 2 months of advertising on here to give it to someone to test on a P2 to add to bluetooth and no one wanting to try, I put it away.
      Nah, I meant the CD mod board, but I guess not

    36. #34
      Member Body Massage's Avatar
      Join Date
      Aug 2008
      Location
      Bellingham, MA
      Posts
      3,603
      I had the BLP-840 or whatever in my R. Features were nice, sound quality over bluetooth was crap. I ended up using a iPod bluetooth adapter connected to the iPod cable to do BT with it.

      It's a good idea, but it's just lacking in the execution.
      2005 V70R

      2010 C30 R-Design

    37. #35
      Junior Member
      Join Date
      Jun 2017
      Location
      USA
      Posts
      305

      Some Questions about BLP 990

      Quote Originally Posted by woowar View Post
      Several people on the group have ordered one and say it works well. My only issue with it is you can't use steering wheel controls to skip track. In the Swedish V50 FB group there are two guys who have developed their own adapter which also connects to the cd player in a similar way, and has an additional module for steering wheel controls, but they are charging almost 3x the price.

      Sent from my CLT-L29 using Tapatalk
      The factory aux on my 2007 doesn’t work with the steering wheel buttons either so the OEM option isn’t any better in that respect. Factory aux also takes a wiring harness and software.

      Also all of you who want better audio, SOURCE MATERIAL IS THE FIRST STEP. Go with a high fidelity streaming service like Tidal.
      Last edited by Tarsas; 09-25-2020 at 01:13 PM.
      Barents Blue Metallic S40 T5 AWD M66 Manual

    38. Remove Advertisements

      Advertisements
       

    Page 1 of 2 1 2 LastLast

    Similar Threads

    1. Wanted: BLP-990 System
      By mamba42 in forum Want Ads
      Replies: 0
      Last Post: 03-08-2018, 09:55 AM
    2. BLP-990 stereo unit
      By clark0505 in forum S40 & V50 (2005-2012)
      Replies: 3
      Last Post: 11-08-2017, 03:11 PM
    3. Installation of BLP-990 Headunit Troubleshoot
      By lynxjava in forum Car Audio, Video & Mobile Electronics Forum
      Replies: 13
      Last Post: 11-03-2017, 05:19 PM
    4. BLP-990 Head Unit for 2004-07 P1 cars with Premium Sound
      By teXas in forum FWD & AWD Parts For Sale
      Replies: 7
      Last Post: 10-12-2017, 10:57 PM
    5. Bluepower BLP-990 - Anyone selling?
      By evy0311 in forum Want Ads
      Replies: 0
      Last Post: 02-11-2017, 08:13 PM